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Dear Reader,

Thank you for choosing Autodesk Maya 2014 Essentials. This book is part of a
family of premium-quality Sybex books, all of which are written by outstanding
authors who combine practical experience with a gift for teaching.

Sybex was founded in 1976. More than 30 years later, we're still committed to
producing consistently exceptional books. With each of our titles, we’re working
hard to set a new standard for the industry. From the paper we print on, to the
authors we work with, our goal is to bring you the best books available.

I hope you see all that reflected in these pages. I'd be very interested to hear
your comments and get your feedback on how we’re doing. Feel free to let me
know what you think about this or any other Sybex book by sending me an
email at nedde@wiley.com. If you think you’ve found a technical error in this
book, please visit http://sybex.custhelp.com. Customer feedback is critical to
our efforts at Sybex.

Best regards,
NEIL EDDE

Vice President and Publisher
Sybex, an Imprint of Wiley
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INTRODUCTION

Welcome to Autodesk® Maya® 2014 Essentials. Autodesk® Maya® soft-
ware is one of many 3D computer graphics (CG) packages available on the mar-
ket, and although it has many unique features, it shares one trait with every
other package out there: it’s very powerful and very complex. The goal of this
book is to walk you through some of the features of the software and familiarize
you with the tools Maya provides and how to use them.

Although nearly every chapter in this book provides a tutorial that covers a
particular facet of the software, the goal is not to show you how to do one single
procedure. In every case, the intent is to provide you with background and con-
text for the steps you're performing, so that you develop an understanding of
the procedure and its place within the overall CG workflow and can apply that
knowledge to all your future projects. In many cases, the tutorials provided
take you step by step through an entire process, ending with a specific result. In
other chapters, while there are still step-by-step instructions provided, it would
be impossible to take you through the entire procedure. In these cases, the
information presented is more conceptual and explains the “why” of what you're
doing, rather than the “what.”

With that end in mind, the tutorials in this book are designed to be com-
prehensive but as simple as possible to complete. Many books on CG provide
tutorials that are too complex, frustrating readers and leaving them with more
questions than answers. The results of the tutorials in this book may look
simple, but the process of completing them will give you a solid foundation in
creating CG imagery.

That said, you will probably make some mistakes along the way. That’s simply
part of the learning process. If it happens, just try again. After all, you don’t learn
to drive a car by hopping on the freeway or entering the Daytona 500—you start
out in a parking lot where there is lots of room for error. I tell my students that
if they have to redo a procedure, they’ll find that the second time around it’ll go
faster and the results will be better—and that has always been the case.

Who Should Read This Book

Anyone who wants to learn how to use Maya should start learning with this
book. The exercises are organized like a production would be, moving from
preproduction tasks (modeling, rigging) through production (animation),

www.LegendaryLibrary.Mihanblog.Com



Introduction

and finally postproduction (lighting, rendering, compositing). In addition to
mimicking the structure of a game or film production, the exercises here are
designed to expose you to the process of creating CG while being as easy to com-
plete as possible. Many books try to cram too much into their tutorials, confus-
ing and frustrating readers in the process. The goal of Aufodesk® Maya® 2014
FEssentials is to give you a solid foundation in the software so you can explore
the areas that most interest you in further detail.

What You Will Learn

This book covers the fundamentals of working in CG with Maya. It’s only a
starting point, though. As with any artistic pursuit, CG is a lifelong process of
learning. With what you learn in this book forming a solid foundation, you can
continue exploring all the complex, interesting facets of creating CG imagery.
And I promise you that by the end of this book, you’ll never watch a CG ani-
mated film or an effects-laden summer blockbuster the same way again.

What You Need

As with any CG software, Maya requires a significant amount of computing
power to run smoothly and efficiently. A good rule of thumb for Maya (or any
3D software) is to run it on a computer with the fastest processor, the most
RAM, and the best video card you can get your hands on. At a minimum,
you need 4 GB of RAM, 10 GB of hard drive space, and a qualified hardware-
accelerated OpenGL graphics card. Maya runs on Windows, Mac, and Linux
systems. For details on system specifications and qualified graphics cards, go
to http://www.autodesk.com/products/autodesk-maya/overview and click
on the System Requirements link.

FREE AUTODESK SOFTWARE FOR STUDENTS AND EDUCATORS

The Autodesk Education Community is an online resource with more than five
million members that enables educators and students to download—for free
(see website for terms and conditions)—the same software used by professionals
worldwide. You can also access additional tools and materials to help you design,
visualize, and simulate ideas. Connect with other learners to stay current with
the latest industry trends and get the most out of your designs. Get started today
atwww . autodesk.com/joinedu.

www.LegendaryLibrary.Mihanblog.Com

XVii

This book is a great
primer for Autodesk
Maya. If you're inter-
ested in taking the
Autodesk Certification
exams for Maya, go to
www. autodesk.com/
certification
forinformation and
resources.



Xviii

Introduction

What Is Covered in This Book

As mentioned earlier, the bulk of this book is organized like a production, with the
chapters proceeding through the process of creating and animating a character sim-
ilar to how that process would take place when developing a game or film project.

Chapter 1: Understanding the Maya Interface This chapter is a quick and
thorough introduction to the interface elements you’ll work with throughout
the rest of the book. It also serves as a great reference as you progress through
the exercises that follow.

Chapter 2: Creating Your First Animation This chapter provides a fun way
to get started exploring Maya. When you're finished, you’ll have a short anima-
tion of a bouncing ball that uses several Maya tools, as well as a number of prin-
ciples of animation.

Chapter 3: Modeling with Polygons, Part 1 This chapter starts your travels
through a production flow by having you rough out the overall shape of a char-
acter. You'll block in the basic shapes and begin the modeling process.

Chapter 4: Modeling with Polygons, Part 2 Building on what you did in the
previous chapter, in this chapter you’ll add details and continue the modeling
process, getting the majority of the character built.

Chapter 5: Modeling with Polygons, Part 3  Here you'll put the finishing
touches on your character, perform some cleanup tasks, and prepare the model
for rigging.

Chapter 6: Surfacing Your Character Laying out the UVs of your character
is a critical step in the production process that lets you use texture maps for
color and detail. This chapter shows you how to lay out UV maps and create tex-
tures and surface shaders.

Chapter 7: Getting Bent Out of Shape: Blend Shapes Facial expressions are
at the heart of every good piece of character animation. In this chapter, you'll
create deformers that allow you to create facial expressions on your character.

Chapter 8: Dem Bones: Setting Up Your Joint System Character models
require joint systems that allow you to pose the model. This chapter walks you
through the process of building a skeleton that will create the overall body
deformations necessary to animate your character.
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Chapter 9: Weighting Your Joints  This chapter describes and demonstrates
the process of joint weighting, which is critical to creating smooth, pleasing
deformations when your character’s skeleton is manipulated.

Chapter 10: Rigging Your Character Every good rig has controls that make
it faster and easier to animate. In this chapter, you'll set up control structures
that allow you to animate your character quickly and easily.

Chapter 11: Setting the Scene: Creating an Environment A character
needs a space in which to perform. This chapter takes you through the process
of creating a set and making some simple props and set dressing, and gives you
a little more practice creating shaders and applying them to geometry.

Chapter 12: Making It Move: Animating Your Character  This chapter
takes you step by step through animating your character performing a simple
action. You pose your character, set keyframes, and make adjustments that
bring your character to life.

Chapter 13: Let There Be Light: Lighting Your Shot Good lighting can
completely change the mood and meaning of a scene. This chapter describes the
three-point lighting system and takes you through the process of setting one up
in your scene.

Chapter 14: Rendering and Compositing Your Scene After all your work,
you'’re going to want to show your shot to family and friends. This chapter walks
you through generating final output from your scene and compiling it into a
QuickTime movie.

Appendix A: Autodesk Maya 2014 Certification This appendix contains the
objectives to the Autodesk Maya 2014 Certified Professional Exam and a table that
lists the topic, exam objective, and chapter where the information can be found.

ol =l Gotowww.autodesk.com/certification tofindinformation
about the Maya 2014 Certified Professional exam covered in this book, as well as other
Maya certification exams.
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The Essentials Series

The Essentials series from Sybex provides outstanding instructions for readers
who are just beginning to develop their professional skills. Every Essentials book
includes these features:

» Skill-based instruction with chapters organized around projects
rather than abstract concepts or subjects.

» Suggestions for additional exercises at the end of each chapter, where
you can practice and extend your skills.

» Digital files (via download) so you can work through the project tuto-
rials yourself. Please check the book’s web page at www.sybex.com/
go/maya2014essentials for these companion downloads.

You can contact the author through Wiley or on Facebook at www. facebook. com/
MayaEssentials. I hope you have fun with the material that follows.
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CHAPTER 1

Understanding the
Maya Interface

Before you start creating in the Autodesk® Maya® program, it’s a good
idea to familiarize yourself with the application’s interface and the tools
you’ll need to use frequently. The Maya interface can be intimidating and
confusing, but you can start by getting to know a few of the windows and
tools, and then learn the rest as necessary. This chapter presents what you
need to know to get started.

Exploring interface elements

Moving views and manipulating objects
Using windows and menus

Setting preferences

Getting help
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The appearance of the
interface windows on
your machine may vary
from the images in this
book, depending on
the operating system
you're using.

Chapter 1 « Understanding the Maya Interface

Exploring Interface Elements

On first glance, understanding Maya’s interface can seem to be a daunting task
(see Figure 1.1).

[ Maya Fie Edi Modfy Create Display Window Asseis Edi Curves Surfaces FEdiNURES NEX Muscle Pipeline Cache Help D % T ) Griows Mon32PM Q
CXaTa Aok Mava Preview Raiease 22 (CIouseau) w64 uattied™

FIGURE 1.1 TheMayainterface

Fortunately, you don’t need to know what all those buttons and icons do
right now. In fact, you can spend years working in Maya and never touch some
of those buttons, depending on the kind of work you do. That said, you’ll use
several of these buttons, windows, and menus frequently and so you should be
familiar with them.

One of the best ways to become familiar with the common tools in Maya is to
take a look at some of the extensive Help files Maya has available—specifically,
the 1-Minute Startup Movies. Choose Help > 1-Minute Startup Movies, and
view the first five movies. We'll get into the topics covered by movies 6 and 7
later. Go ahead, watch the movies; I'll wait.

Back already? Great—now you have a little information about some of the com-
mon tools, menus, and commands in Maya. Let’s explore them in a bit more detail.

Views

When you start a new Maya scene, the Perspective view opens by default. In 3D,
it’s often important to see your scene from more than one view, and it’s easy to
do that in Maya. Figure 1.2 shows the default Maya window.
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Exploring Interface Elements

FIGURE 1.2 Default Mayawindow

To see multiple views, place your cursor in the Perspective view and tap the
spacebar. The single-view window becomes a four-view window with Front, Side,
and Top views in addition to the Perspective view you started with. To return to
a single view, place your cursor in the view you want to be displayed full-screen
and tap the spacebar again. Any of the four views can be displayed full-screen, as
well as several other types of views we’ll discuss later.

Time Slider

At the bottom of the screen below the view window is the 7Time Slider, shown
in Figure 1.3. The Time Slider shows the range of frames that are currently
active in the scene, the location of the playback head, and the frames that
have keyframes set on them for any selected object. (Keyframes are frames on
which you specify actions, such as movement or rotation, for specific objects.
Keyframes are discussed in detail in Chapter 12, “Making It Move: Animating
Your Character.”)

Playback Head Time Slider

FIGURE 1.3 TimeSlider

Try moving the playback head around. You can either click a frame to move
the playback head to that position, or click and drag the head to move it.
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Chapter 1 « Understanding the Maya Interface

Range Slider

Below the Time Slider is the Range Slider. The Range Slider shows the total
number of frames currently in the scene, and the portion of those frames that
are currently active. To the left of the Range Slider are two windows contain-
ing information about the first frame of the scene and the first frame of the
currently active frame range. To the right of the Range Slider are two windows
containing information about the last frame of the currently active frame range
and the last frame of the scene. Figure 1.4 shows the Range Slider and the
frame windows.

Beginning Range Slider End of Active Scene
of Scene

Beginning of End of Scene
Active Range

FIGURE 1.4 RangeSlider

Try changing the length of the active range. One way is to click the square
button on the right side of the Range Slider and drag left or right.

Toolbox Window

On the left side of the screen is the Toolbox window, shown in Figure 1.5. The
Toolbox contains buttons for many of the commonly used tools in Maya, as well
as a space that contains the most recently used tool.

FIGURE 1.5
Toolbox window
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Moving Views and Manipulating Objects

Shelves

Above the view window is a nifty little group of icons called a shelf. Maya comes
with several default shelves, such as polygonal modeling, animation, and ren-
dering shelves. What'’s really handy, though, is that you can create your own
custom shelves and populate them with the tools you use most frequently. The
default shelves and any custom shelves you create are accessible via the tab

on the left side of the shelf or by the tabs that are just above the shelf icons.
Figure 1.6 shows a shelf and the tabs.

FIGURE 1.6 Shelf

Moving Views and Manipulating Objects

Within the Maya 3D space, you can move your position, manipulate an object, or
both. The first descriptions in the following list are of the view tools, followed by
the tools that enable you to move, rotate, and scale objects:

Tumble Tumbling the view enables you to rotate around objects in the scene.
The Tumble tool works only in Perspective views. The keyboard combination for
tumbling is Option/Alt + left mouse button (LMB). Figure 1.7 shows this key-
board/mouse combination.

Option
Alt

FIGURE 1.7 Tumblekeyboard/mouse
combination

Pan Panning the view enables you to move side to side and up and down
within a view. The keyboard combination for panning is Option/Alt + middle
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mouse button (MMB). In most cases, the MMB is your mouse’s scroll wheel.
Figure 1.8 shows this keyboard/mouse combination.

Option
Alt

FIGURE 1.8 Pankeyboard/mouse
combination

Zoom Zooming the view enables you to move closer to or farther away from
objects in the scene. The keyboard combination for zooming is Option/Alt +
right mouse button (RMB). Figure 1.9 shows this keyboard/mouse combination.

Option
Alt

FIGURE 1.9 Zoomkeyboard/mouse
combination

Other Zooming Options Maya also has a couple of keyboard commands that
zoom in on objects in the scene:

» Press the a key to zoom in to show every visible object in the scene.

» Press the f key to zoom in to show every selected object in the scene.
If nothing is selected, the f key behaves like the a key.

The ViewCube Another way to navigate within a view window is with the
ViewCube, shown in Figure 1.10. You can manipulate the view by clicking and
dragging the cube, by clicking a cube face or edge, or by clicking the Home icon
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Moving Views and Manipulating Objects

above and to the left of the cube, which returns you to the standard view for
that window. Try manipulating the view with the ViewCube.

FIGURE 1.10
ViewCube

Move Tool The Move tool can be accessed by clicking its button in the
Toolbox (shown in Figure 1.11) or by pressing w on your keyboard. This tool
enables you to move an object anywhere in the scene. Clicking and dragging one
of the colored handles constrains the motion to that one axis, whereas click-

ing and dragging the center where the three handles meet allows you to move
along more than one axis. Create a polygon sphere by clicking Create > Polygon
Primitives > Sphere and then dragging in the view (if a sphere didn’t automati-
cally appear). Select the Move tool, and move your sphere around.

Move Tool
Rotate Tool
Scale Tool

FIGURE 1.11
Move, Rotate, and Scale tools

Rotate Tool The Rotate tool, shown in Figure 1.11, can be selected by clicking
its button in the Toolbox window or by pressing e. The red, green, and blue han-
dles surrounding the object constrain the rotation to one axis, and the larger
circle outside of them rotates the object parallel to the view plane. Try rotating
your sphere around one or more axes. The small circle inside the red, green, and
blue circles is used for free rotation on all three axes.

Scale Tool The Scale tool enables you to change the size of your object. To
access the tool, you can click the button, shown in Figure 1.11, or press r. The
object’s handles look similar to the Move handles, but the Scale handles have
cubes on their ends. As with the Move tool, dragging a single handle constrains
the scaling to that axis, whereas dragging the center where the three handles
meet scales on all three axes at the same time. Try scaling your sphere, both on
a single axis and as a whole object.
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Enlarging or Reducing the Manipulator Handles Sometimes the manipula-
tor handles for Move, Rotate, and Scale are either too long or too short to work
with. Adjusting their length is easy. With one of the tools active, press the Plus
key (+) to lengthen (or, in the case of Rotate, enlarge) the handles, or press the
Minus key (-) to shorten (or shrink) the handles. Select your sphere, and prac-
tice lengthening and shortening the manipulator handles.

Using Maya Windows and Menus

There are several windows and menus in Maya that you’ll use frequently. Some
are always available to you, and others are brought up by keyboard commands
or mouse clicks:

Channel Box/Layer Editor  The Channel Box/Layer Editor, which is on the
right side of the Maya interface, contains information about the object currently
selected, such as its position, scale, and modeling history, or other attributes
that have been created. If the Channel Box/Layer Editor isn’t visible, bring

it up by clicking its button in the upper-right corner of the Maya interface.
Figure 1.12 shows the Channel Box/Layer Editor.

pSphere1

SHAPES
pSphersShapst

INPUTS
polySphers1

FIGURE 1.12
Channel Box/Layer Editor
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Marking Menu The marking menu, shown in Figure 1.13, allows you to
select various attributes of an object, such as edges or faces on a polygon object,
or isoparms on a NURBS object. Access the marking menu by right-clicking an
object in the scene and continuing to hold the RMB.

FIGURE 1.13 Marking menu

Hotbox The Hotbox is a way to access the menus across the top of the Maya inter-
face without mousing all the way to the top of the window. It contains not only the
main menu items but also several other menus that otherwise would be visible only
by changing menu sets on the interface. To access the Hotbox, shown in Figure 1.14,
place your cursor in the view window and press and hold the spacebar.

Select Mesh

Ed|

ticles  Fluid Effect:

FIGURE 1.14 Hotbhox
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Option Boxes Sometimes, menu items in Maya have options associated with
them that allow you to specify exactly how you want the menu item applied to
the object you’re working on. You can access these options via the option box
that is immediately to the right of the menu item, as shown in Figure 1.15. Not
every menu item has an associated option box.

L& -ICH Display Window Assets Animate GCeometry Cache

NURBS Primitives
Polygon Primitives
Subdiv Primitives
Volume Primitives
Lights

Cameras

Cube
Cylinder
Cone
Plane
Torus
Prism
Pyramid
Pipe

Helix
Soccer Ball
Platonic Solids

CV Curve Tool

EP Curve Tool
Bezier Curve Tool
Pencil Curve Tool
Arc Tools

ooooooooooa

Measure Tools

Interactive Creation
v Exit On Completion

Text
Adobe(R) lllustrator(R) Object...

o oo ¥ Yoooo YYYYMY

Construction Plane
Locator
Annotation...

Empty Group
Sets >

FIGURE 1.15 Optionbox

To familiarize yourself with using the option box, pick any menu item that has
associated options, and click the option box. The Tool Settings window opens,

and you can see the various options available for that menu item. Click Cancel
(or Close in Windows) to close the window.

Setting Preferences

Maya enables you to customize the interface in several ways. One of the most
common is by changing preferences on frequently used features to complement
the way you like to work.

Preferences Window

Click the small, square button to the right of the key icon in the bottom-right
corner of the interface (shown in Figure 1.16) to open the Maya Preferences
window. You can also access the window by choosing Window > Settings/
Preferences > Preferences, as shown in Figure 1.17, or by using the Hotbox and
selecting the same path.
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Preferences
Button

FIGURE 1.16 Preferenceshbutton

m Assets  Animate Geometry Cache Create Deformers

General Editors
Rendering Editors
Animation Editors
Relationship Editors

Settings/Preferences » Prafrences

Attribute Editor Tool Settings
Outliner Performance Settings
Create Node 5
Hypergraph: Hierarchy o 2::::;::;;;’5
Hypergraph: Connections u Marking Menu Editor
Paint Effects Shelf Editor

UV Texture Editor Panel Editor
Playblast o Plug-in Manager
View Arrangement [ 3

Saved Layouts »

Save Current Layout...

Frame All in All Views TA
Frame Selection in All Views OF

Raise Main Window
Raise Application Windows

FIGURE 1.17 Preferences menu

The Preferences window is organized into categories that are listed on its left
side. Under each category are subcategories. Both the categories and subcatego-
ries have options you can set. Selecting one of these categories or subcategories
changes the options available to you on the right side of the window. Sometimes
it takes a little searching to find what you're looking for, but generally things are
pretty well organized and under categories that make sense. Figure 1.18 shows
the Preferences window.

Fdit  Help

Categories Time Slider: Animation Time Slider and Playback Preferences

Time Slider

Playback

FIGURE 1.18 Preferences window
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Settings Used for the Tutorials

Everyone has their favorite tool and display settings for using Maya, and I'm no
exception. I prefer to set up Maya so elements are easy to see and I can tell at a
glance what I'm doing. I also like to set things up so that I can make as few mis-
takes as possible if 'm not paying close attention. The following list details a few
settings I prefer to use. You're welcome to set your preferences the same way—
or not. It’s up to you. I'd strongly recommend these settings if you're brand

new to Maya, though. They make things much easier to see and make it much
harder to make unintended mistakes:

Background In the Preferences window, select Display on the left side, and
then scroll down to the View section on the right. Find Background Gradient,
and set it to Off. This gives you a medium-gray background rather than the
default gradient—much easier to see what you're doing, in my opinion.

Polygon Selection Again in the Preferences window, select the Selection
subcategory under the Settings category, and then scroll down to the Polygon
Selection section on the right side. Choose the option marked Select Faces
With: Center. This does a couple of things for you: it makes it harder to acciden-
tally select a polygon when you don’t mean to, and it turns on small squares in
the center of each poly, which will come in handy when you’re modeling.

Playback Speed Finally, once more in the Preferences window, choose
Settings > Time Slider. In the Playback section, set Playback Speed to Real-
Time [24 fps]. Click the Save button to save your changes.

Getting Help

As you might expect, loads of resources are available to help you become better
at working with Maya. There are many books, magazines, videos, websites, and
all sorts of other resources to aid you. Here are a few to get you started:

1-Minute Startup Movies You've already looked at these once, but don’t
hesitate to go back and take another look at them if you’re unclear on how to
do something in the Maya interface. Frequently they’re the quickest and most
straightforward way to refresh your memory on the basics. You can access the
Essential Skills Movies under Help > 1-Minute Startup Movies, as shown in
Figure 1.19.
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O % = &) (=F000% Mon 3:2|

Maya Help F1
What's New >

Maya Learning Channel

1-Minute Startup Movies

Tutorials

Learning Path
Services and Support >
Communities >

Report a Problem...
Suggest a Feature >
Customer Involvement Program...

Resources and Tools >
Exchange Apps

MEL Command Reference
Python Command Reference
Node and Attribute Reference

Maya Home Page
Check for Updates
Try Other Autodesk Products

FIGURE 1.19 1-Minute
Startup Movies

Help Files The Help files included with Maya are extensive, searchable, and
detailed. You can find basic information about a tool or detailed tutorials to help
you master a technique. The Help files are organized and searchable via the
table of contents or the index. You can access the Help files under Help > Maya
Help, as shown in Figure 1.20.

p ‘0 % = 4) EF000% Mon3:2
|

aya Help
What's New >

Maya Learning Channel
1-Minute Startup Movies
Tutorials

Learning Path
Services and Support >
Communities >

Report a Problem...
Suggest a Feature >
Customer Involvement Program...

Resources and Tools >
Exchange Apps

MEL Command Reference
Python Command Reference
Node and Attribute Reference

Maya Home Page
Check for Updates
Try Other Autodesk Products

FIGURE 1.20 MayaHelpfiles
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Area Website Autodesk has an online community website called Area where
you can browse the topics being discussed or post a question. A screenshot

of Area is shown in Figure 1.21. In addition, tutorials, free downloads, and

more are available to inspire you and help you get up to speed. Membership is
required, but registration is free. Joining Area is highly recommended. The URL
is http://area.autodesk.com/.

@ Ficefox_File bt View History Bookmarks Tools Window _fielp W12 5 & = 43 Groowes Mon2ozm G
~ -

FIGURE 1.21 Areawebsite

THE ESSENTIALS AND BEYOND

The Maya interface can be daunting, with all its buttons and menus. Now you have a working
knowledge of some of the parts of that interface, and you can get started in Maya.
ADDITIONAL EXERCISES

» Change menu sets by using the drop-down window in the upper-left corner of the interface,
and observe how some of the menu options across the top of the screen change.

» Switch the shelf that’s on display, and hover over some of the icons on the new shelf to see
what tool the button calls up. (Some of the icons are pretty abstract.)
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CHAPTER 2

Creating Your First
Animation

Autodesk® Maya® software can be used for many steps in a production,
but one of the most fun—>both to play around with and show to friends and
family—is animation. So you'll start out by creating a simple animation. The
clip you're going to produce is one of the first exercises any animator com-
pletes: the bouncing ball.

Using good scene-file management

Creating and animating a bouncing ball

Refining movement in the Graph Editor

Using animation principles to improve your work

Creating a playblast of your animation

Using Good Scene-File Management

Before you start, you need to set up your Maya scene so all of your assets are
organized and easy to find. This will be very important as you work on more
complex projects, so it’s a good habit to get into right from the start.

Maya provides a way to easily keep all the files for a project organized. It’s
called the project directory. Every time you start a new scene, you should set
up a new project directory by following these steps:

1. Choose File > New Scene.
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2. Choose File > Project Window. The Project window opens, as shown
in Figure 2.1.

Project Window
Edit Help
Current Project: default
Location fnaasp/Documents/maya/projects

~ Primary Project Locations

¥ Secondary Project Locations
} Translator Data Locations

}» Custom Data Locations

Accept Cancel

FIGURE 2.1 Projectwindow

3. Click the New button next to the Current Project field, and give your
project a unique name such as Projectl or BouncingBall, as shown
in Figure 2.2.

8060 Project Window.
Edit Help

Current Project: | Bouncinggall]

Location: /Users/naasp/Documents/maya/projects

~ Primary Project Locations

s Images
urceimages

Dara renderData

Save autosave

» Secondary Project Locations

¥ Translator Data Locations

¥ Custom Data Locations

Accept Cancel

FIGURE 2.2 Projectname
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4. Confirm that your project is being saved to the maya/projects direc-
tory by checking the Location field, shown in Figure 2.3.

ann Project Window
Edit Help

Current Project: Ball

Location aasp /Documents mayaj projects|

~ Primary Project Locations

Translator Dat

AutoSave autosave

» Secondary Project Locations
» Translator Dat Locations

}» Custom Data Locations

Accept Cancel

FIGURE 2.3 C(Checkingthe project location

Maya creates subdirectories within your main directory to hold
various scene elements. These are listed under Primary Project
Locations, as shown in Figure 2.4.

Subdirectories

AN n Project Window

Translator Data

AutoSave autosave

» Secondary Project Locations

¥ Translator Data Locations

P Custom Data Locations

Accept Cancel

FIGURE 2.4 Projectsubdirectories

5. Click the Accept button to close the Project window.
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6. Finally, make sure your scene has 24 active frames by checking the
Time Slider, as shown in Figure 2.5. If you don’t have 24 frames, adjust
the length of the Range Slider or type 24 in the End Time window.

Range Slider Adjustment End Time Window

FIGURE 2.5 Settingthescene to 24 frames

Creating and Animating a Bouncing Ball

Before you start animating, you're going to change your view and turn on an
option that will let you see exactly the space you're working in. Then you’ll
create your ball and set the keys that will get it bouncing.

Selecting a View and Turning On the
Resolution Gate
To make it easier to animate your ball, you’ll work in the Front view and turn on

an option that shows just how much of that window would show up if you were
to create a final render of your animation. Follow these steps:

1. Place your cursor in the view window, and tap the spacebar to access
the four-view layout.

2. Place your cursor in the Front view, and tap the spacebar to make the
Front view active in the single-view layout.

3. In the menu at the top of the view window, choose View > Camera
Settings > Resolution Gate, as shown in Figure 2.6.

FIGURE 2.6 (ameraSettings menu
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Creating and Animating a Bouncing Ball 19

A rectangle appears in the Front view. Anything within the rect- K
angle will appear 1’r1 a final render. Anything in the gray area outside Alternatively, you can
the rectangle won’t show up. dlick the small shaded

sphere icon at the top

4. Using the Pan keyboard/mouse combination (Option/Alt + MMB), e ————

move the thick, black line to the bottom of the screen. Your view turn on the resolution

should look something like Figure 2.7. gate (the icon is visible
in Figure 2.6 just to
the right of the View

menu).

FIGURE 2.7 Viewsetup

Creating a Ball

You'll use a polygon sphere for your bouncing ball. They’re easy to work with
and look pretty good. Follow these steps to create the ball:

1. Choose Create > Polygon Primitives, and click Interactive Creation
to uncheck it, as shown in Figure 2.8.

NURBS Primitives

Polygon Primitives
Volume Primitives > ?:Z};re E
Lights < | Cylinder o
Cameras ™ o &
CV Curve Tool o Plane =
EP Curve Tool o Torus =
Bezier Curve Tool o Prism =
Pencil Curve Tool o Pyramid =
Arc Tools » Pipe ol
Helix o
Measure Tools »  Soccer Ball o
Platonic Solids o
Scene Assembly >
Interactive Creation
Text O v Exit On Completion
Adobe(R) lllustrator(R) Object... O
Cranctriicting Dlana fml

FIGURE 2.8 TurnoffInteractive Creation.
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2. Choose Create > Polygon Primitives > Sphere > Option Box, and
click. Figure 2.9 shows the selection.

(8(-1C8 Display Window Assets Select Mesh Edit Mesh
T Maya Preview Relea:
NURBS Primitives QN Auaite i e et
[ Primitives »
Volume Primitives R Ciibe o
Lights < Cylinder o
Cameras > Coria o
CV Curve Tool o Plane =
EP Curve Tool o Torus =
Bezier Curve Tool g Prism B
Pencil Curve Tool o Pyramid o
Arc Tools » Pipe =)
Helix m]
Measure Tools 3 Soccer Ball =}
Platonic Solids ]
Scene Assembly >
Interactive Creation
Text O Exit On Completion
Adobe(R) lllustrator(R) Object... 0O
ima DL

FIGURE 2.9 C(reatePolygon Primitives
Sphere menu

3. In the Polygon Sphere Options window, shown in Figure 2.10, set the
radius to 2.5.

Edit  Help

FIGURE 2.10 Polygon Sphere Options window

4. Click the Create button.

5. Press 5 on your numeric keypad or keyboard to shade the sphere.
Figure 2.11 shows the shaded sphere.
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FIGURE 2.11 Yourball,shaded

6. Save your scene, either by choosing File > Save Scene or by pressing
Command/Ctrl + S. Name your scene bouncingBall or another name
you choose.

You have your ball; now it’s time to bounce it.

Setting Movement Keyframes

To animate in Maya, you set keyframes for various attributes on specific frames.
That lets the software know that on a particular frame, you want a particular attri-
bute to have a particular value. Then Maya interpolates between the keyframes to
create the motion you're after. Let’s set some movement keyframes, or keys:

1. Click the Move tool in the Toolbox window (shown in Figure 2.12), or
press w.

Move Tool

Maves selected objects or comp
transform manipulator.

FIGURE 2.12 Movetool
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2. Click the sphere, if it’s not already selected.

3. Make sure the playback head in the Time Slider is on frame 1, as
shown in Figure 2.13.

FIGURE 2.13 Playbackhead

4. Click and hold the green arrowhead on the Move tool, and drag the
sphere up to the top of the screen. Release the mouse button. The
ball should be positioned similarly to the one in Figure 2.14.

FIGURE 2.14 Initial ball position

5. Press s. This sets a key for the ball’s position, rotation, and scale on
frame 1. Rotation and scale don’t matter currently, just position.

6. Move the playback head to frame 24 by clicking the playback head
and dragging, and then press s again. You're creating a cycle, and
because the ball is already where you want it to end up, you'll just
set another key while it’s there. Figure 2.15 shows the playback head
at frame 24.
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FIGURE 2.15 Setting the final key at frame 24

7. Move the playback head to frame 13.

8. Click the green arrowhead (it will be yellow if still selected) on the
Move tool, and drag the sphere down so the bottom just touches the
black line. Figure 2.16 shows the ball in its down position.

FIGURE 2.16 Moving the ball down

9. Press s to set a key.

10. Save your scene.
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If your ball is bouncing
very fast, open the
Preferences window,
select Settings > Time
Slider, and under
Playback set Playback
Speed to Real-time

[24 fps].

Chapter 2 « Creating Your First Animation

11. Click the Play Forwards button, shown in Figure 2.17, on the lower-
right side of the screen to see your ball move.

Play Forwards Button

FIGURE 2.17
Play Forwards button

Refining Movement in the Graph Editor

Your ball is moving—pretty cool! But right now it’s not really bouncing. There
are a couple of problems with the way it’s moving. Part of the task of an anima-
tor is to make things move the way you know they should. In this section, you'll
adjust some things to get your ball bouncing like a real ball would.

What’s Wrong with the Way My Ball Is Bouncing?

The reason the ball is moving the way it is has to do with how Maya tries to
interpolate between keys. Maya uses fangents to interpolate between the keys
you set, and sometimes the tangents don’t work as you need them to. Your next
step is to adjust the tangents so the ball moves the way you want:

1. Press Esc to stop playback.

2. With the ball still selected, choose Window > Animation
Editors > Graph Editor, as shown in Figure 2.18.

LULEEEE Assets  Select Mesh  Edit Mesh  Proxy Nnrmalsl

General Editors
Rendering Editors
Animation Editors
Relationship Editors

Settings/Preferences Trax Editor

Camera Sequencer
Attribute Editor Dope Sheet
Qutliner Humanlk

Node Editor Blend Shape
Create Node

Hypergraph: Hierarchy
Hypergraph: Connections

Expression Editor

Daint Effarte

FIGURE 2.18 GraphEditormenu
selection

3. With pSpherel selected, press a on your keyboard.
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Several lines appear in the Graph Editor window. These are the
tangents for the attributes you set by pressing s. You need only one of
these, so you'll select just that one.

4. Click Translate Y in the left column of the Graph Editor.

5. Press a on your keyboard to zoom in on the tangent. Your window
should look similar to Figure 2.19.

FIGURE 2.19 TranslateYin the Graph Editor

Adjusting Spline Tangents

The tangent tells you a lot about how something’s moving. The greater the
change in the tangent as it moves from left to right, the faster the change in
that attribute onscreen. The smaller the change in the tangent, the slower the
change in that attribute. Looking at the tangent for Translate Y, you can see
that the ball starts out slowly (as shown by the flat tangent lines), picks up speed
(represented by the steep tangent lines), and slows down as it nears and leaves
the key at frame 13 (represented by the shallow curve in the tangent). That’s
pretty much what you saw when you played your animation. Let’s adjust the
tangents so you get a more believable bounce:

1. Drag-select the keys at frames 1 and 24 (the small, black boxes at
the beginning and end of the tangent line). The boxes highlight, and
handles appear extending from them, as shown in Figure 2.20.

www.LegendaryLibrary.Mihanblog.Com

25



26 Chapter 2 « Creating Your First Animation

FIGURE 2.20 Keysselected

2. The handles should be horizontal, which is how you want them so
the ball starts off slowly. If they aren’t horizontal, click the Auto
Tangents button (the button at the top of the window with an A
under a tangdent line).

3. Save your scene.

Breaking Tangents for Fast Direction Changes

The start and stop look good, but you have to fix the motion of the ball as it hits
the “ground.” To do this, you're going to break the tangents before and after the
key on frame so you can adjust them individually:

1. Drag-select the key at frame 13.

2. Click the Break Tangents button at the top of the Graph Editor win-
dow. Figure 2.21 shows the button’s location.

Break Tangents Tool

FIGURE 2.21
Break Tangents tool

3. Drag-select the handle on the left side of the key.
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Refining Movement in the Graph Editor

4. Left-click anywhere within the Graph Editor window, and drag
upward to move the handle. If the handle doesn’t move, make sure
you have the Move tool selected by pressing w on your keyboard.
Adjust the handle so it looks more or less like Figure 2.22.

FIGURE 2.22 Adjustingthe tangent handle

5. Drag-select the handle on the right side of the key.

6. Left-click anywhere within the Graph Editor window, and drag
upward. Adjust the handle so it looks more or less like Figure 2.23.

FIGURE 2.23 Adjusting the second tangent handle
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7. Close the Graph Editor window.

8. Save your scene.

9. Click the Play Forward button at lower-right on the screen. Your ball

should now bounce much more like a regular ball.

Using Animation Principles to Improve
Your Work

The ball is bouncing well, but you can add some interest to the cycle by using
basic animation principles.

Squash

You'll use a technique called squash to give more force to the ball’s impact with
the ground. Press the Esc key to stop playback, and then follow these steps:

1.

Make sure the ball is still selected, and then click frame 12 in the
Time Slider to move the playback head there.

. Press Shift + R. Doing so sets keys just for the scale of your ball.
. Go to frame 14, and press Shift + R again.

Go to frame 13, and enter the following into the scale fields in the
Channel Box, as shown in Figure 2.24:

0oL BulPpoW

SHAPES
pSphareShape1
MpUTE

a
2
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3
g
g

FIGURE 2.24
Channel Box squash values

Scale X: 1.125
Scale Y: 0.75
Scale Z: 1.125
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5. Press Return/Enter. Then press Shift + R to set a scale key.
When using squash, it’s important to maintain the volume of the
object. You don’t want the ball to grow or shrink in size, just change
shape.

6. Select the Move tool from the Toolbox, or press w on your keyboard.

7. Move the ball back down so the bottom is touching the black line
again, as shown in Figure 2.25.

FIGURE 2.25 Squashed ball repositioned

8. Press Shift + W to set a move key for the ball.
9. Save your scene.

10. Click the Play Forwards button, as shown in Figure 2.26.

Play Forwards Button

FIGURE 2.26
Play Forwards button

Your ball now has squash. You'll feel it more than see it, and that’s how it
should be.

Stretch

Squash gave your ball impact with the ground. Strefch will give the ball a sense
of acceleration and motion blur that happens when objects move fast while
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Chapter 2 « Creating Your First Animation

being filmed. Press the Esc key to stop playback. Here are the steps for creating
stretch:

1. Click frame 7 in the Time Slider to move the playback head there.
2. Press Shift + R to set a scale key.
3. Click frame 18.
4. Press Shift + R.
5. Click frame 12.
6

. In the Channel Box, set the following values, as shown in Figure 2.27:

wijooy Buippon

SHAPES
pSphereShaps1

a
£
E
g
L)
E
]
s

FIGURE 2.27
Channel Box stretch values

Scale X: 0.9
Scale Y: 1.2

Scale Z: 0.9
Just as with squash, you want to maintain the volume of the ball
when stretching it. You don’t want it to look like it’s growing or
shrinking.

7. Press Return/Enter, and then press Shift + R to set a scale key. If the
end of your ball is extending below the black line, click the green
arrow in the ball, move the ball up to a little above the line, and press
Shift + W to reset its move key. The ball should look something like
Figure 2.28.
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Creating a Playblast of Your Animation

FIGURE 2.28 Stretched ball repositioned

8. Click frame 14, and set the same values.

9. Press Shift + R to set a scale key. Adjust the ball’s position if
necessary.

10. Save your scene.
11. Click the Play Forwards button.

Your ball now has squash and stretch. Notice how much more flexible and
rubbery it looks than it did before.

Creating a Playblast of Your Animation

The Play Forwards button is good for getting a general idea of how your scene
looks, but it may not be an accurate example of the speed at which your anima-
tion is running. To be sure everything is playing as it should be (as well as to be
able to show off your work to others), you're going to make a playblast of your
animation. A playblast is a low-resolution render that plays as a QuickTime or
AVI movie. Follow these steps:

1. Click anywhere in the view window to deselect the ball. The wire-
frame overlay disappears, leaving you with a gray ball.
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32 Chapter 2 « Creating Your First Animation

2. Choose Window > Playblast > Option Box, as shown in Figure 2.29.
The Playblast Options window opens.

lmm Assets  Select Mesh Ed|

General Editors
Rendering Editors
Animation Editors
Relationship Editors
Settings /Preferences

vyvvwvwy

Attribute Editor

Outliner

Node Editor

Create Node

Hypergraph: Hierarchy o
Hypergraph: Connections o

Paint Effects
UV Texture Editor

Playblast [=]

View: A I

FIGURE 2.29 Opening
the Playblast Options window

3. Change Scale to 0.50, as shown in Figure 2.30.

Playblast Options

Edit Help

Time range: & Time Slider Start/End

Use Sequence Time
v

Formar (gt -

Encoding [PNG

Browse...

Playblast Close

FIGURE 2.30 Scalesetting

4. Make sure Save To File is checked, as shown in Figure 2.31. If it isn’t,
click the check box to select it.
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Creating a Playblast of Your Animation

Playblast Options

Time range: ® Time Slider Start/End

Use Sequence Time:

Format gt
Encoding [PNG
Quality 70

Display size: [From window

0.50
-

This needs to be checked

ouncingBall

Playblast

FIGURE 2.31 SaveToFilesetting

5. Under Save To File, click the Browse button and navigate to a location
you’ll remember (the desktop is usually good).

6. Type in a name for your movie, and click Save.

7. In the Playblast Options window, click the Playblast button, as shown
in Figure 2.32.

. > Playblast Options
Edit Help

Time range: @ Time Slider Start/End

Use Sequence Time
Vi

amera Qutput

ouncingBall

Playblast

FIGURE 2.32 Playblastbutton
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Chapter 2 « Creating Your First Animation

The playblast renders, and the resulting movie file opens in Apple
QuickTime, Microsoft Windows Media Player, or Fcheck, depending
on which player is your default.

8. Turn on looping in your player, and then click the Play button.

Congratulations! You've just completed your first 3D animation!

THE ESSENTIALS AND BEYOND

In this chapter, you've created your first animated clip. You set keyframes, adjusted tangents
in a couple of different ways, worked with movement and scaling, and rendered a playblast
movie of your animation.

ADDITIONAL EXERCISES

P Instead of having the ball bounce straight up and down, how would you bounce it across the
screen? Hint: You need only a Translate X key on the first and last frames to make it happen
(highlight any Translate X keys in the middle of the tangent and delete them).

» Add some more frames to the active frame range, and have your ball bounce more than
once. Make each bounce slightly lower than the last, as a real ball would bounce. With the
48 frames you get in a new scene, you should be able to fit in two bounces. If you want to
bounce the ball more times, add frames to the scene by typing the number of frames you
want in the End Time window below the Time Slider.

> If your bounce travels across the screen, turn on Create Editable Motion Trail (Animation
menu set, Animate > Create Editable Motion Trail). The motion trail will show you the
path your ball is traveling. As your ball moves along the trail, be sure to rotate the stretch
keys so the ball looks like it’s stretching along the path of travel, as shown in Figure 2.33.

FIGURE 2.33 Squash keyrotated
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CHAPTER 3

Modeling with
Polygons, Part 1

In both games and film, polygon modeling is a technique frequently used
to build characters, sets, and props. Knowing how to model effectively with

polygons is an important skill to have. In this chapter and the two that fol-

low, you'll explore some poly modeling techniques.

Understanding polygons
Constructing a good model
Getting started and using the main modeling tools

Box modeling and building a character

Understanding Polygons

Polygons, or polys, are essentially flat surfaces that combine to make up a
larger object. They’re easy to work with and modify. Polygons, which are also
called faces, are made up of smaller elements—vertices and edges.

Vertex

A vertex is a point in space. Each vertex (or vert) has X, Y, and Z coordinates
for its location. Those coordinates are used by the Autodesk® Maya® soft-
ware to track the object within the 3D environment. Any changes to the
vert’s position indicate some kind of movement, whether it’s the whole object
or just a component of it. Figure 3.1 shows a sphere with vertices visible.
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Vertex

Edges

Faces

FIGURE 3.1 Vertices, edges, and faces

Edges

Edges are two vertices connected. Edges make up the borders of polygons.
When modeling, you can extrude and modify edges to refine the shape of your
model, as you'll see shortly. Three or more connected edges make a poly, or face.
Figure 3.1 shows a sphere with edges selected and a sphere with faces selected.

www.LegendaryLibrary.Mihanblog.Com



Constructing a Good Model 37

Constructing a Good Model

There are some important factors to consider when building a model, especially
one that will bend and deform like the character you're going to build. Good
modeling technique means adhering to standard practices that lead to well-
constructed models.

The Importance of Quads

Quads are polygons with four edges. Your goal is to always use quads in model-
ing. In a pinch, you can use a triangle, but quads are much more preferable.
Quads render and deform well, and packages such as Pixologic’s ZBrush and
Autodesk® Mudbox® software require your model to be made of quads in order
for you to work on them in the software. Figure 3.2 shows a quad poly.

FIGURE 3.2 Quadpolygon
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The Problem With Ngons

Maya works best with quads and, to a lesser extent, triangles, or fris. But it is
possible to make a polygon with more than four edges. These are referred to

as Ngons. Except in very specific instances, you need to avoid having Ngons in
your models. They can create many problems in deformation and rendering, and
ZBrush and Mudbox won’t import models with Ngons in them. It’s surprisingly
easy to create Ngons, so you have to constantly be on the lookout for them.
Watch for any poly that has more than four edges around its perimeter. The
easiest way to avoid Ngons is to be extremely careful when deleting edges; that’s
where many Ngons are created. Figure 3.3 shows an Ngon.

FIGURE 3.3 Ngon

Getting Started and Using the Main
Modeling Tools

To get started modeling, you'll need to import some reference images, create a
polygon primitive as a starting point, and work with a few tools to build your
character.
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Getting Started and Using the Main Modeling Tools

Setting Up View Planes

To make modeling easier, you'll load reference images with front and side views.
You can download the images used in the exercise at www.sybex.com/go/
maya2014essentials or use your own. The files provided are mode1SketchFront
.tif and modelSketchSide. tif. Create a new project as described in Chapter 2,
“Creating Your First Animation.” Call the project characterModel. Then follow
these steps:

1.
2.
3.

Place your reference images in the sourceimages folder.
Choose File > New Scene.

Place your cursor in the scene window, and tap the spacebar to go to
the four-panel view.

In the Front view, choose View > Image Plane > Import Image, as
shown in Figure 3.4.

image Plane

Import image...
View Sequence Time
Import Movie...

FIGURE 3.4 Importingtheimage

Navigate to your sourceimages folder, and select mode1SketchFront.tif
or your front-view sketch.

Repeat steps 4 and 5 in the Side view, and choose mode1SketchSide.tif
or your side-view sketch.

You now have front- and side-view sketches of the character you'll model in
the scene, but the sketches are right in the middle of the environment. Next,

www.LegendaryLibrary.Mihanblog.Com

39



40 Chapter 3 « Modeling with Polygons, Part 1

you’'ll move them so they’re still visible but won’t get in the way when you start
building your character:

1. In the Perspective view, click the edge of the mode1SketchFront
image. The edge highlights, as shown in Figure 3.5.

FIGURE 3.5 Frontsketchselected

2. In the Channel Box, click imagePlaneShapel under SHAPES.

3. Change the Image Center Z value to -12, as shown in Figure 3.6.

FIGURE 3.6 Changingthelmage
Center Z value for the front-view image plane
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Getting Started and Using the Main Modeling Tools

4. Again in the Perspective view, click the edge of the mode1SketchSide
image.

5. In the Channel Box, click imagePlaneShape2, and change the Image
Center X value to -12, as shown in Figure 3.7.

FIGURE 3.7 C(hangingtheImage
Center X value for the side-view image plane

The reference images are now at the edges of the grid, as shown in Figure 3.8,
but look the same in the Front and Side views as when they were in the center of
the grid.

FIGURE 3.8 Referenceimages moved
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You're starting with

a cube because it's
the easiest shape to
work with initially. It
also requires the least
geometry to create.

Chapter 3 « Modeling with Polygons, Part 1

Starting with a Cube

You're going to start your model with a polygon cube and use a technique called
box modeling to build your character. Here are the steps:

1. Choose Create > Polygon Primitives > Cube > Option Box.

2. In the Polygon Cube Options window, input the following values, as
shown in Figure 3.9:

anNo _Polygon Cube Options
Edit Help

Width:  3.2000
Heig| 3.2000
Depth: 3.2000
Width divisions: 4
Height ns:
Depth divisions
Axis: X
Texture mapping: v Create UVs
v Normalize

@ Colle ely

v Preserve aspect ratio

FIGURE 3.9 PolyCubeOptions window

» Width, Height, Depth: 3.2
» Width Divisions and Height Divisions: 4
» Depth Divisions: 3
Click the Create button. A cube is created at the origin.
Place the cursor in each view, and press the 5 key to shade the cube.

. Select the Move tool.

& voA W

. Click the cube (if it’s not already selected), and move it up so it covers
the head in the Front and Side views, as shown in Figure 3.10. Pan
the view down so you can see the entire head in the sketch.
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Getting Started and Using the Main Modeling Tools

FIGURE 3.10 Cubemoved

Extruding Faces

You'll rough in the basic form of your character by using the Extrude tool.
Then you’ll add additional detail by using the Insert Edge Loop and Split
Polygon tools. Follow these steps:

1. Make sure the drop-down menu in the upper-left corner of the inter-
face is set to Polygons. Then click the Edit Mesh menu and verify that
Keep Faces Together is checked, as shown in Figure 3.11. If it’s not,
click it to check it.

LU CEIE Proxy  Normals  Color O

Modeling Toalki
Modeling Toolkit

v Keep Faces Together

Extrude
Bridge
Append to Polygon Tool

ooao

Deni Curnm nn mach

1

FIGURE 3.11 TheKeepFacesTogetheroption
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2. Right-click the cube in any view to bring up the marking menu, and
select Face.

3. Tumble the Perspective view so you can see the bottom of the cube.
Select the center two faces on the bottom, as shown in Figure 3.12.

FIGURE 3.12 Selectingfaces to extrude

4. Switch to the Front view, and choose Edit Mesh > Extrude, as shown
in Figure 3.13.

Edit Mesh WEEE)

Hide Modeling Toalkit
 Keep Faces Together

Bridge
Append to Polygon Tool

oo ooao

Project Curve on mesh

Snlit mach with iartad ciine

FIGURE 3.13 Selecting the Extrude option
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Box Modeling and Building a Character

5. Click the blue (Z axis) arrowhead, and drag down. New faces appear.
Drag until the bottom edge of the new faces is the length of the neck
in the sketch, as shown in Figure 3.14.

FIGURE 3.14 Movingextruded faces

Box Modeling and Building a Character

Now that you've extruded some faces from your cube, you'll extrude out the
main shapes of the character. After you have those in, you'll go back and add
detail with the Insert Edge Loop and Split Polygon tools. Follow these steps:

1. With the bottom faces still selected, choose Edit Mesh > Extrude
again, or press g on your keyboard. The g key repeats the last com-
mand you performed.

2. Click the blue arrowhead, and drag down to create a shoulder area.

3. Click the red cube (X scale), and drag to the right to scale the new
faces to the width of the torso, as shown in Figure 3.15.
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FIGURE 3.15 Scalingfaces

4. Press g to extrude another set of faces, and then drag them down the
length of the torso. Select the X scale handle, and scale the faces so
they’re the width of the bottom of the torso, as shown in Figure 3.16.

] —F
| [ L |

FIGURE 3.16 Extruding the torso
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5. Switch to the Perspective view. Select the face on the bottom of the
torso, at the right side of the screen, as shown in Figure 3.17.

FIGURE 3.17 Single-faceselection

6. Return to the Front view, and extrude a set of polys for the leg, as
shown in Figure 3.18. Scale on the X axis, and move right on the X
slightly.

FIGURE 3.18 Legextrusion

www.LegendaryLibrary.Mihanblog.Com

47



48

Chapter 3 « Modeling with Polygons, Part 1

7. Extrude one more time to create the foot height, as shown in
Figure 3.19.

FIGURE 3.19 Footextrusion

8. Select the front face of the preceding extrusion, as shown in
Figure 3.20.

FIGURE 3.20 Frontfaceselection
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9. Switch to the Side view and extrude, moving the new faces on the Z
axis, as shown in Figure 3.21.

FIGURE 3.21 Secondfootextrusion

10. Switch to the Perspective view. Select the face on the side, just below
the neck, as shown in Figure 3.22.

FIGURE 3.22 Selectingaface for thearm
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11. Switch to the Front view. Choose Edit Mesh > Extrude.

12. Click the small circle icon above and to the right of the manipulator
handle, as shown in Figure 3.23. The manipulator handles switch

orientation.
Toggle
—— Manipulators
Switch
FIGURE 3.23 Manipulators’ toggle switch
[ | 13. Drag out the new faces. Scale and move the selected face so that it
looks like Figure 3.24.
You can make the face
at the end of the arm

vertical by moving the
red X scale manipulator
in toward the center of
the control.

FIGURE 3.24 Extrudingthearm

www.LegendaryLibrary.Mihanblog.Com



Box Modeling and Building a Character

14. Extrude the face again to create the palm base, as shown in Figure 3.25.

FIGURE 3.25 Extruding the palm base

15. Extrude once more to create the rest of the palm, as shown in
Figure 3.26.

FIGURE 3.26 Extruding the remainder of the palm
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16. Select the faces on the front and back of the most recent extrusion,
and extrude again, as shown in Figure 3.27.

FIGURE 3.27 Buildingthe finger base

17. Select the three faces on the end of the arm, and extrude them again
to create the finger base, as shown in Figure 3.28.

FIGURE 3.28 Fingerbase extruded
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18. Select the center of the three end faces, press R to activate the Scale
tool, and scale in on the Z axis until the three end faces are about the
same size, as shown in Figure 3.29.

FIGURE 3.29 Scalingthefingerbase

19. Choose Edit Mesh > Keep Faces Together to turn off the Keep Faces
Together option.

20. Select the three end polys on the finger base.
21. Choose Edit Mesh > Extrude, and move the faces out on the Z axis.

22. Click any of the scale manipulator boxes to activate the Scale func-
tion, and then scale using the center of the manipulator to taper the
finger sections slightly, as shown in Figure 3.30.

FIGURE 3.30 Fingerextrusion
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23. Choose Edit Mesh > Keep Faces Together to turn the Keep Faces
Together option back on.

24. To create a thumb, select the poly on the side of section of the palm
with three divisions, as shown in Figure 3.31.

FIGURE 3.31 Selectingthe thumb base

25. Choose Edit Mesh > Extrude, and click a scale handle to activate the
Scale function.

26. Scale the selected poly by using the center handle, as shown in
Figure 3.32.

FIGURE 3.32 Scaling the thumb base
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27. Extrude again, and pull the poly out on the Z axis, as shown in

Figure 3.33. In the figure, the thumb has also been tapered slightly
as the fingers were.

FIGURE 3.33 Extruding the thumb

You’ve now blocked in the main shapes of your character. Now it’s time to
refine and add some details.

Refining the Character’s Geometry

You're probably wondering why you created only one arm and leg. It’s easier and
faster to model one half of a symmetrical object such as a character. Then, when
you have finished half, you’ll reflect that geometry over the center axis to com-

plete the model. Here are the steps:

1.
2.

Right-click on the model, and select Face from the marking menu.

In the Front view, select all the faces on the screen-left side of the
character (the side without the leg and arm).

Press the Delete key. The selected faces are deleted, as shown in
Figure 3.34.
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One of the primary
rules of modeling is to
keep your geometry
as simple as possible

foraslong as possible.

This makes it easier
to refine the shapes
without a lot of extra
faces and verts to deal
with. You can always
add more detail later,
asyou'll do in this
chapter.
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FIGURE 3.34 Facesdeleted

4. Right-click on the model again to bring up the marking menu, and
select Object Mode. The model is now selected as an object and ready
for refining.

Using the Insert Edge Loop Tool

You'll start to refine your model by using the Insert Edge Loop tool to add addi-
tional geometry. This tool inserts edges at points you specify, effectively splitting
existing polygons in two. The Insert Edge Loop tool works only on quad polys.
Follow these steps:

1. Choose Edit Mesh > Insert Edge Loop Tool.
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2. Click and hold the vertical edge in the middle of the character’s torso.

A dotted line appears, as shown in Figure 3.35.

FIGURE 3.35 InsertEdgeLoop tool

3. Drag the dotted line to a point in the torso where you'd like to make
adjustments to the shape. Then release the mouse button. A new
edge is inserted, as shown in Figure 3.36.
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New Edge

FIGURE 3.36 Newedgeloopinserted

4. Using the Insert Edge Loop tool, insert new edges at the elbow and
knee, as shown in Figure 3.37.

_New Edges

FIGURE 3.37 Kneeandelbowedgeloops
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5. Insert an edge loop running through the arm, hand, fingers, and
torso, as shown in Figure 3.38.

FIGURE 3.38 Armedgeloop

6. Insert an edge loop that runs up the front of the foot, leg, torso, neck,
and head, as shown in Figure 3.39.

FIGURE 3.39 Llegedgeloop
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Using the Split Polygon Tool

When you added the leg loop, it went all the way around the model and added
geometry to the face that you really don’t need. You're going to use the Split
Polygon tool to terminate that loop under the character’s chin while maintain-
ing the quad polys you're working with:

1. Press Q to exit the Insert Edge Loop tool.
2. Right-click on the model, and select Edge from the marking menu.

3. In the Perspective view, select the edge under the head block, as
shown in Figure 3.40.

FIGURE 3.40 Edgeselection

[ | 4. Delete the edge by choosing Edit Mesh > Delete Edge/Vertex.
Using Delete Edge/ 5. Right-click on your model, and select Object Mode.
Vertex ensures that

any leftover verts are
deleted along with the
edge. This helps pre-
vent accidental ngon
creation.
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6. Click the model to select it, and then hold down Shift and right-click
on the model. Drag to Split; then, when the menu changes, drag to
Split Polygon tool, as shown in Figure 3.41.

FIGURE 3.41 SplitPolygon tool menu

7. In the Tool Settings window, uncheck the Split Only From Edges
check box. Set Snapping Tolerance to 25, as shown in Figure 3.42.

Tool Settings

Split Polygon Tool Reset Tool Tool Help
Description

Draw a line across a face to split i nore new faces.

Settings

Divisions: 1 (vertices added per edge)

Smoothing angle: 0.0000 §

Split only fro
v Use snapping
Number of p 1 (1 = sn:

Snapping toles 25.0000

FIGURE 3.42 SplitPolygon tool settings

8. Click and drag the bottom edge of the cube to set the first point,
making sure the point is on the vertex where the edges meet. (Be
sure your new point is at the intersection of the two edges to keep
from creating ngons.) Then click in the center of the face to set the
second point. Finally, click and drag the edge where the neck shape
meets the head, as shown in Figure 3.43. If any of the points end up
where they shouldn’t be, press Delete and reset the point.
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irag on next edge. To finish

| RN

FIGURE 3.43 Settingedge points

9. Press Return/Enter to create the edge, as shown in Figure 3.44.

FIGURE 3.44 Edgecreated

10. Pressy to reselect the Split Polygon tool.

11. Set a point at the corner of the new edge and a second point on the
edge to the left.

12. Press Return/Enter to create the edge, as shown in Figure 3.45.
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FIGURE 3.45 Secondedge created

13. Repeat steps 1-12 on the other side of the head shape. The result is
shown in Figure 3.46.

FIGURE 3.46 Secondsplit complete

14. Return to the front of the model, and in edge selection mode, double-
click the edge shown in Figure 3.47.
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FIGURE 3.47 Edgeselected

15. Choose Edit Mesh > Delete Edge/Vertex to delete the selected edges.
The result is shown in Figure 3.48.

FIGURE 3.48 Extraedgesdeleted

www.LegendaryLibrary.Mihanblog.Com



Box Modeling and Building a Character 65

Shaping Your Character

Now that you have the basic geometry in place, you can begin sculpting it to
make it look more like the sketches on the image planes. Follow these steps:

1. In the Front and Side views, choose Shading > X-Ray, as shown in
Figure 3.49.

Shading Lighting Show Renderer

5

FIGURE 3.49 X-Rayshading

2. Right-click on the model in either view to bring up the marking
menu, and select Vertex.

3. Using the Move, Rotate, and Scale tools and working in the Front and
Side views, move the vertices on the model to more closely match the
contour of the sketches, as shown in Figure 3.50.

_ Someone once said
that when you're
modeling, you'll touch
every vert on the
model, sometimes
more than once. This
is very true. Just take
your time, refer to your
sketches often, and
keep in mind that the
FIGURE 3.50 Vertexadjustment goalis a nice, rounded
(not boxy) model.

4. Continue moving vertices around to make your character look more  [[KIGczGNGNG
like the sketches. Keep in mind that the shapes of the body should be
rounded looking, not square. After a lot of vertex moving, your model
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Make sure none of your
geometry is overlap-
ping when you're
finished moving verts.
It's especially easy

to overlap geometry
if you worked in the
smooth proxy mode,
50 be sure to go back
to poly view mode
and ensure that any
changes you've made
don’t create overlap-
ping geometry.
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should look similar to Figure 3.51. To see what your model will look
like when it’s smoothed, press 3 on your keyboard to create a smooth
proxy. You can reposition vertices with the smooth proxy on, but
take care not to move any vertex too far. Check your low-poly model
frequently by pressing 1 to return to poly view mode. In Figure 3.51,
another edge loop has been added between the top of the leg and the
lower torso loop to provide more control over the torso shape.

FIGURE 3.51 Modelaftersculpting: low poly (top) and smoothed (bottom)
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THE ESSENTIALS AND BEYOND

In this chapter, you modeled the main shapes for your character by using the Extrude, Insert
Edge Loop, and Split Polygon tools, along with moving vertices. This is the starting point for
all modeling done in Maya. When you're creating a model, it’simportant to keep the geometry
as light as possible, adding only as much as is absolutely necessary to create the shapes you
need. In the next chapter, you'll add details to the head.

Additional Exercises

» Model a prop for your character to use. Keep it simple, and use the techniques you
learned in creating your character model.

» Add some additional edge loops to parts of the character that will bend. Fingers, the
foot, and the torso are good candidates.
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CHAPTER 4

Modeling with
Polygons, Part 2

An important consideration when modeling is how your polygons are
organized and arranged. Your character will be animated using a couple of
kinds of deformations, so you have to create poly arrangements that will
deform well without causing surface problems. In this chapter, you’ll tackle
the facial details, including creating edge loops around facial elements so
they’ll deform well.

Creating edge loops

Adjusting vertices, polygons, and edges, and adding details

Creating Edge Loops

Edge loops are rings of edges that mimic the layout of muscles, in this case in
the face. When modeling, you want to create edge loops so that parts such as
mouth shapes and eyelids will work properly when you create facial expressions.
The finished edge loops you'll create in this chapter are shown in Figure 4.1.
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FIGURE 4.1 Facial edgeloops

Getting Started: Deleting Edges and Setting Tool
Options
Your first steps in creating facial details are to delete some edges you won’t need

and set up the Split Polygon tool, which you’ll use to create your edge loops:

1. Start with your model from Chapter 3, “Modeling with Polygons, Part 1,”
or open Ch4Start.ma. If you're using Ch4Start.ma, save the file to the
scenes folder in your project directory.

2. Zoom in on the front of the head, as shown in Figure 4.2. Select
Shading > Wireframe on Shaded in the View menu.

FIGURE 4.2 Yourstarting
point on the face
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Creating Edge Loops

3. Right-click on the model to bring up the marking menu, and
select Edge.

4. Select the three edges shown in Figure 4.3.

FIGURE 4.3 Edgeselection

5. From the Polygons menu set, choose Edit Mesh > Delete Edge/Vertex,
as shown in Figure 4.4.

Izﬂllml Proxy Normals Color

Show Modeling Toolkit

 Keep Faces Together
Extrude
Bridge
Append to Polygon Tool

oo

a

Project Curve on mesh

Split mesh with projected curve
Cut Faces Tool

Interactive Split Tool

Insert Edge Loop Tool

Offset Edge Loop Tool

Add Divisions

Slide Edge Tool

Transform Component

Flip Triangle Edge

Spin Edge Forward XE-
Spin Edge Backward N~
Edit Edge Flow C

ogooooooano

egEs]

Poke Face
Wedge Face
Duplicate Face o

oo

Connect Components o
Detach Component

Merge (m]
Merge To Center
Collapse

Merge Vertex Tool

Merge Edge Tool g
FIGURE 4.4 C(hoosing
the Delete Edge/Vertex option
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6. Deleting the edges has created an Ngon that you’ll break up by using
the Split Polygon tool. Right-click on the model, and select Object
Mode. Click on the object to select it, hold down Shift and right-click,
and drag to Split and then Split Polygon Tool, as shown in Figure 4.5.

FIGURE 4.5 Choosing Split Polygon Tool from the Hotbox

7. Verify that Split only from edges is unchecked in the Tool Settings win-
dow, as shown in Figure 4.6. Click on the X button to close the window.

FIGURE 4.6 SplitPolygon Tool
Settings window

Building Your Edge Loops

Now that you have your tool set correctly, it’s time to start creating edge loops
for the face:

1. Using the Split Polygon tool, lay out the edges shown in Figure 4.7.

www.LegendaryLibrary.Mihanblog.Com



Creating Edge Loops

FIGURE 4.7 Thefirstedges
of the edge loop

Press Return/Enter to create the new edges.

Press y to reactivate the Split Polygon tool, and create another new
poly, as shown in Figure 4.8.

FIGURE 4.8 C(reatingthe
second poly
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When you're placing
points on existing
edges, make sure
you're putting those
points directly on

top of the existing
vertices. If you miss,
you're creating Ngons.
Existing vertices are
located anywhere that
two edges connect. A
good way to make sure
you're placing points
on top of existing
vertices is to click and
hold a short distance
away from a corner and
then drag to the corner,
stopping when the
point stops moving.
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| 4. Repeat step 3 twice to create two more polys, one at a time, as shown
in Figure 4.9.

Occasionally, the Split
Polygon tool will place
the point you set on

the opposite side of

the polygon you're
working on. When this
happens, you'll click

to seta pointand see

no visual confirmation
that the point was
created. If this happens,
you can switch tem-
porarily to x-ray mode
(Shading > X-ray) to
see the points being set.

FIGURE 4.9 C(reatingtwo
more polys

5. Create another poly, as shown in Figure 4.10.

FIGURE 4.10 C(reatingthe
bottom-corner poly
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Creating Edge Loops

6. Continuing to use the Split Polygon tool, create a new split as shown
in Figure 4.11.

FIGURE 4.11 (reatingthe
initial split

7. Create three final splits that connect the edges on the Ngon all the
way to the center of the character, as shown in Figure 4.12.

FIGURE 4.12 C(reatingthe
final three splits
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8. To start the mouth loop, use the Split Polygon tool to create an edge,
as shown in Figure 4.13.

FIGURE 4.13 Beginning
the mouth loop

9. Create a quad poly for the outside of the mouth loop, as shown in
Figure 4.14.

FIGURE 4.14 Completing
the loop for the corner of the mouth
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Creating Edge Loops

10. Finish the mouth loop by extending it to the center edge, as shown in
Figure 4.15.

FIGURE 4.15 Mouthloop
completed

11. Select Edit Mesh > Insert Edge Loop Tool, and create another
edge loop around the mouth loop you just created, as shown in
Figure 4.16. To insert the loop, click on the vertical edge right above
the mouth loop you just created. This loop will allow you to shape the
lips later.

FIGURE 4.16 C(reatingthe
outer mouth loop
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12. Press q to exit the Insert Edge Loop tool. Using the marking menu,
switch to Face selection mode, select the two faces in the middle of the
mouth loop, and extrude them inward, as shown in Figure 4.17. If your
manipulator is at an angle, click on the Toggle Manipulators Switch as
you did in Chapter 3 and extrude the new faces straight back.

FIGURE 4.17 Extrudingthe
interior of the mouth

13. Select the two faces where the eye socket will be, and select Extrude.
Select scale mode, and scale using the center manipulator, creating a
new edge loop around the eye socket, as shown in Figure 4.18.

FIGURE 4.18 Extrudingthe
eye loop

www.LegendaryLibrary.Mihanblog.Com



Creating Edge Loops

14. Extrude the selected faces again, and move them inward to create the
eye socket, as shown in Figure 4.19.

FIGURE 4.19 Extrudingthe eye
socket

15. Tumble the view so you can see into the model from the left side of the
character, as shown in Figure 4.20. Select the face shown in the figure,
and press Delete. This face has to be deleted so that when you mirror
the character, the mouth is open without a face down the center.

FIGURE 4.20 Selectingthe
center face of the mouth

www.LegendaryLibrary.Mihanblog.Com

79



80

It'sa goodidea to
drag-select the vertices
you want to move. In
many cases, multiple
verts line up, and drag-
selecting is a good way
to get them all at once.

Chapter 4 -« Modeling with Polygons, Part 2

Adjusting Vertices, Polygons, and Edges,
and Adding Details

With all your edge loops are in place, you can begin sculpting your character to
create the facial features. You'll move existing verts and extrude new geometry
to build the features.

1. Switch to the Front view, turn on Shading/X-Ray as you did in
the preceding chapter, and choose Display > Polygons > Custom
Polygon Display. The Custom Polygon Display Options window opens,
as shown in Figure 4.21. Scroll to the bottom of the window, and turn
on Backface Culling. This setting hides the back faces of the model,
allowing you to work on just the vertices on the front of the model.

Apply and Close

FIGURE 4.21 TurningonBackface Culling

2. Move vertices around so the geometry of the character matches the
sketch on the view plane. When you’re finished, your model should
look something like Figure 4.22.

3. Select the face at the center edge between the eye loop and the
mouth loop.

4. Extrude the face and scale inward so the face looks similar to
Figure 4.23. This creates the base of the nose.
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FIGURE 4.22 Moving
vertices to match the sketch

Figure 4.23 has x-ray shading turned off for clarity. You can work
with it either on or off, as you prefer.

FIGURE 4.23 Extruding
the base of the nose
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5. Switch to the Side view, and extrude two more times. Scale each
extrusion to roughly follow the sketch on the view plane. When
you're finished, your model should look similar to Figure 4.24.

FIGURE 4.24 Extruding the nose

6. Using the marking menu, switch to vertex mode and reposition the
vertices on the nose shape to more closely match the sketch. Your
finished nose will look similar to Figure 4.25.

FIGURE 4.25 Adjustingthe nose verts

7. Tumble the Perspective view so you can see the inside edge of the
nose, and delete the three faces running down the middle of the nose
shape, as shown in Figure 4.26.
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FIGURE 4.26 Extranosefacestobe deleted

8. In the Side view, with XRay turned on, select the two faces nearest
the location of the ear in the sketch. If you need to move verts a bit
to make the faces align with the ear, feel free. The selected faces are
shown in Figure 4.27.

FIGURE 4.27 Selecting faces for the ear
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9. Just as you did with the nose, extrude a new set of faces, and scale
them inward to create the ear base, as shown in Figure 4.28.

FIGURE 4.28 Extrudingandscalinga poly for
the ear base

10. Switch to the Front view, and extrude again. Click on the Toggle
Manipulators Switch, if necessary, and pull out the new faces to cre-
ate a rough ear shape, as shown in Figure 4.29.

FIGURE 4.29 Earextruded
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11. Use the Insert Edge Loop tool to create a vertical edge loop similar
to the one in Figure 4.30. Move the ear verts around to create an ear
shape similar to the sketch.

FIGURE 4.30 Earedgeloop
inserted

12. Switch to Perspective view, and select the four faces in the cen-
ter of the front of the ear. Extrude, and scale inward, as shown in

Figure 4.31.

FIGURE 4.31 Earfacesscaled
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13. Extrude one more time, scale the faces slightly inward, and move
them toward the back of the ear, taking care not to move them
through the other ear faces. Figure 4.32 shows what this looks like.

FIGURE 4.32 Final earfaces positioned

Creating Eyebrows

Finally, you’ll create a new piece of geometry for the eyebrow, combining it with
the main model so Maya treats it all as one piece:

1. Create a polygon cube with the values shown in Figure 4.33.

FIGURE 4.33 Polygon cube values
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2. The cube appears near the middle of your character. Move it up to the
eyebrow position, and move verts around until you get a shape simi-
lar to Figure 4.34. Be sure to move the box to the front of the head
geometry.

FIGURE 4.34 Eyebrowgeometrysculpted

3. In Object Mode, select the eyebrow, and then Shift-select the main K
model. Select Mesh >Combine, as shown in Figure 4.35. This com- .
) The brow is modeled
mand tells Maya that all the selected geometry is to be treated as a e

single piece. tion than in the sketch.
This is to provide more
flexibility when creat-
ing blend shapes for
the eyebrow. The brow
is also bent slightly to
curve around the con-
tour of the character’s
head. These are classic
FIGURE 4.35 Mesha cartoony “floating”
Combine menu item eyebrows, which are
easier to create and
much more fun to work
with!

Combine
Separate
Extract

Booleans

Average Vertices

=}
>
Smooth o
o
o

Transfer Attributes
Dtk Tiaru ik Minichés Toal
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[ | 4. Switch to the Perspective view and tumble the view, looking at your
character’s face in both polygon and smooth mode, as shown in

Y tice that th .
I::dr:ﬁ);z;sl:;it:if_ ¢ Figure 4.36. Make any final tweaks you feel are necessary to get the
ferent than the sketch look you want.

in places. Sometimes
it’s necessary to alter
design elements in
order to make them
work in 3D. Anything’s
possible in a 2D sketch;
in 3D, the shapes have
to work on every axis.
Remember to toggle
between polygon view
and the smooth proxy
to check your work (1
and 3 are the keys that
toggle the view).

FIGURE 4.36 Character’sface
(poly view and smoothed)

www.LegendaryLibrary.Mihanblog.Com



The Essentials and Beyond

THE ESSENTIALS AND BEYOND

Creating edge loops around features such as the eyes and the mouth is essential to ensuring
proper deformation when you animate those shapes. You've also spent some time reposition-
ing vertices and faces to get elements of your model to match the design sketches as closely
as possible.

ADDITIONAL EXERCISES

» Turn on the Poly Count Heads-Up Display (Display > Heads Up Display > Poly Count), and, in
vertex mode, select some of the intersections where you started new edges. On the Verts line
of the Heads-Up Display (HUD), check the third column to see how many verts are selected.
Note the ones where the number is higher than 1—you’ll fix those in the next chapter.

» Add any additional features you'd like your character to have, using the eyebrow addition
method. Mustaches, ties, buttons, and many other details can be added using this technique.
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CHAPTER 5

Modeling with
Polygons, Part 3

Now that your character model is in pretty good shape and has facial
geometry that will deform well, it’s time for the last few steps that will pre-
pare the character for rigging and animation. You'll add some geometry to
ensure that your character deforms well once the skeleton is added, mirror
the existing geometry to complete the character, and delete the modeling
history.

Refining and cleaning up
Mirroring your model

Deleting history

Refining and Cleaning Up

You need to take some final steps to finish your character and get it set for
rigging. These procedures will make sure your character moves as well as
possible, eliminate any extraneous geometry, positions the character well for
rigging, and, of course, create the other half of the character.

Adding Geometry for Good Deformations

Before you complete the character by mirroring the existing half, you want
to be sure all the areas where bending will occur (elbows, knees, and so
forth) have enough geometry to support the bending. If there isn’t enough
geometry, the model will collapse in on itself. Here are the steps:

1. Open your model from the preceding chapter, or use
Chapter5Start.ma.
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92 Chapter 5 « Modeling with Polygons, Part 3

2. Select the Insert Edge Loop tool, and add edge loops to the elbow
area. You should have a total of three loops, as shown in Figure 5.1.

FIGURE 5.1 Elbowedgeloops

— 3. Add two more edge loops to the shoulder area, as shown in
Figure 5.2.

Don’t place your loops
too close together. In
order for them to work
asintended, there
needs to be a little
space between the
loops.

FIGURE 5.2 Shoulderedgeloops

4. Add two more edge loops to the wrist area, as shown in Figure 5.3.
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FIGURE 5.3 Wristedgeloops

5. Add edge loops to the hip, knee, ankle, and toe, as shown in
Figure 5.4.

FIGURE 5.4 Legedgeloops

6. Add an edge loop to the base of the foot to help flatten out the bot-
tom, as shown in Figure 5.5. The closer together edge loops are
arranged, the sharper the transition between them. The two loops
close together provide a flatter bottom surface for the foot.
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FIGURE 5.5 Footbaseedgeloop

7. Add edge loops to the neck and fingers, as shown in Figure 5.6.

FIGURE 5.6 Neckandfingeredge loops
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8. Make sure you have a few edge loops in the torso, as shown in
Figure 5.7.

FIGURE 5.7 Torsoedgeloops

9. Make any final changes to the geometry that you’d like. In the
smoothed proxy in Figure 5.8, the nose, arm, fingers, leg, foot, and
inside of the mouth have been resculpted to more closely match the
sketch. Also, another edge loop has been added around the lips to cre-
ate a sharper transition from the outside to the inside of the mouth.

FIGURE 5.8 Finalmodeling
adjustments
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Cleaning Up the Model

While you’re modeling, it’s easy for stray vertices to find their way into your
model if you either delete edges without using Delete Edge/Vertex or acciden-
tally click the mouse while using the Split Polygon tool. These extra verts can
cause problems when you rig your model for animation. To get rid of any extra
verts that may be in the model, you're going to do a merge operation:

1. Right-click on the model, and select Vertex mode.

2. Drag-select over the entire model to select all the vertices, as shown
in Figure 5.9.

FIGURE 5.9 Modelvertices
selected

3. Choose Edit Mesh > Merge > option box, as shown in Figure 5.10.

4. The Merge Vertices Options window opens. Set the Threshold value
to a very low number, such as 0.0010, as shown in Figure 5.11. Click
on the Merge button.
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IEH“EI Proxy Normals Color C

v Keep Faces Together
Extrude
Bridge
Append to Polygon Tool

oo

o

Project Curve on mesh

Split mesh with projected curve
Cut Faces Tool

Interactive Split Tool

Insert Edge Loop Tool

Offset Edge Loop Tool

Add Divisions

ooooooao

Slide Edge Tool

Transform Component

Flip Triangle Edge

Spin Edge Forward N~
Spin Edge Backward X

oo

Poke Face o
Wedge Face
Duplicate Face

oo

Connect Components o
Detach Component

Merge =]

Merge To Center
Callanca

FIGURE 5.10 Edit
Mesh a Merge a option box
menu choice

Merge Vertices Options_

Edit  Help

Settings

Threshold: |0.0010

+ Always merge for two vertices

FIGURE 5.11 MergeVertices Options window

5. Inspect your model carefully to make sure no verts intended to be K
on the surface of the model were accidentally merged. The geometry

. The Threshold number
of the model should look unchanged from what you built. If verts T ——
were merged, press z to undo, and repeat steps 3 and 4 with a lower are very close together
Threshold value. will merge, while leav-

ing verts that are far-
ther apart as they are.
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Positioning Your Character for Rigging

Although it doesn’t technically matter where your model is when you rig it, it’s
good modeling practice to have your character’s feet on the grid. Follow these
steps to position your character:

1. Switch to the Front view.

2. In the view window, select the Show menu, and turn the Grid option
back on. Figure 5.12 shows the location of the Grid option.

Isolate Select
All
None

+ NURBS Cus

FIGURE 5.12
Show a Grid option

3. Select your model in Object Mode.

4. Press w to activate the Move tool.
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5. The manipulator handle should be in the center of your character. If
it is, skip to step 8. If it’s not, press and hold the d key. The Move Pivot
tool appears, as shown in Figure 5.13.

FIGURE 5.13 Move
Pivot tool

6. Click the vertical handle, and drag so the Move Pivot tool is in the
middle of your character, as shown in Figure 5.14.

FIGURE 5.14 Pivottool moved
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7. Release the d key to deactivate the Move Pivot tool.

8. Click the Y move handle (the green arrowhead), and move your model
up so the feet are resting on the horizontal black line, as shown in
Figure 5.15.

[C T TT7F

i
|

FIGURE 5.15 Model moved

9. Choose Modify > Freeze Transformations, as shown in Figure 5.16.
This operation zeroes out the Move and Rotate values, making it easy
to reposition your model if necessary.

UL Create  Display  Window

Transformation Tools
Reset Transformations
Freeze Transformations

Y opv

Snap Align Objects
Al Toal

FIGURE 5.16
Freeze transformations

Adding Eyeballs

One last modeling task to tackle is to add eyeballs to your character. Because
they move independent of the body, eyeballs are nearly always created as sepa-
rate objects, which are then parented to the skeletal structure during rigging so
that they move when the head moves. To create an eyeball for your character,
perform the following steps:

1. Switch to the Front view, and zoom in on the model’s eye socket.
Press 3 to switch to smooth proxy mode.
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2. Turn on XRay mode by clicking on the button shown in Figure 5.17.

FIGURE 5.17 XRaymode button

3. Go to Create > Polygon Primitives, and turn on Interactive Creation.

4. Select Create > Polygon Primitives > Sphere, as seen in Figure 5.18.

NURBS Primitives
Polygon Primitives
Volume Primitives
Lights

Cameras

Cube
Cylinder
Cone

Dl

vvvldv|[

poooa

FIGURE 5.18 (reatePolygon Sphere
menu choice

5. Place your cursor in the center of the eye socket, and drag out a
sphere roughly the size of the socket, as shown in Figure 5.19.

FIGURE 5.19 C(reatingthe eyeball sphere
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6. Switch to the Perspective view, and move the eyeball into position in
the eye socket. Make any adjustments to the eye-socket vertices so
that the socket conforms to the surface of the eyeball, as Figure 5.20
shows. You want the eye socket to just touch the surface of the eye-
ball, not pass through it.

FIGURE 5.20 Eyesocketadjusted

Mirroring Your Model

With your model in place, you will finish it by mirroring the existing geometry
and attaching the copied geometry to the existing model. First, you’ll make
sure all the vertices along the center of your model are aligned with the 0 (zero)
point on the X axis. To do this, you're going to use a short Maya Embedded
Language (MEL) script:

1. Right-click on the main model, and select Vertex mode.

2. In the Front view, drag-select all the vertices along the centerline of
your character, as shown in Figure 5.21.
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Make sure you select
only the vertices along
the centerline. It may
help to switch to the
Perspective view and
tumble the view to see
all around the model.

FIGURE 5.21 Verticesselected

3. Locate the MEL window below the Range Slider, as shown in
Figure 5.22.

If Python appears
FIGURE 5.22 MELwindow next to the MEL win-
dow, click the word to
4. Type the following text into the MEL window: switch to MEL.
5. Press Return/Enter. This MEL command
moves all the selected
6. Choose Mesh > Mirror Geometry > option box, as shown in vertices to the 0 point
Figure 5.23. The Mirror Options window opens, as shown in on the Xaxis This
Figure 5.24. guarantees that all the
vertices are aligned at
0 X while keeping their
positions on both the Y
and Z axes.
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mEditMesh Proxy Normals Color

Combine =}
Separate
Extract

Booleans

Yo

Smooth
Average Vertices

Transfer Attributes

Paint Transfer Attributes Weights Tool
Transfer Shading Sets

Clipboard Actions

YEgo|ma

Reduce ]
Paint Reduce Weights Tool o
Cleanup...

Triangulate
Quadrangulate

Fill Hole

Make Hole Tool
Create Polygon Tool
Sculpt Geometry Tool
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0O 00oao

Mirror Cut
Mirror Geometry

]

FIGURE 5.23 Mirror
Geometry option

8.NO Mirror Options
Edit  Help

Settings

Mirror Direction:

Mirror

FIGURE 5.24 Mirror Options window

7. Set Mirror Direction to -X. Make sure the options Merge With The
Original and Merge Vertices are selected, and then click Mirror. The
model’s geometry is reflected across the Y axis and connected to the
existing geometry, completing the model as shown in Figure 5.25.
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FIGURE 5.25 Model mirrored

Notice in Figure 5.25 that some of the verts in the neck and mouth area have
been inadvertently merged into each other. This is because the Mirror function
has a preset merge threshold. Any verts closer together than the merge thresh-
old are automatically merged during the mirror operation. Fortunately, this is
easy to fix:

1. In the Channel Box, under Inputs, click on polyMirrorl to open
the node.

2. Click on the Merge Threshold value, and lower it to a very small
number like 0.01, as shown in Figure 5.26. Press Enter/Return. The
merged verts should separate and give you a result similar to the one
shown in Figure 5.27. If not, try a lower value until they do.

FIGURE 5.26
Merge Threshold value
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Occasionally, the mirror
function doesn’t mirror
correctly, leaving a gap
between the halves of
the character or over-
lapping the halves. If
that happens, undo the
mirror and complete
the “Deleting History”
procedure that follows,
and then try mirroring
again. Deleting the
modeling history will
often cause the mirror
operation to complete
successfully.

Chapter 5 « Modeling with Polygons, Part 3

FIGURE 5.27 C(orrectedverts

Deleting History

To prepare your model for rigging, you must delete the modeling history. If the
modeling history is retained, it can occasionally conflict with the deformers
used to animate the character, creating problems that can be tricky to solve.
Deleting modeling history removes one potential problem, making the task of
troubleshooting easier.

1. Select the model in object mode.

2. Look at the Channel Box, as shown in Figure 5.28. Every modeling
action you've performed is listed under INPUTS. Scroll down through
the list to see how much was done to create your model.

SHAPES
polySurfaceShape
INPUTS
polyMirrori
polyTweak13

polyTweak1t
polySpIltRIngST
polySplitRingss

FIGURE 5.28
Channel Box inputs
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3. Choose Edit > Delete By Type > History, as shown in Figure 5.29.

m Modify Create Display Window Assets Select Mesh El

Undo "select” ®Z
Redo ’Y
Repeat "SaveSceneAs" G
Recent Commands List Animation Dynamics. Rendering L
Cut 8X
Copy 8C
Paste £

Keys

Delete
Delete by Type

History
Delets All by Type Non-Deformer Histary

Select Tool
i ey Channels

FIGURE 5.29 DeleteByTypeaHistory

4. Check the Channel Box again. The inputs are gone, which means the
modeling history has been deleted. The result of Delete By Type is
shown in Figure 5.30.

polySurface1
Transiats X

SHAPES
polySuriaceShape1

FIGURE 5.30
History deleted
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THE ESSENTIALS AND BEYOND

In this chapter, you've tackled the cleanup steps that are necessary to prepare your model for
rigging. You added some edge loops to help with bending joints, did a cleanup pass to check
for stray verts, moved the character into position for rigging, mirrored, and deleted history.
Now your character is ready to be rigged.

ADDITIONAL EXERCISES

» Sometimes even deleting history won’t create a mirror that works correctly. If that happens,
you'll have to merge the verts along the centerline by hand. Select each pair of center verts,
and then choose Edit Mesh > Merge. Work your way around the centerline of the character,
merging as you go. Remember that pressing g performs the last command issued, a handy
shortcut when performing repetitive actions.

> Create the other eyeball for your character, either by using Create > Polygon
Primitives > Sphere or by duplicating the existing eyeball. DO NOT use Mirror Geometry,
as this will merge the eyeballs together and treat both spheres as one object.

» If you duplicate the existing eyeball, use Edit > Duplicate Special > option box, and make
sure Duplicate Input Graph is checked. Once you duplicate the eyeball, use the Move tool to
move it into the other eye socket.

» Make sure your character is facing the same direction as the positive Z axis. This is the
orientation that the Autodesk® Maya® software assumes the character is in for rigging. If
your character is facing another way, turn it so it’s facing the same direction as positive Z,
and do another Modify > Freeze Transformations to zero out the rotation values.
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CHAPTER 6

Surfacing Your
Character

Thus far, your character has been a uniform gray, the default surface
that the Autodesk® Maya® program assigns to all new geometry. Very few
animated characters are that color, however. To change the color of your
character, you'll create shaders in a process known as surfacing.

Creating a surface
Laying out UVs

Texture mapping

Creating a Surface

You can create two types of surfaces: those with a uniform color, and those
that use texture maps to add variety and detail to your character. Texture
maps are covered later in the chapter; before you can tackle them, you need
to know how to create surface types.

Using the Hypershade Window

The Hypershade window is a very powerful and flexible tool for creating
surfaces for your model. The following steps show you how to create a basic
colored surface:

1. Open your model from the end of Chapter 5, “Modeling with
Polygons, Part 3,” or use Ch6Start.ma.

2. Choose Window > Rendering Editors > Hypershade, as shown in
Figure 6.1.
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LULEETE Assets  Edit Curves  Surfaces  Edit NURBS Muscle NEX
Doc & j
Ceharal Edltare = Users/naasp/Documents/maya/proje
Rendering Editors > TR

Animation Editors > ;

= ; 7 Render Settings
Relationship Editors > FRrerhate
Settings/Preferences > mental ray »
Attribute Editor Render Layer Editor
Outliner Custom Stereo Rig Editor

Nede Editor
Create Node
Hypergraph: Hierarchy
Hypergraph: Connections O Hardware Render Buffer

Rendering Flags
Shading Group Attributes

Paint Effects
UV Texture Editor

Playblast

View Arrangement
Saved Layouts
Save Current Layout...

Frame All in All Views A
Frame Selection in All Views {tF

Raise Main Window
Raise Application Windows

FIGURE 6.1 Hypershade menuitem

3. The Hypershade window opens, as shown in Figure 6.2. On the left
are the different types of shader bases you can use for your surface,
and on the right are two windows that show the shaders currently in
the scene (on top) and the shader currently being worked on (at the
bottom).

FIGURE 6.2 Hypershadewindow

4. Create a new lambert surface by clicking the Lambert button on the
left side of the Hypershade window, as shown in Figure 6.3. The new
lambert surface is added to the shader list, and a thumbnail view of
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the surface is loaded into the work area at the bottom right of the
Hypershade window.

Hypershade

Create Tabs Graph Window Op

e @& e Show

Materials  Textures

= Anisotropic
* glinn
— Hair Tube Shader
Lambert
# \Layered Shader
#2) Ocean Shader
* Phong
* Phong E
&) Ramp Shader
Shading Map
Surface Shader Waork Area
Use Background [
(D Env Fog
& Fluid Shape
® Light Fog
Particle Cloud
@ Volume Fog
Volume Shader

# € Muscle Shader

FIGURE 6.3 C(reatinganewlambertsurface

5. Scale the Hypershade window (using the standard method for scal-
ing windows in your operating system) so you can see the main Maya
window. Open the Attribute Editor window by clicking the button at
upper right in the main window. The Attribute Editor shows the new
lambert2 surface, as shown in Figure 6.4.

FIGURE 6.4 Hypershadeand Attribute Editor windows
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6. Under Common Material Attributes, click the swatch next to the Color
attribute. A Color History window opens, as shown in Figure 6.5.

= Atrbute Edior

List Selected Focus Amributes Show Help

lambert2
lambert: lambert2
Sample

Color History
|}

|
,  EEEEE

S A P P B B

H: 0.000

|
|

S: 0.000

V: 0.500

b Special Effects

Notes: lambert2

FIGURE 6.5 ColorHistory picker window

7. Select a new color for lambert2, and then roll your cursor off the Color
History window to close that window. The thumbnails in the Attribute
Editor and Hypershade work area change to reflect the shader’s new
surface color, as shown in Figure 6.6.

FIGURE 6.6 lambert2withanew surface color
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8. Move (and scale if necessary) the Hypershade window so you can
see your model in the main Maya window. Middle-mouse-click
lambert2 in the Work Area window of the Hypershade window, and
drag your cursor over the model. Release the middle mouse button
(MMB). The lambert2 shader is applied to the model, as shown in
Figure 6.7.

= Anisotrop

* Blinn

* Phong E

2 Ramp Sha
Wark Area
Shading A

lambert2

v

e ) O P
=y

FIGURE 6.7 lambert2applied to the model

9. In the Attribute Editor, highlight the lambert2 text and change the
name of the shader to modelSurface, as shown in Figure 6.8. Notice
that the shader name on the tab in the Attribute Editor and in the
Work Area window of the Hypershade changed as well.
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lambert: modelSurface

Joyp;

Type |Lambert

J03p3 AANGUIIY

Common Material Auributes

> Special Effects

Notes: modelSurface

Load Antributes Copy Tab

FIGURE 6.8 Shadername changed

Using the Marking Menu
Another way to create and assign shaders to a surface is to use the marking menu:

1. In the Perspective view, click one of the eye spheres to select it, and
then right-click over the eye to bring up the marking menu.

2. Select Assign New Material, as shown in Figure 6.9.

FIGURE 6.9 Assign New Material option
in the marking menu
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3. The Assign New Material: pSpherel window opens, as shown in K
Figure 6.10. Click the Phong E option.
Phong and Phong E
_ surfaces have a specu-
!: Assign New Material: pSpherel lar component, which
gives the shiny quality
< anisotropic that an eyeball would
i have. Lambert surfaces
= T:: . don’t have a specular
# Layered Shader component.

5 Ocean Shader

* Phong

* Phong E

%) Ramp Shader
Shading Map
Surface Shader
Use Background

D Env Fog

© Fluid Shape

@ Light Fog

) builtin_bsdf_carpaint
) builtin_bsdf_lambert

) builtin_bsdf_mirror

) builtin_bsdf_phong

2 dgs_material

FIGURE 6.10 Assign
New Material: pSphere1 window

4. The Assign New Material: pSpherel window closes, and the Attribute
Editor opens. As you did previously, click the swatch next to the
Color attribute, and select a color for the eyeball. As you change the
color by using the Color History window, the surface of your model
changes as well. When you selected Assign New Material, the material
shader was assigned to the surface, and any changes to the shader are
automatically shown on the surface. Figure 6.11 shows the result of
the color selection. Rename the surface eyeball.
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FIGURE 6.11 Surface color changed

5. Select the other eye, and right-click to bring up the marking menu.
Select Assign Existing Material a eyeball, as shown in Figure 6.12. The
surface of the geometry now has the eyeball material applied to it.

You can assign shaders
to individual faces as
well as whole models.
You will do this laterin
the chapter. Right-click
the model, choose
Face, and select the
faces to which you
want to assign the
shader.

FIGURE 6.12 AssignExisting Material
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Laying Out UVs

Frequently you'll want to have more than just a solid color on some or all of
your model’s surface. You may want to add details such as a name patch, a pants
pocket, or some other detail that is too time-consuming or difficult to model
into the character’s geometry. One technique you can use to add detail to your
model is fexture mapping, whereby you create and assign a picture to the sur-
face of the model. This picture provides the detail that isn’t in the geometry
itself. Before you create a texture map, you have to lay out your model’s UVs.

Understanding the UV Space

UVs are like vertices, except UVs occupy a 2D space rather than a 3D one as ver-
tices do. Think about a box of cereal you buy at the store. When you get the box,
it’s three-dimensional with pictures and text on it telling you what’s inside. That
box, however, started out as a flat sheet of cardboard on which the image was
printed. Then the cardboard was folded into the 3D shape you see at the store.
The UV space is a 2D space where you lay out UVs so they'’re flat and can be more
easily textured. Laying out your UVs in the UV space allows you to put a complex
image onto the surface of the model. Figure 6.13 shows the UV space in Maya.

FIGURE 6.13 UVspace
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Performing the UV Layout

UVs are automatically created as you model, but frequently they’re not arranged
in a usable layout. Figure 6.14 shows the default UV layout of the model in the
ChéStart.ma file.

FIGURE 6.14 DefaultUVlayout

As you can see, it’s impossible to tell which UVs correspond to which part of
the model. Follow these steps to lay out your model’s UVs so you can tell which
ones are which:

1. Right-click the view window presets (just below the toolbox), and choose
Persp/UV Texture Editor, as shown in Figure 6.15. Your view windows
now show a Perspective window and the UV Texture Editor window.

FIGURE 6.15
Persp/UV Texture Editor layout selection
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2. Click the model. In the Polygons menu set, choose Create UVs >
Planar Mapping > Option Box, as shown in Figure 6.16.

(SCACNOEN Edit UVs  NEX  Muscle
e

Planar Mapping

Cylindrical Mapping
Spherical Mapping
Automatic Mapping

Create UVs Based On Camera
Best Plane Texturing Tool

000 ojsy

Assign Shader to Each Projection

Create Empty UV Set
Copy UVs to UV Set

Set Current UV Set...
Rename Current UV Set...
Delete Current UV Set
UV Set Editor

Per Instance Sharing »>

i)

FIGURE 6.16
Create UVs menu

3. The Planar Mapping Options window opens, as shown in Figure 6.17.
In the Project From options, select Z axis. Make sure Keep Image
Width/Height Ratio is checked, and click the Project button.

Planar Mapping Options

Edit  Help
Projection Manipulator

Fit projection to:

Project from.

Create new UV Set

Project

FIGURE 6.17 Planar Mapping Options window

4. The planar projection manipulator appears around the model, and
the UVs in the UV Editor window are laid out to reflect the projection,
as shown in Figure 6.18.
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FIGURE 6.18 UVsprojected (reference planes turned off for clarity)

[ | With a planar projection, the UVs on the front of the model overlap the ones
on the back. Usually that’s undesirable, because it means the texture map is

:z::?ppl:gte:: :::ap_ the same for all UVs that overlap. To keep that from happening, each set of UVs
pears, make sure the (known as a shell) should occupy its own area in the UV space. (In some cases,
model is selected, having UVs overlap is fine, such as when two parts of the model share the same
andthen gotothe texture.) To select, scale, and move a UV shell, follow these steps:

Channel Box and click

m}l’)lljf’Tl:narPrOH under 1. In the Perspective window, right-click the model, and select Face

from the marking menu. If the model is still in Smooth Proxy mode,
press 1 to switch to Polygon mode.

2. Select the faces on the hands and wrists, as shown in Figure 6.19.

FIGURE 6.19 Handfacesselected

3. Press Shift and the right angle bracket key several times to expand
the selection to include the whole arm, as shown in Figure 6.20.

4. Choose Create UVs > Planar Mapping > Option Box, select Y Axis
from the Project From options, and click the Project button. Your
arm UVs are projected as shown in Figure 6.21.
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Pressing Shift and >
expands your selection,
and pressing Shift and
< contractsiit.

FIGURE 6.20 Selectionexpanded

FIGURE 6.21 ArmUVsprojected

5. Click the yellow arrow in the UV window, and drag the arm UVs up to
the top of the UV space, as shown in Figure 6.22.

FIGURE 6.22 ArmUVsmoved
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6. Click anywhere in the Perspective view to deselect the projection.
Your UV Editor window should look something like Figure 6.23.

FIGURE 6.23 RevisedUV
space

7. You can place the UVs for the arms on top of each other, because
they’ll share the same texture map. This also frees some of the UV
space for other projections, as well as saves you time in painting
your textures. In the UV Editor window, right-click the arm UV
shell on the left, and select UV from the marking menu, as shown in
Figure 6.24.

8. Drag to select a few UVs in the arm shell, and then right-click again
and choose Select > Select Shell, as shown in Figure 6.25.

FIGURE 6.24 MarkingmenuinUV
Editor window
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FIGURE 6.25 Selecting the UV shell

9. With all the UVs in the shell selected, right-click the shell, and choose
Polygons > Flip > Option Box, as shown in Figure 6.26.

FIGURE 6.26 Polygonsa Flip
menu option

10. The Flip UVs Options window opens, as shown in Figure 6.27. Make
sure Horizontal is selected, and then click Apply And Close.

FIGURE 6.27 FlipUVsOptionswindow
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11.

12.

13.

14.

The UV shell flips horizontally and highlights. Click anywhere in the
Perspective window to deselect the shell and show all the model’s UVs
in the UV Editor.

Repeat step 8 to reselect the UV shell. Press w to select the Move tool,
as shown in Figure 6.28.

FIGURE 6.28 Shellselected, Move tool active

Click the red arrowhead, and drag the flipped shell on top of the other
arm shell, matching them as precisely as you can. Your UV Editor
window should look something like Figure 6.29.

FIGURE 6.29 UVshell moved

Continue selecting groups of faces and projecting planar UVs to sepa-
rate overlapping UVs. When you're finished, your UV space should
look something like Figure 6.30.
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As you project your
UVs, each set automati-
cally fills the UV space,
overlapping some of
the other UV shells.
You need to scale them
down. To do so, select
the shell as you did in
the preceding steps,
press r to activate the
Scale tool, and use

the center handle

to scale the shell
proportionately.

FIGURE 6.30 CompletedUV projections

15. To export an image of your UV layout for use in Photoshop or another
paint program, select your model in Object mode in the Perspective
view. Then, in the UV Editor window, choose Polygons > UV Snapshot,
as shown in Figure 6.31.

FIGURE 6.31
UV Snapshot menu option
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16. The UV Snapshot window opens. Set the Size X and Size Y options to
2048, as shown in Figure 6.32. Select Targa as the Image Format, and
click OK. The UV snapshot is sent to the images folder in the project
directory for your scene. The default name for the image is outUV.

UV Snapshot 1

FIGURE 6.32 UVSnapshotwindow

Texture Mapping

To create your texture map, you load your outUV image into a paint program
such as Adobe Photoshop, Corel Painter, or the open source GNU Image
Manipulation Program (GIMP), and create an image to be applied to your char-
acter, using the outUV image as a guide. It’s beyond the scope of this book to
provide instruction on using paint programs; loads of good books, videos, and
tutorials are available on the subject. This section provides a general overview
of how to put a texture map together, as well as specific instructions on how to
import a texture map into your scene and apply it to your character.

Creating a Color Map

A color map is what the name suggests: a texture map that provides the color
for your model. The following procedure describes how to create a color map in
general terms:

1. In a paint program (Photoshop, Painter, and so forth), open your
outUV image. Figure 6.33 shows outUV. tga open in Photoshop.
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FIGURE 6.33 outUV.tgain Photoshop

Create a new layer in the paint program, and begin creating your tex-
ture. Figure 6.34 shows a color map in progress.

orp o mraniineed 8 5 K o 1. K
Be sure you overpaint
a little when creating
your textures. The tex-
ture map has to come
to the edge of the UV
shellin order to fully
cover the model. So, it’s
usually a good idea to
go alittle beyond the
edge of the UV shell,
just to be certain there
are no gaps in your
texture map.

33 Doc: 12.04/22.9M
5] I 3 i

FIGURE 6.34 Painting the texture
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If youwork in
Photoshop to create
your color map, take
advantage of layers
and save your final
image as a PSD file.
Maya can import PSD
files, and any changes
you make to the color
map file automatically
appear in the Maya
scene.

Chapter 6 « Surfacing Your Character

3. Your color map can be as simple or as complex as you like. When
you're finished painting, save your file in the sourceimages directory
for your project. Figure 6.35 shows a simple color map.

[ Xal:) [
LR oo Jeoo oo

psd @ 33.3%
0 Jeoo. Joov Jeon oo Jeou [0 Jsouo [iios

EIETTIN ) Dux_12.0M/45.2M 3

FIGURE 6.35 Completedcolormap

Applying Your Color Map

Now that you have a color map, it’s time to apply it to the character and see
the result:

1. In Maya, click the character model.

2. In the Attribute Editor, locate the modelSurface tab and click it. You
may have to use the left and right arrows next to the tabs, as shown
in Figure 6.36.

3. Click the checkerboard button next to the Color attribute. The Create
Render Node window opens, as shown in Figure 6.37.
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FIGURE 6.36 modelSurface
tab in the Attribute Editor

FIGURE 6.37 C(reate
Render Node window

4. Click on the type of file you created (in this example, PSD File). The K
Attribute Editor window changes to show a psdFileTex1 tab, as shown .
K i If your texture is saved
in Figure 6.38. as a file type other than
a PSD, click on the File
button, and select your
texture file.
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Attribute Editor

List Selected Focus Attributes  Show

lleTex]l  place2dTexturel

¥ | xog [Puueyd

psdFileTex: psdFileTex1

File Attributes
Hardware Texture Cycling Options
Color Balance

Effects

UV Coordinates

Node Behavior

Extra Auributes

Notes: psdFileTex1

Load Attributes Copy Tab

FIGURE 6.38 psdFileTex1 tab

5. Click the arrow next to File Attributes to open that section of the
Attribute Editor window (if it’s not already open), and then click the
folder icon next to the Image Name field. The Open window opens, as
shown in Figure 6.39.

FIGURE 6.39 Openwindow
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6. Select your color map, and click the Open button. Your map is loaded
into the Image Name field, as shown in Figure 6.40.

psdFileTex: psdFileTex1

¥ File Auributes
Filter Type Quadratic |+
Pre Filter

Image Name sourceimages ftextureMap.psd

Reload Edit View

1 Composite

Use Cache

Notes: psdFileTex1

Select Load Attributes Copy Tab

FIGURE 6.40 Colormaploaded

7. In the Perspective view, choose Shading > Hardware Texturing, as
shown in Figure 6.41.

Shading Lighting Show Renderer

fault material

me on Shaded

Hardware Texturing
Hardware Fog

Apply Current to All

FIGURE 6.41
Selecting Hardware Texturing
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8. Click the model to select it. In the Attribute Editor, click the model-
Surface tab, and change the name of the surface in the Lambert field
to finalsSurface. Save your file.

Your texture should appear on the model in Perspective view. By laying out
your UVs and using that layout as a guide to painting your textures, the textures
appear correctly on the model when you assign the color map to the surface.
Figure 6.42 shows a smoothed version of the model with the texture applied.

If your texture map
doesn’t appear, it could
be due to your system’s
RAM (not enough to
display the texture)

or your video card.

To see the texture on
your model, click the
small clapboard icon at
the top of the screen.
Clicking thaticon
renders a frame of your
scene, which lets you
see the texture.

FIGURE 6.42 Modelwithcolortexture map applied

Applying Additional Surfaces

Your model can have more than one surface applied to the geometry. You prob-
ably noticed that the character’s eyebrows and the inside of his mouth are the
same color as the rest of the head. To correct this, you can create additional sur-
faces and apply them to those specific parts of the model:

1. Using the marking menu, select the faces that make up the eyebrows,
as shown in Figure 6.43.

2. Asyou did earlier in the chapter, right-click to bring up the marking
menu, and select Assign New Material.

3. Select a Lambert surface.
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FIGURE 6.43 Eyebrow facesselected

. In the Attribute Editor, click the color swatch, and pick an eyebrow
color you'd like to use.

. Rename the surface eyebrow. Figure 6.44 shows the eyebrows colored
and the surface name changed.

FIGURE 6.44 Finaleyebrow color

. Reposition your Perspective view so you can see into the character’s
mouth, and select the four faces across the back of the mouth.

. Hold down the Shift key, and press the right angle bracket once to
expand the selection to include all the faces in the mouth interior.

. Repeat step 2-5, but this time select a Phong E surface and rename
your new surface MouthInt.

www.LegendaryLibrary.Mihanblog.Com

133



134 Chapter 6 « Surfacing Your Character

9. Save your file. A smooth proxy view of the textured and surfaced
character is shown in Figure 6.45.

FIGURE 6.45 Modelwith multiple surfaces

THE ESSENTIALS AND BEYOND

Having a good UV layout is essential to being able to surface your model well. By laying out
your UVs and creating a texture map, you can add detail to the model that may not exist in
the geometry itself.

ADDITIONAL EXERCISES

P Create a UV layout and color map for the eyes. One map will probably do for both eyes,
although each eye needs its own UV layout.

P Try using some of the other UV projection types that are available and see what results they
create. A cylindrical projection, for example, is good to use on features such as the arm and
torso, whereas a spherical projection may be a good choice for the head.

» Once you apply your texture map and look at the smooth proxy, you may find areas where
the surface isn’t as you expected it to be. Feel free to go back and change your UV layout
to address these issues.
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CHAPTER 7

Getting Bent Out of
Shape: Blend Shapes

The next step in preparing your character for animation is to create

a deformer set and attach it to your main model. Deformers, known in
Autodesk® Maya® software as blend shapes, change the surface topology of
your model in ways you can mix, match, and control.

Understanding blend shapes and how they work
Creating deformers for your character

Setting up the blend shape interface

Understanding Blend Shapes and How
They Work

Blend shapes are frequently used for creating facial expressions—smiles,
frowns, eyebrow raises, blinks, and so on. They are essentially copies of your
main character geometry with specific, focused changes to a small part of
the geometry.

Deformer Order

A quick word about deformer order: Maya uses multiple types of deformers
to alter your model’s geometry, and the order in which those deformers are
applied makes a difference. Maya goes through the deformers in the order
they were applied, and later deformers can override earlier deformers if they
perform similar alterations.

The two main deformer types you'll apply to your model are blend shapes
and the skeleton you create in Chapter 8, “Dem Bones: Setting Up Your Joint
System,” and you should create them in that order. The skeleton won't affect
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what you're doing with the facial expressions, but the facial blend shapes will
definitely influence how the skeleton affects the model. It’s possible to reorder
the deformers, but it’s easier to create them in the right order in the first place.

Blend Shapes

Each vertex in your model has a unique number assigned to it, and the verts
are numbered in a particular order. Blend shapes work by checking the position
of the verts in a given blend shape and adjusting their position relative to that
vert’s position in your main model.

Because of this, it’s vital that you not add geometry to or delete geometry
from either the main model or any of your blend shapes after you've cre-
ated your blend shapes. If you do add or delete geometry, the vert numbering
changes, and the blend shapes will no longer work. If you need to make changes
to your geometry, you must do it before you create your blend shapes. For exam-
ple, you'll add a couple of edge loops to your existing model in order to give you
some additional geometry to work with:

1. Open your character model file from the end of the preceding chap-
ter, or use Ch7Start.ma.
You don’t need the image planes anymore, so choose Edit >
Delete All By Type > Image Planes to remove them from the scene.

2. Add an additional edge loop around the eye sockets, as shown in
Figure 7.1.

FIGURE 7.1 Neweyeloop
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3. Add an additional loop around the mouth area, as shown in
Figure 7.2.

FIGURE 7.2 Newmouthloop

4. Clear the modeling history by choosing Edit > Delete By Type >
History, as shown in Figure 7.3.

Undo "select”
Redo

Repeat "SplitEdgeRingTool"
Recent Commands List

Cut #X
Copy #8C
Paste ®’Y B

Keys

Delete
Delete by Type

Delete All by Type albitans

Non-Deformer History

Select Tool
Lasso Select Toal
Paint Selection Tool

Channels
Static Channels
Maotinn Paths

FIGURE 7.3 Deleting history

Creating Deformers for Your Character

Now that you have the geometry set, you can start creating your blend shapes.
To do that, you need to plan an approach for creating specific, flexible shapes
that you can use in various combinations.
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Planning for Facial Deformers

In general, blend shapes work best when they’re not trying to do too much.
Typically, you make blend shapes that focus on moving one small aspect of the
facial geometry rather than trying to create an entire expression at once. For
example, you can create blend shapes that move the corner of the mouth up and
down, and others that open and close the mouth, rather than creating one blend
shape that creates an open-mouth smile. It may seem like more work to create
focused, specific blend shapes, but the end result provides more flexibility and
options in how the blend shapes are used.

To prepare for creating blend shapes, make a list of the kind of movements
you need in your facial features. The example in this chapter focuses on the
mouth, so a list of mouth shapes might look like the following:

» Mouth corner up
Mouth corner down
Mouth corner in
Mouth corner out

Upper lip up

vV v.v v Vv

Upper lip down
» ...andsoon

You'll also create blend shapes for the eyebrows, so create a list of possible
blends:

Inner brow up
Inner brow down
Mid brow up

Mid brow down

Outer brow up

vV v v v v Y

Outer brow down
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Creating Your Facial Blend Shapes
To create your mouth blend shapes, perform the following steps:
1. Select the model in Object mode.

2. Rename the model Base by using the Channel Box, as shown in
Figure 7.4.

Channel Box / Layer Editor

Channels Edit Object Show

Visibility on

SHAPES
BaseShape
INPLITS

FIGURE 7.4
Base model renamed

3. Choose Edit > Duplicate, as shown in Figure 7.5.

Igil Modify Create Display

Undo "select” %z
Redo "Duplicate” ®Y
Repeat "Duplicate” G

Recent Commands List

Cut 38X
Copy ®C
Paste LA

Keys >

Delete
Delete by Type
Delete All by Type >

v

Select Tool

Lasso Select Tool

Paint Selection Tool

A

Deselect

Select Hierarchy

Invert Selection Rk
Select Similar

Select All by Type >
Quick Select Sets 13

Duplicate

Duplicate Special {8DO
Duplicate with Transform {D
Tramck ik Lal

FIGURE 7.5
Duplicating the Base model
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4. Select the Move tool (w key), and move the copy of the model to the
right of the original, as shown in Figure 7.6.

Because the eyeballs
are separate objects
and will be animated
as part of the main
model, you don’t have
to copy them for your
blend shapes.

FIGURE 7.6 Model copy moved

5. Zoom in on the mouth area of the copy, and select the vertices at
the corner of the mouth on the character’s left side (screen right), as
shown in Figure 7.7.

When you select the
verts to adjust, make
sure you select only
the verts you intend
to move. Rotate the
view and/or use x-ray
mode to be sure you
don’t have any extra
verts selected. If you
accidentally select and
move other verts, they FIGURE 7.7 Verticesselected
become part of your
blend shape.

6. Move the verts, both as a group and individually, to move the corner
of the mouth up, as shown in Figure 7.8.

7. Select the model in Object mode, and rename it mouthCnrUpLt in the
Channel Box, as shown in Figure 7.9.
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FIGURE 7.8 Verticesmoved

It'simportant to
rename your blend
shapes as you go.

The name the blend
interface displays for
each shape is the name
assigned to the geom-
etry. It’s also important
to establish a naming

FIGURE 7.9
Blend shape renamed

convention that effi-
. L . ciently describes what
8. Select Base, and create another duplicate, this time by pressing the blend shape does
Command/Ctrl + D. and to use that conven-
tion throughout.

9. Move the duplicate over so it’s next to mouthCnrUpLt, as shown in
Figure 7.10.

FIGURE 7.10 Secondduplicate created
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10. Repeat steps 5 and 6 on the right corner of the character’s mouth
(screen left), creating a blend shape that is a mirror of the first one, as
shown in Figure 7.11.

It's good practice to
create all your dupli-
cates from the Base
model. Because Base
is the model you want
the blend shapes to
affect, it'sa good idea
to create your blends
from a direct copy of
that model.

FIGURE 7.11 Leftandright mouth cornerup blend shapes

11. Rename the new blend shape mouthCnrUpRt in the Channel Box, as
you did for the previous blend in step 7.

12. Create two more duplicates from Base, and adjust the verts at the
corners of the mouth to move them down, as shown in Figure 7.12.
Name the new blend shapes mouthCnrbnLt and mouthCnrDnRt.

FIGURE 7.12 Leftandright mouth corner down blend shapes
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13. Continue duplicating the original geometry and creating blend shapes
for your mouth. Some suggestions for additional blends are as follows:

» Upper lip up
Upper lip down
Lower lip up/down

Corner in (toward center of mouth)

vV v.v Vv

Sneer (using the verts between the center of the mouth and the
corner)

14. Once you have the mouth blends you want, create some blends for the
eyebrows. This eyebrow set will give you great flexibility and expression:

» Inner brow up (left and right)
Inner brow down (left and right)
Mid-brow up (left and right)
Mid-brow down (left and right)

vV v.v Vv

Outer brow up (left and right)
» Outer brow down (left and right)

Figure 7.13 shows a selection of blend shapes for the mouth and brows, with
the original Base model highlighted on the far left of the top row. Looks a little
like a chorus line, doesn’t it? As you can see, the number of models you need for
creating blend shapes can add up quickly.

FIGURE 7.13 Blendshapescreated
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Setting Up the Blend Shape Interface

After you have all your shapes created, it’s time to create the blend shape inter-
face that will allow you to apply one or more blends to the main model. To cre-
ate the blend shape interface window, follow these steps:

1. Select your blend shapes one at a time, Shift-selecting as you go.
Finally, select your Base model. Figure 7.14 shows the results of the
selection process.

The order in which
you select your blend
shapes is the order in
which the controls will
appear in the Blend
Shape window.

FIGURE 7.14 BlendshapesandBase selected

2. Switch to the Animation menu set, as shown in Figure 7.15.

FIGURE 7.15
Animation menu set

3. Choose Create Deformers > Blend Shape, as shown in Figure 7.16.

4. Click anywhere in the scene to deselect the blend shapes and the Base
model.

5. Select the Base model, and press f on the keyboard to zoom in on the
model. Then zoom in closer on the face.
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8 Edit Defor... Skeleto

m}
Lattice o
Wrap (m]
Cluster o
Soft Modification ®BW O
Nonlinear >
Sculpt Deformer o
Jiggle Deformer o

Jiggle Disk Cache
Jiggle Disk Cache Attributes

Wire Tool o
Wire Dropoff Locator o
Wrinkle Tool o
Point On Curve o

FIGURE 7.16
Creating the blend shape interface

6. Choose Window > Animation Editors > Blend Shape, as shown in
Figure 7.17.

IEILEEEN Assets  Animate Geometry C... Create Def... Edit D|

£ Doc P
Ceneral Editors > E/nazsn/Documents/maral
Rendering Editors » g
AmmtlunEdw!rs > Graph Editor
Relationship Editors > di
Settings/Preferences » HaiiEion

Camera Sequencer
Attribute Editor Dope Sheet
Outliner Humanlk

Node Editor Blend Shape

Create Node
L L b

Expression Editor

FIGURE 7.17 BlendShape menuselection

7. The Blend Shape window opens, as shown in Figure 7.18.

8.N6 8lend Shape

Edit Options Help

~ blendShapel
Delete
Add Base
Key All
Reset All

0.000 0.000 0.000 0.000 0.000

WwOUtDNRE WMIDNRt "owinDnRt wOUtUpRt  wMidUpRt

Key Key ey Key Key

FIGURE 7.18 BlendShapeinterface window

8. Move the Blend Shape window so you can see your Base model.
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9. Move the sliders in the Blend Shape window, and observe how the
sliders affect the Base model, as shown in Figure 7.19. The model is in
smooth proxy mode to better show the results of the blend shapes.

FIGURE 7.19 Blendshapesapplied to the Base model

THE ESSENTIALS AND BEYOND

Blend shapes are one type of deformer you can use to affect the surface of your model. With
the blend shapes you created, you can animate facial expressions. Animating facial expressions
is covered in Chapter 12, “Making It Move: Animating Your Character.”

ADDITIONAL EXERCISES

D After you've created your blend shape interface, you can delete the blend shape models
from your file, and the blend shapes will continue to work. Be sure to save a copy of your
file containing the blend shape models in case you need to make changes.

» You can add new blend shapes after the interface is created. Create your new blend shape
from a copy of the Base model, as before. Select that new blend shape and then the Base
model, and then choose Edit Deformers > Blend Shape > Add.

» You can also create new blend shapes from your existing blend shapes! Move the sliders in
the Blend Shape window to generate the expression you want to make into a blend shape,
and then select your Base model and duplicate it. The duplicate will have the expression
you created “baked in.” Add the new blend shape to the interface as described in the pre-
ceding bulleted item.
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CHAPTER 8

Dem Bones: Setting
Up Your Joint System

Now that your blend shapes are complete, you can add the skeleton, or
joint system, to the model. The skeleton’s job is to animate larger segments
of your character, such as the arm or the head.

Understanding how joints work
Building joint chains
Putting it all together

Putting it to use: connecting the joints to your model

Understanding How Joints Work

Joints in a 3D model work pretty much like joints in your body do—you
rotate a joint, and some portion of your body moves as a result. However, in
a 3D model you can have joints rotate in ways that they never could in your
body. You can have an elbow joint that rotates in more than one direction,
for example.

Joints function by influencing vertices on the surface of the model.
Typically, joints are used for rotation and mimic the joints in a human or
animal body. Although they can be used for translation, this happens rarely.

Joints have the potential to influence any vertex on the surface of your
model, no matter how far the vertex is from the joint. Therefore, you have
to take care in setting up your skeleton, as you will in this chapter, and in
weighting the vertices to the joints in your model, as you will in Chapter 9,
“Weighting Your Joints.”
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Joint chains—like
weighting and rigging,
which are discussed in
later chapters—can
get very complex. The
details of building a
complex skeleton can
(and do) fill an entire
book. The concepts
presented here are the
essentials you need to
know to build a basic
skeleton.

Chapter 8 « Dem Bones: Setting Up Your Joint System

Building Joint Chains

You're going to build a few joint chains, name the joints, and place them in vari-
ous sections of the model as you go. You build the skeleton in pieces by using
these joint chains so they’re easier to place in the parts of the model they’re
designed to influence.

Picking the Correct View for a Chain

When you're creating a joint chain, you should carefully pick the view in which
you create that chain. You want to select the view that provides the most infor-
mation about where the joints in that chain should be positioned. Typically, this
is the view that shows the most detail about a feature in the model. For that rea-
son, you will use the Side view to create the spine/neck/head joint chain, as well
as the leg chain. For the arm/hand chain, you will use the Top view. Both views
are shown in Figure 8.1.

FIGURE 8.1

Views used to create joint chains

Starting in the Middle (of the Character)

The first joint chain you’ll create is the chain for the spine, neck, and head. This
is the chain all the other chains will hook into to create the overall skeleton, so
it’s a good place to start. Follow these steps:

1. Open your file from the end of the preceding chapter, or use
Ch8Start.ma.
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2. Place the cursor in the Perspective window, and tap the spacebar
to go to a four-panel view. Place the cursor in the Side view, tap the
spacebar again to maximize the Side viewport, and zoom in on the
model so the torso and head fill the viewport, as shown in Figure 8.2.

To match the look

of theillustra-

tions in the rest of

the chapter, select
Shading > Wireframe
on Shaded in the Side
viewport.

FIGURE 8.2 Sideviewport maximized

3. Turn on X-Ray view by choosing Shading > X-Ray or by clicking the
X-Ray button, both shown in Figure 8.3.

FIGURE 8.3 X-Rayview
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4. Switch to the Animation menu set, shown in Figure 8.4.

FIGURE 8.4
Animation menu set

5. Choose Skeleton > Joint Tool, as shown in Figure 8.5.

S GG Skin - Constrain  Char

Joint Tool o
IK Handle Tool o
IK Spline Handle Tool o
Insert Joint Tool

Reroot Skeleton

Remove Joint
n laiat

FIGURE 8.5
Joint tool

6. In the Side viewport, place the crosshair cursor at the character’s pel-
vis area, and click to create a joint, as shown in Figure 8.6.

FIGURE 8.6 Pelvisjoint
positioned

www.LegendaryLibrary.Mihanblog.Com



Building Joint Chains

7. Continue up the character, placing three or four joints in the torso
area, as shown in Figure 8.7.

FIGURE 8.7 Spinejoints
positioned

8. Place a joint at the base of the neck, another at the base of the head,
and a final joint at the top of the head, as shown in Figure 8.8. When
all your joints are in place, press Return/Enter to create the joint
chain, as shown in Figure 8.9.

FIGURE 8.8 Headandneck
joints placed
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Place your joints where
you want the rotation
to occur. This generally
means you need to
position them on edge
lines and at the points
where the model
should bend. That'’s
why you placed the
spine joints closer to
the back of the model.

You can adjust the

size of the joints

inthe display by
selecting Display >
Animation > Joint Size
and adjusting the slider
toincrease or decrease
the size of the joint
display. This doesn’t
affect how the joints
behave atall.
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Part of what a joint
does is orient the previ-
ous joint in the chain.
That’s why you created
afinal joint at the top
of the head. You won't
use this joint for any
rotation, but it's neces-
sary to orient the head
joint.

FIGURE 8.9 Torsojoint
chain created

9. Switch to the Front view, turn on X-Ray as described previously, and
check to make sure the first joint you created (the pelvis joint) is inside
the model geometry. If it’s not, select it with the Move tool and move it
so that it is. Figure 8.10 shows the pelvis in the correct position.

FIGURE 8.10 Pelvispositioned

10. Return to the Side view, and make any necessary adjustments to the
joint positions to return them to where you placed them initially. Use
the Move tool to position the joints.
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Naming Joints

It’s important to name joints as you go. Naming joints makes it clear which
joint does what and makes it easier to create copies of the leg and arm joints to
use on the other side of the character:

1. Select the pelvis joint. The entire joint chain highlights, but only the
pelvis joint is actually selected.

2. In the Channel Box, select the joint1 label above the channel values,
as shown in Figure 8.11.

Channel Box / Layer Editor

Channels Edit Object Show

Jjoine1]

FIGURE 8.11
Joint name selected

3. Type pelvis to rename the joint and press Return/Enter. The joint is
renamed, as shown in Figure 8.12.

FIGURE 8.12
Joint renamed

4. Continue up the joint chain, renaming the joints. In the example, the _

joints are named spinel, spine2, spine3, spine4, neck, head, and TEnEs e

headEnd. down arrows on your
keyboard to move up
and down the joint
chain.
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Creating the Leg Chain

Next, create the joint chain for one leg:

1. Still in the Side viewport, reposition the view so the hip and leg area
fill the view, as shown in Figure 8.13.

FIGURE 8.13 Leggeometryin Side view

. Select the Joint tool again by pressing the y key (or from the

Skeleton > Joint Tool menu).

. Being careful not to click the pelvis joint, click to set a joint in the

hip area, as shown in Figure 8.14.

. Work your way down the leg, creating joints for the knee, ankle, foot,

toe, and toe end, as shown in Figure 8.15. Press Return/Enter to cre-
ate the joint chain.

. Rename the joints as you did with the torso joints. The names used

in the example are as follows:
> hiplLt
» kneelLt

» anklelLt
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» footLt

> toelt

» toeEndLt

When you have joints
that are repeated on
the opposite side of the
character, it’simpor-
tant to indicate the
side where the joints
belong. Naming con-
ventions vary, but they
usually include the
joint name and either
Lt orRt toindicate
which side of the body
they’re on.

FIGURE 8.14 Firstlegjointpositioned

FIGURE 8.15 Legjointscreated
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Don’t move any of the
leg joints other than
the hipLtjointin
the Front view. The
joints need to stay
aligned on the Y axis
for the leg IK you'll be
setting up in Chapter
10, “Rigging Your
Character.” /K, or
inverse kinematics,
is a technique used

to keep parts of the
character in place
while joints higher up
the chain can still be
rotated. In this case,
the leg joints will

be set up with IK to
keep the foot in place
while the knee and hip
rotate.

Chapter 8 « Dem Bones: Setting Up Your Joint System

6. Switch to Front view. Notice that the joint chain has been created
on the 0Y axis, as shown in Figure 8.16. Select the hipLt joint, and
use the Move tool to move the joint chain into the character’s left leg
geometry, as shown in Figure 8.17.

FIGURE 8.16 Leftlegjoints before move

FIGURE 8.17 Leftlegjointsafter move
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Creating the Arm Chain

Finally, create a joint chain for the arm and hand:

1. Switch to the Top view. Zoom and reposition the view so the hand,
arm, and part of the torso are visible, as in Figure 8.18. As you did in
the Side view, turn on X-Ray view.

FIGURE 8.18 Topview positioned

2. Select the Joint tool again by pressing the y key (or from the
Skeleton > Joint Tool menu).

3. Being careful not to click on any existing joints, click to set a joint in
the mid-back area between the spine joints and shoulder, as shown in
Figure 8.19. This is your clavicle joint.

FIGURE 8.19 C(laviclejoint created
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4. Moving down the arm, create a shoulder joint, an elbow joint, and a
wrist joint, as shown in Figure 8.20.

FIGURE 8.20 Shoulder, elbow, and wrist joints created

5. Continue down the hand, creating joints in the middle of the palm
and down the middle finger, as shown in Figure 8.21.

Don't forget: if your
joints appear too large
in the view, you can
adjust their display size
by choosing Display >
Animation > Joint
Size and adjusting the
slider. The display size
of the joints doesn’t
affect their function
atall.

FIGURE 8.21 Firsthandjoints created

6. Press the up arrow on your keyboard to return to the wrist joint.
Then begin setting joints again, this time going down the index fin-
ger, as shown in Figure 8.22.

7. Press the up arrow on your keyboard to return to the wrist joint
again. Then set joints down the little finger, as shown in Figure 8.23.
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The purpose of the
mid-palm joint is to
decrease the distance
between the wrist and
the first finger joint.
This makes it easier to
set up hand deforma-
tions, as you'll doin
Chapter9.

FIGURE 8.22 Indexfingerjoints created

FIGURE 8.23 Llittle-fingerjoints created

8. Press the up arrow to return to the wrist again, and create joints for
the thumb, as shown in Figure 8.24.

FIGURE 8.24 Thumbjoints created

www.LegendaryLibrary.Mihanblog.Com



160

Chapter 8 « Dem Bones: Setting Up Your Joint System

9. Press Return/Enter to create the joint chain, as shown in Figure 8.25.

10.

FIGURE 8.25 Armjoint chain created

Switch to the Front view, select the shoulder joint, and move the
arm joint chain up into the left arm of the model, as shown in
Figure 8.26.

FIGURE 8.26 Armchain moved

. As you can see in Figure 8.26, some of the joints aren’t in the right

position inside the model because of the model’s surface. Rotate
joints as necessary to get the joints into the center of the model, as
shown in Figure 8.27. Rotate on only one axis at a time; and it may be
helpful to use the Perspective view, moving around the model for the
best view as you work.
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After you're finished
rotating a joint, choose
Modify > Freeze
Transformations with
the joint still selected
to reset the joint’s
rotation value to zero.
It'simportant that the
joint’s rotation be zero
in case you have to
reset the joint during
animation.

FIGURE 8.27 Armchainadjusted

12. Time to rename the joints. Here’s a list of the joint names in the
example:

» clavlt
shldrlLt
elbwlLt
wristlt
idxPalmLt (the palm joint for the index finger)
jdxBaselt
idxMidLt
idxTipLt
jdxEndLt
midPalmLt
midBaselLt
midMidLt
midTipLt
midEndLt
1tlPalmLt
1t1Baselt

1tMidLt

vV V. vV vV vV vV VvV V. VvV V. V. Y vV VvV Vv Vv Y

1t1TipLt
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TtlEndLt
thmbBaselt
thmbMidLt

thmbTipLt

vV v.v v Vv

thmbEndLt

Putting It All Together

Now that you have a named joint chain for the torso and one arm and leg, it’s time
to create the remaining chains and connect everything into one joint system.

Mirroring Joint Chains

The Autodesk® Maya® software allows you to mirror a joint chain across a
specified axis. This saves you the time and trouble of creating duplicate chains
for parts like arms and legs. Follow these steps to mirror the chains:

1. In the Perspective view, turn on X-Ray, and zoom in on the charac-
ter’s legs, as shown in Figure 8.28.

FIGURE 8.28 Preparing tomirror
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2. Click the hipLt joint, and choose Skeleton > Mirror Joint > Option
Box. The Mirror Joint Options window opens.

3. Determine which axis you need to mirror across by looking at the
axis widget in the bottom-left corner of the view window. In this
example, the axis is the YZ axis (you’ll mirror over the axis that runs
down the center of your character).

4. Make sure Mirror Function: Behavior is selected, but don't click the
Mirror button yet.

Using Variables for Naming

Here’s where typing Lt over and over again pays off. You can identify a charac-
ter string within the joint names and have it replaced with another character
string. In this case, you will replace Lt (for left) with Rf (for right):

1. In the Mirror Joint Options window, type Lt into the Search For field.

2. Type Rt into the Replace With field. The completed window is shown
in Figure 8.29.

Mirror Joint Options.

FIGURE 8.29 Variable namesinserted

3. Click the Mirror button. Maya creates a duplicate joint chain inside
the right leg of the character, as shown in Figure 8.30, with the joints
renamed.

4. Reorient the view window so you can select the clavLt joint, as
shown in Figure 8.31.
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FIGURE 8.30 Mirroredjoint chain created

FIGURE 8.31 cavltjointselected

5. Press g on your keyboard to repeat the Mirror command, and create
an arm chain for the right side of your character. The result is shown
in Figure 8.32.

FIGURE 8.32 Right-side arm chain created
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Connecting All Your Chains

With all your joint chains created and named correctly, you can now connect
them all together into one joint system. Follow these steps to parent the leg and
arm chains to joints in the torso chain:

1. Zoom in on the pelvis and hip joints, as shown in Figure 8.33.

FIGURE 8.33 Pelvisandhipjoints

2. Select the hipLt joint, and then Shift-select the pelvis joint, as
shown in Figure 8.34.

FIGURE 8.34 hiplLtand pelvis joints selected
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3. Press the p key on your keyboard to parent the hipLt joint to the
pelvis joint. The result is shown in Figure 8.35.

The order in which

you select the joints
determines which is
the parent and which
is the child. The pe1-
Vi s joint should be
the parent. You can
tell which joint is the
parent by determining
which joint is next to
the large end of the
bone geometry. The
large end indicates the
parent. If the small end
of the bone is nearest

the pelvis, select the FIGURE 8.35 hiplLTand pelvis joints parented

hipLt jointand press

Shift + P to unparent, 4. Repeat steps 2 and 3 on the right side, parenting the hipRt joint to
and then try again. the pelvis joint. The result is shown in Figure 8.36.

FIGURE 8.36 hipRtand pelvis joints parented
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5. Scroll up so you can see both clavicle joints and the top spine joint
(the one just before the neck joint). Repeating the process you used
in steps 2 and 3, parent the clavicle joints to the top spine joint. The
result is shown in Figure 8.37.

FIGURE 8.37 C(lavicleand spine joints parented

6. Your skeleton is now complete. Figure 8.38 shows the model with the
skeleton highlighted.

FIGURE 8.38 C(ompletedskeleton
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Putting It to Use: Connecting the Joints to
Your Model

The joints are now set up in a hierarchy that can control your model’s deforma-
tion nicely. The final step in this chapter is to attach the joints to the model’s
geometry, in a process called skinning, so rotating a joint causes the model to
bend in response. You will also attach the eyes to the skeleton via parenting.

Using Smooth Bind

You will use the Smooth Bind option to attach the joints to the model. Smooth
Bind allows any given vertex on the model to be influenced by more than one
joint, something that’s desirable when you'’re rigging a character. Frequently
you'll want to have more than one joint influence the vertices near a joint so
that the bends happen more smoothly and naturally.

Skinning Joints to Your Model

To skin the joints to your model so that rotating a joint affects the model’s
geometry, follow these steps:

1. Select the pelvis joint. Shift-select the character mesh, as shown in
Figure 8.39.

e L et

FIGURE 8.39 Skeletonand mesh selection

2. From the Animation menu set, choose Skin > Bind Skin > Smooth
Bind > Option Box, as shown in Figure 8.40.
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Detach Skin

= Interactive Skin Bind O
Go to Bind Pose ~ Rigid Bind o

Edit Smooth Skin
Edit Rigid Skin

FIGURE 8.40 Selectingthe
Smooth Bind option box

3. The Smooth Bind Options window opens. Set Bind Method to
Closest Distance, set Max Influences to 1, and uncheck Maintain
Max Influences. The settings are shown in Figure 8.41.

FIGURE 8.41 SmoothBindOptions settings

4. Click the Bind Skin button.

The character mesh turns purple to show the mesh has been bound to the
joints, as shown in Figure 8.42. Click a joint, and then select the Rotate tool and
rotate the joint to see how it now affects your model, as shown in Figure 8.43.

FIGURE 8.42 Meshbound tojoints
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Rotate as many joints
asyou like, but be sure
to reset their rotations
to 0,0, 0 when you're
finished. There is still
more setup to do, and
it works best if the
joints are in their rest
positions when the
work is done.

FIGURE 8.43 Jointsaffecting the model

Parenting the Eyes to the Skeleton

Because the eyes are separate from the main character model, they aren’t cur-
rently connected to the skeleton. You can parent the eyes to the head joint so
that when the head rotates, the eyes move with the head and stay in the eye
sockets:

1. Click either eye, and then Shift-click the head joint. The selection
should look like Figure 8.44.

FIGURE 8.44 Eyeandheadjointselection
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2. Press p to parent the eye to the head joint.

3. Repeat steps 1 and 2 for the other eye. Rotate the head joint to ensure
that the eyes are parented correctly.

THE ESSENTIALS AND BEYOND

Setting up joints can be a time-consuming, precise task, but it’s an important step in the rig-
ging process. Extra time spent getting it right means fewer problems when you start animating
your character.

ADDITIONAL EXERCISES

» Experiment with the other types of bind options available, and see what kinds of results
they produce. For instance, how is the bind different if you choose Closest In Hierarchy
instead of Closest Distance?

» The Max Influences setting determines the maximum number of joints that can influence
any given vertex on a model. You set this to 1in order to make the weighting steps that
follow in Chapter 10 easier to complete. Try setting Max Influences to another number, and
then rotate a few joints in your character and see how the character mesh reacts differently.
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CHAPTER 9

Weighting Your Joints

After your joints are influencing the surface of your model, they need to
be weighted so they cause smooth, pleasing deformations when the joints
are rotated. This chapter describes how weighting works and how to weight
your joints so they deform your model in the way you want.

Understanding joint weighting and why it’s important

Adjusting weights

Understanding Joint Weighting
and Why It’s Important

Painting skin weights is a vital step in the rigging process. Appropriate skin
weights, or the amount of influence a joint has on a given vertex, are crucial
in creating a character rig that deforms the model in a pleasing and convinc-
ing way.

Joint Influence on Deformation

Every joint in a skeleton has the potential to influence every vertex on the
surface of the model. In fact, every joint does influence every vertex on the
model, but sometimes that influence is zero. The amount of influence a joint
has over a vertex will determine how much or how little that vertex moves
when the joint is rotated.

Every vertex on the surface of a model must have a fofal influence of 1, or
100%. That influence can be assigned to only one joint, a couple of joints,
or many joints, but the total influence on a vertex can be only 1. So if Joint1
has 70% influence on a vertex, and Joint2 has 30% influence on the same
vertex, then that vertex will be displaced significantly more when Joint1 is
rotated than when Joint2 is rotated. If the influence on a vertex from a joint
is 100%, that vertex will move when that joint is rotated, and only when that
joint is rotated.
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In the Autodesk® Maya® software, one way joint weights are displayed is with
a grayscale surface on the character, using black, white, and a range of grays.
When vertices have white underneath them, they’re influenced 100% by the
current joint. When they have black under them, they aren’t influenced at all.
When the shading under a vertex is gray, it means the selected joint is influ-
encing that vertex at something less than 100%. The closer to white the gray
is, the more the joint is influencing the vertex; the closer to black, the less the
influence.

Why You Used the Options You Did at the End
of the Last Chapter

You'll remember from the end of Chapter 8, “Dem Bones: Setting Up Your

Joint System,” that you set Max Influences to 1 and turned off Maintain Max
Influences. With these settings, every vertex on your model is currently influ-
enced by only one joint, but that influence can be redistributed to more than
one joint. This style of binding makes it much easier to redistribute weights over
two or more joints. If you had set Max Influences to 2 or higher, there would
likely be weight on multiple joints, making it more time-consuming to adjust
the joint weights to create smooth, pleasing deformations.

Adjusting Weights

In order to get your model to deform well, you have to make adjustments to the
weighting Maya did automatically. Although this is a time-consuming process,
the tools Maya provides are easy to use and do the job well. You will use the Paint
Skin Weights tool to adjust your weights. To select the tool, choose Skin > Edit
Smooth Skin > Paint Skin Weights Tool > Option Box, as shown in Figure 9.1.

2148 Constrain  Character Muscle NEX Pipeline Ca... Help]

Bind Skin
Detach Skin

Co to Bind Pose

Add Influence

Remove Influence

Set Max Influences...
Move Skinned Joints Tool

Interactive Skin Bind Tool
Paint Skin Weights Tool
Export Skin Weight Maps...

FIGURE 9.1 Selecting Paint Skin Weights
tool options
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Strategies for Assigning Weights

When assigning and adjusting weights on your model, there are some effective
approaches that work very well, get the weights the way you want them, and
don’t cause additional work for you.

Remember, every vert has to have a total weight of 1. Therefore, it’s impossible
to “erase” weight by lowering the influence to 0. Any weight you remove from
a given vert in this manner has to go to some other joint in the rig, and that’s
dangerous. You could end up with random parts of your model moving when
you rotate the joint, which is undesirable.

To avoid this, a good strategy is to only add weight to a vertex, never remove
it. If you need to lower the influence of a joint on a vert, select a nearby joint in
the chain and add weight to that joint. Adding weight to another joint automati-
cally removes it from the joint with too much influence. In the exercise in this
chapter, you’ll see this strategy in action. To adjust weight on your model, you’ll
use two of the paint operations: Add and Replace.

Paint Skin Weights Tool—Add

The Add operation, shown in Figure 9.2, adds the current Value setting, also
shown, to the vertex being painted, up to a value of 1. This tool can only
increase the value on a vert.

Tool Settings

Reset Tool Tool Help

Select Geometry
* Add

Smooth

FIGURE 9.2 PaintSkin Weights
Add operation
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Paint Skin Weights Tool—Replace

The Replace operation, shown in Figure 9.3, replaces the current value on a vert
with the value in the current Value setting. This tool can reduce values if the
value currently on the vert is higher than the replacement value, so take care
that you're replacing with a higher value than the value currently assigned. A
good way to check values is with the Eyedropper tool, also shown in Figure 9.3.
Click the Eyedropper, and then click the vert you want to check. The Value slider
resets to the vert’s current value.

Tool Settings

Reset Tool Tool Help

Replace
Operation

Eyedropper
Tool.

FIGURE 9.3 PaintSkin Weights
Replace operation

Painting Your Weights

Every character is different, and how the weights on your specific character are
distributed will depend on the structure of the model and your goals for how the
character will deform. The following exercise shows how to distribute weights
and some strategies for working efficiently. To see the example model with com-
pleted weights, check out Ch9Finish.ma.

Follow these steps:

1. Open Ch9Start.ma.

2. Select the model geometry.
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3. From the Animation menu set, choose Skin > Edit Smooth Skin >
Paint Skin Weights Tool > Option Box. The model turns black and
white, and the Tool Settings window opens, as shown in Figure 9.4.

FIGURE 9.4 PaintSkin Weights tool selected

4. Zoom in on the character’s left elbow. Select the elbowLt joint from
the joint list in the Tool Settings window, as shown in Figure 9.5.

FIGURE 9.5 Leftelbowselected

As the figure shows, the elbow influence (white areas) is also dis-
tributed to the wrist area, and part of the elbow has no weight at
all from the elbow joint (the black area under the verts nearest the
shoulder). You'll add some weight to those verts so the verts between
the elbow and shoulder are influenced by two joints. You'll also redis-
tribute some weight from the wrist joint to the elbow joint.
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178 Chapter 9 « Weighting Your Joints

5. Near the middle of the Tool Settings window, select the Solid Brush
profile, and set Normalize Weights to Interactive, as shown in
Figure 9.6. Click Yes in the pop-up window that appears.

FIGURE 9.6 SolidBrush profile
selected, and Interactive Normalize Weights selected

6. If necessary, scroll the Tool Settings window and select Replace as the
Paint Operation, and set the Value slider to 0.5, as shown in Figure 9.7.

FIGURE 9.7 Selectingthe
Replace operation
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7. Hover your cursor over the character geometry. The brush icon
appears—a red circle with an R in the center. Reduce the size of the
brush by holding down the b key and dragging left until your brush is
small enough to touch only one row of verts, as shown in Figure 9.8.

FIGURE 9.8 SizingtheReplace brush

8. Click and hold the LMB, and drag the paintbrush icon over the verts
in the elbow edge loop nearest the shoulder. Reposition the view, and
paint the weights on the back side of the arm as well. As you paint
over the verts, the geometry turns gray, indicating that it is now
influenced 50% by the elbow joint. Figure 9.9 shows the completed
paint operation.

FIGURE 9.9 Elbow vertspainted

www.LegendaryLibrary.Mihanblog.Com



180 Chapter 9 « Weighting Your Joints

9. Reset the Value slider in the Tool Settings window to 1.0, and paint
any verts in the next edge loop over (closer to the wrist) that have
black beneath them, as shown in Figure 9.10. The completed paint
operation for these verts is shown in Figure 9.11.

FIGURE 9.10 Unpainted elbow verts

FIGURE 9.11 Painted elbow verts

10. Select wristLt from the Influences list in the Tool Settings window.
The wrist loop nearest the elbow should have black under the verts,
as shown in Figure 9.12.

11. Reset the Value setting to 0.5 in the Tool Settings window.
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12.

13.

Hold down the b key, and left-click and drag to resize your brush. Paint
the verts in the wrist loop nearest the elbow, as shown in Figure 9.13.

FIGURE 9.12 Wristverts

FIGURE 9.13 Wristverts painted

Switch back to the elbwLt joint by using the Tool Settings window,
and observe how the verts at the first wrist loop are now gray instead
of white, as shown in Figure 9.14. By adding influence to those verts
for the wrist joint, you automatically reduced the influence of the
elbow joints on the same verts.
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FIGURE 9.14 Elbowloop painting complete

14. With elbwLt selected in the Tool Settings window, click the Lock but-
ton at the left side of the window, shown in Figure 9.15. This locks
the weights for the elbow as they currently are, so they can’t acciden-
tally be changed.

o (o) o o | B3 Y (1

FIGURE 9.15 Elbow weightslocked

15. Continue painting weights for every joint on the left side of the
character as well as the spine and head. As you get each weight the
way you want it, lock the weight to the joint as you did in step 14.

To see how the weights are affecting the surface, rotate the joint
you're working on and observe the surface deformation. When you're
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finished checking the rotation, select the model and click the Paint
Skin Weights tool icon in the Last Tool Used slot of the Toolbox, as
shown in Figure 9.16, and continue weight-painting for any joints
that still need adjusting.

FIGURE 9.16

Paint Skin Weights
tool in the Toolbox

Mirroring Weights

Painting weights is a time-consuming, exacting process. Fortunately, you have

to paint only half your character, because Maya has a tool that mirrors your skin

weights to the other side of the character:

1. Select the model geometry.

2. Choose Skin > Edit Smooth Skin > Mirror Skin Weights > Option Box,
as shown in Figure 9.17. The Mirror Skin Weights Options window opens.

t13UB Constrain Character Muscle NEX Pipeline Ca... Help

Bind Skin
Detach Skin

Go to Bind Pose

Add Influence

Remove Influence

Set Max Influences...
Move Skinned Joints Tool

| Interactive Skin Bind Tool

Paint Skin Weights Tool

R{ Export Skin Weight Maps...
o Import Skin Weight Maps...

Mirror Skin Weights
Copy Skin Weights
Smooth Skin Weights

Meinht Hammer

FIGURE 9.17 Mirror Skin Weights Options
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In order for Mirror
Skin Weights to work,
your character has to
be centered over the
0Y axis. If your model
isn'tin the center of
the Maya scene, the
mirror function won’t
find comparable verts
on theright side of the
model and won’t com-
plete successfully.

Chapter 9 « Weighting Your Joints

3. Select the options shown in Figure 9.18, and then click Mirror. The
skin weights on the left are mirrored to the right side of the model.

Mirror Skin Weights Options

Edit Help
Mirror across
ection: v Po

Surface Assoclation: @ point on surface

ponent
Influence Association 1: Closest joint | v

Influence Association 2: |Nene 2

Normalize

FIGURE 9.18 Mirror Skin Weights Options settings

THE ESSENTIALS AND BEYOND

Skin weighting is a vital part of the rigging process, because it ensures that the surface of the
model deforms appropriately. It can be a time-consuming process, but it also can be approached
like a puzzle to solve by determining just how much weight from each joint should be applied
to each vertex.

ADDITIONAL EXERCISES

» One way to speed up the weighting process is to slightly rotate the joint you're working
with before weighting. With the joint rotated, you'll see the verts move as you change the
weighting, giving you an idea of how the weight you're assigning will affect the surface of
the model. After you're finished, be sure to reset the joint to 0 rotation on all three axes.

» This process can be overwhelming, especially when you're starting out. If you're having
trouble getting your weights the way you want them, try practicing with a cylinder. Create
a cylinder with 10-12 loops around the circumference, and put a joint structure inside it,
then weight the surface to the joints. Practicing with simpler geometry can make it easier
to get the concepts down.
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CHAPTER 10

Rigging Your
Character

With your skeleton in place and attached to your model, the next step is
to rig your character for animation. Character rigging creates controls for
making rotating joints easier and speeding up your animation workflow.

Understanding basic rigging concepts
Setting up the leg controls

Setting up the torso control

Setting up the character control

Creating a custom shelf

Understanding Basic Rigging Concepts

Before you get started, it’s helpful to understand the two types of joint rota-
tion you'll be working with: forward kinematics and inverse kinematics.
Kinematics describes the motion of objects and groups of objects without
considering the force that moves those objects—in other words, how the
joints in your character rotate, without worrying about what drives that
rotation.

Forward Kinematics

Forward kinematics (FK) uses a joint higher up the hierarchy to move the
joints farther down the hierarchy. For example, the shoulder joint, when
rotated, moves the elbow and wrist joints along with the shoulder. FK is
automatic when setting up a joint hierarchy—all the joints in your charac-
ter’s skeleton currently use FK for rotation.
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Character rigs can get
very complex. Whole
books are written on
the process of creating
sophisticated rigs. The
rig you'll construct here
is a simple, functional
rig that will familiarize
you with basicrigging
practices.

Chapter 10 « Rigging Your Character

Inverse Kinematics

With inverse kinematics (IK), you use a joint farther down the hierarchy to
rotate joints higher up in the joint chain. An IK chain has a defined length, and
the joints are all controlled by an IK handle, which when moved rotates the
joints in the chain.

IK is great for things like legs, where feet need to stay in place on the ground
when a character crouches down. The IK handle is left in place, and by moving
or rotating other joints in the model outside of the IK chain, you can bend the
character’s leg without the foot moving, something nearly impossible to achieve
with an FK chain.

Setting Up the Leg Controls

Using IK in a character’s legs is a requirement in any rig in order to keep the
character’s feet in contact with the surface on which he/she/it is standing. You'll
use IK chains to set up your character’s leg so that it can stay in place and still
have the foot and knee rotate as you want them to.

Creating Leg IK Chains

IK chains are relatively straightforward to create. You will use a total of three
chains in your character’s leg and foot. Follow these steps:

1. Open your weighted character file from the end of the preceding
chapter, or use Ch16Start.ma.

2. To make the joint chains easier to see and select, go to the Show
menu in the Perspective view, and uncheck Polygons, as shown in
Figure 10.1.

Isolate Select

FIGURE 10.1
Show > Polygons unchecked
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3. Zoom in on the left leg joint chain, as shown in Figure 10.2.

FIGURE 10.2 Leftlegjointchain

4. From the Animation menu set, choose Skeleton > IK Handle Tool >
Option Box, as shown in Figure 10.3.

Skeleton

Joint Tool

1K Handle Tool

IK Spline Handle Tool o
Insert Joint Tool

Rercot Skeleton

Ramonua lnint

FIGURE 10.3
IK Handle Tool menu item

5. In the Tool Settings window, select ikRPsolver from the Current
Solver drop-down menu, as shown in Figure 10.4.

FIGURE 10.4 ikRPsolverselected
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6. Your cursor is now a crosshair. Click the left hip joint, skip over the
knee joint, and click a second time on the ankle joint. Your first IK
chain is created, as shown in Figure 10.5.

The Rotation-Plane
solver allows you to
rotate the joint chain.
The practical applica-
tion of this is that you
can rotate the knee
from side to side. The
Single-Chain solver
doesn’t allow for this
kind of rotation.

FIGURE 10.5 FirstlK chain created

7. Pressy on the keyboard to reselect the IK Handle tool. Click the
ankle joint, skip over the foot joint, and click a second time on the
toe joint. Your second IK chain is created, as shown in Figure 10.6.

FIGURE 10.6 SecondIK chain created
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8. Pressy to reselect the IK Handle tool. Click the toe joint, and click a
second time on the toeEnd joint. Your third and final IK chain is cre-
ated, as shown in Figure 10.7.

FIGURE 10.7 ThirdIK chain created

9. Your leg IK chains are complete. If you select all three IK handles
(the three-pointed icons that appeared at the end of each chain) and
select the Move tool, you can move the foot around, the knee bends
in response, and the movement stops at the hip, or the top of the first
IK chain. The moved foot is shown in Figure 10.8. After you're fin-
ished moving the foot (it Zs fun, isn’t it?), undo your moves to return
the foot to its rest position.

10. Repeat steps 6-9 on the right leg joints to create IK chains for the
right leg.

FIGURE 10.8 LegjointsunderIK control
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Creating an External Control Handle

Selecting all three IK handles on either leg every time you want to move the leg
is too time-consuming, so you will create an external control and connect it to
the handles. Then, by selecting one control, you select all the handles for a leg
with one click. Here are the steps:

1. Turn the model’s geometry back on temporarily by clicking the Show
menu in the Perspective view and rechecking Polygons, as shown in
Figure 10.9.

v
v
&
v
v
v
v
v
)

FIGURE 10.9
Show > Polygons checked

2. Choose Create > NURBS Primitives > Interactive Creation
to uncheck that option, then choose Create > NURBS
Primitives > Circle, as shown in Figure 10.10.

(&I Display Window Assets Animate Geometry C... Cr
NURES Primitives S e

Polygon Primitives zzl';;re E
\;ul;:me Primitives S 5
el Cone o
Cameras s s
CV Curve Tool Trs o
EE SupveiT ool o
Square o

Bezier Curve Tool
Pencil Curve Tool
Arc Tools

Interactive Creation
v Exit On Completion

Measure Tools

Scene Assembly

t
Adobe(R) lllustrator(R) Object...

Construction Plane
Free Image Plane
Locator
Annotation...

oo oo Y Y Yoooo YYY UM

Empty Group
Sets

FIGURE 10.10 Create > NURBS
Primitives > Circle
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3. Select X-Ray from the Perspective view’s Shading menu to make the
model transparent.

4. Move and scale the NURBS circle so that it surrounds the left-foot
geometry of the character. When you're finished, you should have
something that looks like Figure 10.11.

FIGURE 10.11 NURBScircleinplace

5. Choose Modify > Freeze Transformations, as shown in Figure 10.12.
This zeros out the move information and makes the control easy to
reset if necessary.

LLEDVM Create Display  Window)

Transformation Tools
Reset Transformations
Freeze Transformations

Y gog¥

Snap Align Objects
Align Tool
Snap Together Tool

Evaluate Nodes

Make Live

Cantar Divnt

FIGURE 10.12
Modify > Freeze Transformations

6. In the Channel Box, click the text nurbsCirclel, and rename the
circle footCtrlLt, as shown in Figure 10.13.
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FIGURE 10.13
Foot control renamed

7. Duplicate the circle (Edit > Duplicate), and move the duplicate circle
so that it surrounds the right foot, as shown in Figure 10.14. Rename
this circle footCtrlRt.

FIGURE 10.14 NURBScircle duplicated and moved

8. Choose Modify > Freeze Transformations to reset the move informa-
tion to zero.

Connecting the IK Chains to the Handle

To connect the IK chains to the handle you just created, perform the following
steps:

1. Uncheck Polygons in the Perspective view’s Show menu.

2. On the left leg, click the IK handle at the toeEnd joint, and then
Shift-click the IK handle at the toe joint. Press p on the keyboard to
parent the toeEnd IK handle to the toe IK handle.
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3. Click off the handles to deselect them.

4. Click the toe IK handle, and Shift-click the ankle IK handle. Press p
to parent.

5. Click off the handles to deselect them.

6. Finally, click the ankle IK handle, and Shift-click footCtrlLt. Press p
to parent the ankle IK handle to the NURBS circle. The NURBS circle
now controls all three IK handles.

7. You need to adjust the position of footCtr1Lt’s pivot point. Select the
NURBS circle. Press and hold the d and v keys on your keyboard. The
d key activates the pivot point Move tool, and the v key snaps the pivot
point to a joint when you move it. With d and v pressed, your pivot point
Move tool should look like Figure 10.15.

FIGURE 10.15 Pivotpoint Move tool

8. Click and hold in the center of the pivot point Move tool, and move
the pivot point to the ankle joint, as shown in Figure 10.16. Release
the d and v keys. The pivot point of footCtrlLt is now at the ankle.

FIGURE 10.16 Pivotpoint moved

9. Repeat steps 2 through 8 on the right leg.
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Using Pole Vector Constraints for Controlling
the Knee

Next, you'll create another control and apply a pole vector constraint to it so the
knee moves when the control does:

1. Choose Create > Locator, as shown in Figure 10.17.

(&, -F1CH Display Window Assets

NURBS Primitives
Polygon Primitives
Volume Primitives
Lights

Cameras

CV Curve Tool

EP Curve Tool
Bezier Curve Tool
Pencil Curve Tool
Arc Tools

Measure Tools
Scene Assembly

Text

Adobe(R) lllustrator(R) Object...

oo go Y ¥ Ygooog YYYYY

Construction Plane
Free Image Plane
Locator
Annotation...

Empty Group
Sets >

FIGURE 10.17
Create > Locator menu

2. With the Move tool selected, press and hold the v key to turn on snap-
ping. Click and hold in the center of the Move tool, and move the
locator to the left knee, as shown in Figure 10.18.

FIGURE 10.18 Locatorsnapped to the
knee joint
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3. Using just the Z-axis handle, move the locator forward to in front of
the knee, as shown in Figure 10.19.

FIGURE 10.19 Locatormoved

4. With the locator selected, choose Modify > Freeze Transformations,
to zero out the move information.

5. Using the Channel Box, rename the locator kneeCtr1Lt.

6. With the locator still selected, Shift-click the ankle IK handle and
choose Constrain > Pole Vector, as shown in Figure 10.20.

(-1 1L Character NE)

Parent

Geometry
Normal
Tangent
Point On Poly
Closest Point

Pole Vector

0o ooooo ooooollfé

Remove Target
Set Rest Position
Modify Constrained Axis...

FIGURE 10.20
Constrain > Pole Vector menu
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7. A connection is established between the pole vector on the IK handle
and the locator, as shown by the line connecting the two. Now, mov-
ing the locator rotates the pole vector, which in turn rotates the
knee, as shown in Figure 10.21.

FIGURE 10.21 Polevectorrotated

8. Repeat steps 1 through 6 for the right leg.

Setting Up the Torso Control

Next to the feet, the torso is probably the part of your character you’ll move the
most. Your next rigging step is to set up a control similar to the foot controls for
the torso.

Creating the Torso Control Handle

The torso control attaches to the pelvis joint and allows you to move the char-
acter’s hips. To create the control handle, perform the following steps:

1. Make the polygons of your model visible by checking Polygons in the
Perspective window’s Show menu.

2. Create another NURBS circle by using the Create menu.
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3. Holding down v to turn on snapping, move the NURBS circle to the
pelvis joint.

4. Scale the circle so it’s outside the model geometry, as shown in
Figure 10.22.

FIGURE 10.22 Torsocontrolscaled

5. Choose Modify > Freeze Transformations to zero out the move infor-
mation and reset scaling for the circle to 1.

6. Using the Channel Box, rename the circle torsoCtrl.

7. Using the Perspective window’s Show menu, uncheck Polygons.

Connecting the Torso Control

With the torso control created, the next step is to attach it to the pelvis joint
using the following procedure:

1. Select the pelvis joint. Shift-click torsoCtr1, and press p on your
keyboard to parent.

2. Test your leg IK. Click torsoCtr1, and move it down toward the feet.
The pelvis joint and everything above it should move down, but the
feet should stay in place, and the legs should bend as the torso moves
down. Figure 10.23 shows torsoCtr1 moved downward.
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FIGURE 10.23 torsoCtrl moved

3. Reset the Translate values on torsoCtr1 to zero using the Channel Box.

Setting Up the Character Control

It’s convenient to have one control to click that moves the entire character and
all its controls to a new location or positions the character at the beginning of a
shot. The final control you'll create moves all the controls at once.

Creating the Character Control Handle

To create the character control handle, which moves the model and all its con-
trols, follow these steps:

1. Create a NURBS circle by using the Create menu.

2. Scale the circle so it encompasses the foot controls, as shown in
Figure 10.24.

3. Using the Channel Box, rename the NURBS circle charCtr1.

4. Choose Modify > Freeze Transformations to reset the values for the
circle.
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FIGURE 10.24 Charactercontrol scaled

Connecting the Character Control Handle

The next step is to connect the character control handle to the rest of your rig.
Follow these steps:

1.

S o »d w N

Select kneeCtr1Lt. Shift-click footCtrlLt, and press p on your key-
board to parent the knee control to the foot control.

Repeat step 1 for the right knee and foot controls.
Select footCtrlLt. Shift-click charCtrl, and press p.
Repeat step 3 for the right foot control.

Select torsoCtr1l. Shift-click charCtr1, and press p.

Select charCtrl, and move the character in the scene. All the other
controls should move along with the character.
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Creating a Custom Shelf

Another way to easily access controls is to create a custom shelf for your charac-
ter. The following procedure takes you through creating a shelf and button; the
number of buttons you create depends on your particular character:

1. Click the small down arrow above the Toolbox window, to the left of
the shelf window, and select New Shelf, as shown in Figure 10.25.

FIGURE 10.25
New Shelf menu

2. In the pop-up window that appears, shown in Figure 10.26, type in a
name for your new shelf. Click OK.

@ " O Create News.

Enter new shelf name

RudyShelf

oK Cancel

FIGURE 10.26
Shelf naming window

3. Click the Script Editor button in the lower-right corner of the inter-
face, as shown in Figure 10.27, to open the Script Editor window.

I« 4 » »| > =l

No Character set = [

E

Script Editor button

FIGURE 10.27
Script Editor button location
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4. In the Script Editor window, choose Edit > Clear History, as shown
in Figure 10.28.

FIGURE 10.28 C(learScript Editor history

5. In the scene window, select the left shoulder joint. A line of code
appears in the Script Editor window, as shown in Figure 10.29.

FIGURE 10.29 Jointselected
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The amount of space
for text on a button

is very limited. Keep
the names you give
the buttons as short as
possible.

Chapter 10 « Rigging Your Character

6. Highlight the line of code in the Script Editor window, and click the

Save Script To Shelf button, as shown in Figure 10.30.

File Edit History Command Help

FIGURE 10.30
Save Script To Shelf button
location

7. A pop-up window appears, as shown in Figure 10.31. Type shdLt in

the text field, and click OK.

Enter Name of New Shelf item

shdLt

oK Cancel

FIGURE 10.31
Button-naming window

8. Another pop-up window appears, as shown in Figure 10.32. Click the

MEL button.

Q. Save script to shelf as type:

Python MEL

FIGURE 10.32
Script type window

. The new button appears on your custom shelf, as shown in

Figure 10.33. If the button doesn’t immediately appear, click the tab
for another shelf and then return to your custom shelf.
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FIGURE 10.33
New shelf button

10. Click anywhere in the scene to deselect the joint. Click the new shelf
button. The left shoulder joint is again selected.

THE ESSENTIALS AND BEYOND

In this chapter, you learned some of the basics of rigging. Rigs can be very simple or mind-
bogglingly complex, but they all share the same goal—to make the animation process as
smooth and effortless as possible.

ADDITIONAL EXERCISES

» You used simple NURBS circles for control handles, but anything can be used as a control.
Some handles are shaped like the features they control; others are arrows that show the
direction in which the feature can be moved or rotated. Try customizing your controls: select
and then right-click the NURBS circle, and select Edit Point. Select an edit point, and use the
Move tool to move it around and change the shape of the NURBS circle.

» You can use the Create Text menu and icon fonts like Wingdings and Webdings to create
interesting-looking controls. Look at the fonts in an application like Photoshop, and see
what you could use.

» When creating buttons, you can select more than one joint and have those joints combined
in one button. The spine joints are good candidates for being selected together. Start with
the top spine joint, and Shift-click to select the joints, moving down the spine and select-
ing the lowest spine joint last. Then, in the Script Editor window, select all the lines that
reference the spine, and click the Save Script To Shelf button.
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CHAPTER 11

Setting the Scene:
Creating an
Environment

Your character is now rigged and ready for animation, but he needs some
place to show off his moves. In this chapter, you'll create a set for your char-
acter, texture the walls and floor, and put in a couple of props to make the
room look more interesting.

Building a Room

Building Props

Building a Room

Building a set in computer graphics is a lot like building a set for a live-
action movie: you only build the parts of the set that will be seen on-camera.
Not only does this save time and effort, but it also makes camera placement
and movement easier, because you're not dealing with walls, furniture, or
other elements that may get in the way. For your set, you’ll create and tex-
ture a side wall, back wall, and floor.
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Creating the Floor and Walls

You'll create your set in the scene file containing your character. That way you
won’t have to import the character later, and you can build your set at an appro-
priate scale. You'll start by creating the geometry for the floor, then you'll dupli-
cate that geometry, and tweak it for use as the walls, as follows:

1. Open your file from the end of Chapter 10, or use Ch11Start.ma.

2. Select Create > Polygon Primitives, and make sure Interactive
Creation is unchecked. If it’s checked, select it to uncheck it.

3. Select Create > Polygon Primitives > Plane > Option Box.

4. The Polygon Plane Options window opens. Use the settings shown in
Figure 11.1, and click Create.

Width:  30.0000

FIGURE 11.1 PolygonPlane Options

5. With the floor plane selected, select Edit > Duplicate. The duplicate
will be your back wall.

6. In the Channel Box, set Rotate X to 90, as shown in Figure 11.2.

SHAPES
pPianeShape3

FIGURE 11.2
Rotating the first wall plane
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7. Using the Move tool, position the rotated plane at the back edge of
the ground plane, and move it up so the bottom edge is just below the
ground plane (see Figure 11.3).

FIGURE 11.3 Backwallplane moved

8. With the back wall still selected, select Modify > Freeze
Transformations.

9. Duplicate the back wall, and rotate it 90 degrees on the Y axis.

10. Move the copied wall into position on the screen-left side of the set,
as shown in Figure 11.4.

11. With the side wall still selected, choose Modify > Freeze
Transformations.

FIGURE 11.4 Sidewallcreated
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Texturing the Floor and Walls

With your set walls and floors in place, you can now texture them. The good
news is, because they’re in their original state, you don’t have to lay out UVs
for them. You can use a small, tileable texture on the walls and floor, and set
the texture so it repeats on the surfaces. Tileable textures are created in a
way that makes the edges between repetitions of the texture invisible. Follow
these steps:

[ | 1. Find or create tileable textures for the wall and floor surface.
. Figure 11.5 shows a quick wall texture created in Photoshop, along
Loads of free tileable . .
textures are available with a floor texture found on the Internet. Place the textures in your

on the Web. If you project directory’s sourceimages folder.
don’t want to create
your own textures, do
a search for “tileable
textures” or “seamless
textures,” and pick
ones you like.

FIGURE 11.5 Walltextureandfloor texture

2. Select and then right-click on the back wall, and select Assign New
Material, as shown in Figure 11.6.

3. The Assign New Material window opens. Select Lambert.

4. The Attribute Editor opens, showing the Lambert surface you just
created. Click the name field next to Lambert, and change the name
to wallTexture, as shown in Figure 11.7.

5. Click the checkerboard next to the Color attribute. In the Create
Render Node window that appears, click the File button.
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FIGURE 11.6 Assign
New Material menu item

Joup3 Mngquazy

FIGURE 11.7 Surfacerenamed

6. In the Attribute Editor, click the folder next to Image Name. Navigate
to your sourceimages folder (if necessary), and select your texture
map, as shown in Figure 11.8. Click Open.

FIGURE 11.8 Texturemap selected
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7. Turn on hardware texturing by selecting Shading > Hardware Texturing
in the Perspective view. The wall texture is visible on the back wall, as
shown in Figure 11.9. Currently, the texture is spread over the whole
wall. Here’s where the repeatable nature of the texture comes into play.

FIGURE 11.9 Texturemapplaced

8. In the Attribute Editor, click the place2dTexture2 tab. Under 2d Texture
Placement Attributes, change the Repeat UV values to something
greater than 1. The number you enter in these fields is the number
of times the texture will be repeated over the surface of the object.

U is the number of repetitions on the horizontal axis, and V represents
the number of repetitions on the vertical axis. When you achieve a
look that you like, close the Attribute Editor. Figure 11.10 shows the
place2dTexture window with Repeat UV values of 5 for the wall texture.

You can change the
tiling number at any
time by clicking the
wall, selecting the T

wallTexture tab in the = S

Attribute Editor, click- ~ 2 Texture Placement Atiibutes

ing the button next Interactive Placement
to the Color field, and i S
then returning to the . ;
place2dTexture2 tab. ' i

place2dTexture: pl;

1031p3 13k / Xog [PUURYY)

0.000

FIGURE 11.10 place2dTexture values
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9. To texture-map the other wall, click to select it, and then right-click.
Select Assign Existing Material > wallTexture, as shown in Figure 11.11.
The texture is assigned to the side wall, as shown in Figure 11.12.

Remove Material Override
Baking

FIGURE 11.11 Assign
Existing Material menu item

FIGURE 11.12 Textureassigned

10. Select and then right-click the floor plane, and select Assign New
Material from the marking menu. Select a Phong E surface, and
rename it floor.
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11. Repeat steps 5 and 6 to assign your texture map to the floor material.
Figure 11.13 shows the texture in place (the grid has been turned off
to improve visibility).

FIGURE 11.13 Floortexture assigned

I 12. Click the place2dTexture3 tab for the floor texture, and change the
Repeat UV values until you get a look you like. Figure 11.14 shows the

The Repeat UV values repeat values for the floor texture.

don’t have to be the
same. One number
can be greater than
or less than the other,
in order to achieve
the effect you want. placezdTexture: | pl
In Figure 11.14, the U
repeatis set to 2 and | AUE
theVto4.

List Selected

file3  place2dTextured

Joyip3 Jake] / xog [uuey)

¥ 2d Texture Placement Attributes

Joup3 gty

Interactive Placement
Coverage 1.000 1.000

Translate Frame 0.000 0.000

Rotate Frame 0.000 U]

Mirror U Mirror V
 Wrap U v Wrap V
Stagger
Repeat U/ 4.000

FIGURE 11.14 FloorRepeatUV
settings changed
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Building Props

You now have a textured room in which your character can perform, but it looks a
little bare. Next, you’ll create a couple of props to give your set a more lived-in feel.

Creating a Table

You'll build a simple small table and a wall hanging for your set, texture them,
and put them in place. First, follow these steps to hide the walls and floor in
your scene and make it easier to work on the table:

1. Select the walls and floor of your set.

2. Select Display > Hide > Hide Selection, as shown in Figure 11.15.
The walls and floor disappear.

ECEVE Window  Assets  Select Mesh  Edit Mesh Pn:i
22 (Clouseau) x64: /Users/naasp/D

v Grid o
Heads Up Display
Ul Elements

nics _ Rendering PaintEffects  To

Hide Selection
Hide Unselected Objects
Wireframe Color... Hide Unselected CVs

Al

Show

FIGURE 11.15 HideSelection
menu item

3. Select Create > Polygon Primitives > Cylinder > Option Box. In the
window that opens, set the values as shown in Figure 11.16, and click
Create.

spect ratio

FIGURE 11.16 Polygon Cylinder Options
window
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4. Move the cylinder off to the side of the character. In vertex compo-
nent mode, move and scale the rings of vertices to create a basic table
shape, as shown in Figure 11.17.

FIGURE 11.17
Table sculpted

5. Select Display > Show > All to make the walls and floor visible
again. Move the table onto the set, and position it near the side wall
toward the back of the set, as shown in Figure 11.18.

FIGURE 11.18 Tablemodel positioned

6. You will use procedural textures to surface the table. Procedural
textures are mathematically generated and don’t require image files
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to create their effects. Select the faces that make up the tabletop, as
shown in Figure 11.19. Right-click to bring up the marking menu,
and select Assign New Material.

Object Mode

Assign New Material...
Assign Favorite Material
Assign Existing Material

FIGURE 11.19 Tabletop facesselected, and
marking menu open

7. The Assign New Material window opens. Select a Phong E material.
Rename the material tableTop.

8. In the Attribute Editor window, click the checkerboard next to the
Color attribute. The Create Render Node window opens, as shown
in Figure 11.20. Scroll down the list of materials (if necessary), and
select Granite.

Create Render Node

Options

2D Textures 8 substance Output
3D Textures
Env Textures Water

%3 Brownian

ol cloud

Crater

& Fluid Texture 3D

Granite

FIGURE 11.20 C(reateRender
Node window
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9. In the Perspective window, select Renderer > High Quality Rendering
to see the texture on your tabletop. In the Attribute Editor, make
adjustments to the Granite Attributes until you have a surface you
like. Figure 11.21 shows one possible combination of settings.

FIGURE 11.21 Graniteattribute
settings

10. Select the untextured faces on the table, and assign a new Phong E
material to these faces. Rename the material tableBase. This time,
assign a Wood procedural texture to the Color attribute (review step 8
for details on assigning the surface). As you did in step 9, adjust the
surface settings until you have something you like. Figure 11.22 shows
one possible combination of settings.

FIGURE 11.22 Woodattribute
settings
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Creating a Poster

Finally, you'll create a poster to hang on the wall and further dress your set. You
will use a photo as a texture map to create the poster’s contents:

1. Select Create > Polygon Primitives > Cube > Option Box, and input
the values in Figure 11.23. Click Create.

You could use a poly-
gon plane for the
poster, as you did for
the walls and floor.
However, because the
poster will be hanging
on the wall, it's a good
idea to give it some
thickness, however
minimal, by using a

FIGURE 11.23 Postercubesettings polygon cube. Polygon
planes have no actual
2. Move the cube on the Z axis until it’s clear of the floor plane, as depth, so there would

be no thickness to the
poster.

shown in Figure 11.24.

FIGURE 11.24 Postercube moved

3. Assign a new material to the cube, and make it a white Blinn surface.
Rename the surface posterBackSides.
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4. In Face mode, select the front faces of the cube, as shown in
Figure 11.25.

An easy way to select
just the front faces is
to click the middle face
and then hold down
Shift and press the
period key one time.
This key combination
expands the selection
to the surrounding 1
faces, selecting the !
rest of the faces on the |
front of the cube. If you
select too many faces,
hold down Shift and

press the comma key to
contract the selection. FIGURE 11.25 Frontfacesselected

5. Assign a new Blinn material to the selected faces. Rename the surface
posterFront.

6. With the front faces still selected, choose Create UVs > Planar
Mapping > Option Box from the Polygons menu set.

7. Set Project From to Z Axis, as shown in Figure 11.26, and click
Project. In the Perspective view, click off the poster to deselect it.

Planar Mapping Options.
Edit  Help
Projection Manipulatar
Fit projection to: Best plane
® Bounding box
Project from: X axis
¥ axis
® Zaxis
Camera

Keep image width/height ratio

+ Insert projection befare deformers

Create new UV Set

Project

FIGURE 11.26 Planar Mapping Options window

8. Select an image you'd like to have on your poster, and place the image
in your project directory’s sourceimages directory. The example image
used in this tutorial is of the author wearing a Cookie Monster costume.
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9.

10.

11.

Click the checkerboard next to the Color attribute in the poster-
Front surface. Select your image from the sourceimages directory,
and click Open.

The image loads and appears on the front of the poster. If the image
needs to be rotated, click the place2dTexture tab in the Attribute
Editor, and use the Rotate Frame slider in the 2d Texture Placement
Attributes window to rotate it, as shown in Figure 11.27.

a
B
]
g
E
3
g
8 2

1011p3 ANqUIY

FIGURE 11.27 RotateFrame control

Select the poster in Object mode, and move it to the side wall, rotat-
ing it so it’s oriented correctly. Figure 11.28 shows the poster in
place. Wireframe on Shaded and X-Ray Joints have been turned off,
and the hardware render setting has been reset to default quality.

FIGURE 11.28 Posterhungon the wall
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Using the orthographic
views (Top, Front,

and Side) can be very
helpful in getting your
poster placed exactly
as you want it.
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THE ESSENTIALS AND BEYOND

In this chapter, you set up an environment for your character to perform in, created new mate-
rials and assigned them both texture-based and procedural surfaces, and placed props in the
environment to give it a more natural feeling. In the next chapter, you'll bring your character
to life by creating a short animated sequence.

ADDITIONAL EXERCISES

> (Create some additional props to populate your scene. Define a personality for your character,
and then think about the kind of things he/she/it would have in a room like this. Would there
be chairs? A larger table? More wall hangings? What about little touches, like a flower vase
or tableware? Adding details to your scene creates richness and texture in the environment
and tells the viewer something about your character.

> Several sites on the Internet have premade props and set pieces free for the downloading.
Do a search for “Maya models,” and see what you find. You can also check out sites like
Turbosquid.comand Creativecrash.com, where there are a lot of models aggregated
for browsing. In addition to .ma and . mb files, Maya can import several other file types.
Select File > Import to open the Import window, and look in the Files of Type drop-down to
see the file types Maya can import. Maya can also open . obj files using File > Open Scene.
The . obj formatis a standard 3D format that practically every 3D application recognizes.
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CHAPTER 12

Making It Move:
Animating Your
Character

It’s time to bring your character to life. In this chapter, you'll do some
simple animation to get your character moving. The techniques discussed
represent the basics of creating animation in Autodesk® Maya® software.
Whole books can (and have) been written about animation techniques. The
information presented here will get you off to a good start.

Setting up Maya for animation

Animating your character

Setting Up Maya for Animation

Before you start animating your character, it’s a good idea to set up a few options
in Maya that will make animating your character easier and more efficient.

Setting Key Tangents

There are as many ways to approach animating a shot as there are anima-
tors. One common way uses a technique called pose fo pose, in which you
pose your character on one frame and then create a different pose further
along the timeline. To make it easier to see the poses as you work on them,
you set the default out tangents (the curve type that determines how Maya
moves your character) to Stepped. This tangent type holds the pose you set
until the playback head reaches the next key, and then the character “pops’
into the next pose. Set your tangents by following these steps:

)

1. Open your file from the preceding chapter, or use Ch12Start.ma.
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2. Click the Animation Preferences button in the lower-right corner of
the interface, as shown in Figure 12.1.

I« «a » »| »] »l
No Character Set = &

=

FIGURE 12.1
Animation Preferences
button location

3. In the Preferences window, choose Settings > Animation in the
Categories window.

4. In the Tangents section, change the Default In Tangent option to
Linear and Default Out Tangent to Stepped, as shown in Figure 12.2.
Click the Save button.

Animation: Animation Preferences

Auto Key

Rotation Interpolation
urve default: Independent Euler-angle curves  ~

New HI default: | Quaternion Cubic =

Tangents
Weighted tangents
Default in tangent: [Linear |~
Default out tangent:

Animation Blending

Blend: ® Alw:

Graph Editor

« Snap Value to Adjacent Keys

Cancel

FIGURE 12.2 Defaultinand outtangents set

Creating a Camera and Turning On the
Resolution Gate

When you animate a shot, you always want to animate fo camera, so you can
pick the strongest pose possible. Having a camera created and the gafe turned
on lets you see exactly what your audience will see:

1. Choose Create > Cameras > Camera, as shown in Figure 12.3.
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NURBS Primitives
Polygon Primitives

Volume Primitives
Lights

Cameras
Camera

CV Curve Tool Camera and Aim
EP Curve Tool o Camera, Aim and Up
Bezier Curve Tool

o

Stereo Camera

FIGURE 12.3 C(reate > Cameras menu

2. From the view window menus, choose Panels > Perspective > cam-
eral, as shown in Figure 12.4.

FIGURE 12.4
Selecting the cameral window

3. The view window switches to the cameral view. From the view win-
dow menu, choose View > Camera Settings > Resolution Gate, as
shown in Figure 12.5.

Undoable
Pan

® No Gate

View Sequence Time

Film Gate
Resolution Gate
v Ga

FIGURE 12.5 Turningon
the resolution gate

4. A box appears in the view window. Whatever is inside the box
is within the camera’s resolution. Using the view-manipulation
tools, move the camera so that your view window looks similar to
Figure 12.6.

www.LegendaryLibrary.Mihanblog.Com



224 Chapter 12 « Making It Move: Animating Your Character

When you use the
view-manipulation
tools in a camera
window, you're physi-
cally repositioning the
camera in the environ-
ment. This is a much
easier way to frame a
shot than moving the
camerain a perspective
window, because you
can see exactly what
the camera is seeing as
you move it.

FIGURE 12.6 Shotframed

Locking Down the Camera

It’s very easy to accidentally move the camera after you have it set up for your
shot. To prevent that, you will lock down the camera so it stays in the position
you've chosen:

1. In the view window, click the Select Camera button. The box in the
cameral view highlights to indicate that the camera is selected, as
shown in Figure 12.7.

Select Camera button

e

FIGURE 12.7 SelectCamerabutton, and box highlighted
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2. With the camera selected, open the Channel Box window (if it isn’t
already open), and drag-select all the channels for the camera, as
shown in Figure 12.8.

Channel Box / Layer Editor

Channels  Edit

camerai

FIGURE 12.8
Camera channels selected

3. With the channels selected, right-click any channel name,
and choose Lock Selected from the pop-up menu, as shown in
Figure 12.9.

Channel Box / Layer Editor

Channels Edit  Obje:

cameral
Translate X

FIGURE 12.9
Lock Selected option
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If you need to move the
camera later, reselect
the camera and the
channel names as you
did earlier, and then
right-click a channel
name and choose
Unlock Selected.

A cycleis any ani-
mated clip whose

end matches up to its
beginning, so it can
play endlessly. The
simplest example of

a cycleis an animated
GIF that you might see
on a website. More
sophisticated examples
are character actions in
video games or some
background character
animation in feature
films.

Chapter 12 « Making It Move: Animating Your Character

4. The value fields for the camera’s channels turn gray to indicate
they’re locked, as shown in Figure 12.10. The camera is now locked
down and can’t be moved.

el Box / Layer Editor

Channels Edit Object Show
camerat
Transiate X
Trarsiate ¥
Transiate Z
Fotate X
Rotate ¥

SHAPES
camerasha
Hort

FIGURE 12.10
Camera channels locked

Animating Your Character

A piece of animation goes through several stages from concept to completion. In
this section, you explore those stages as you create a simple looping animation,
or cycle, of the character doing a little hopping dance step.

Creating a Pop-Thru

The first step in animating your character is creating the main poses for your
action. With the out tangent set to Stepped, your character will appear to “pop”
from one pose to the next. This action is called a pop-thru for that reason.
Follow these steps to create a pop-thru:

1. Before you start posing your character, take a little time and work
out the main poses with pencil and paper, creating small thumbnail
sketches, as shown in Figure 12.11.
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I O " You don’t have to be
: v o able to draw well to
e create thumbnails.
/ & el Simple stick-figure
ﬁ /] drawings work very
(' well. It's faster to

work out your ideas
on paper, trying a few
options, before you
FIGURE 12.11 Thumbnail sketches spend the time and
effort posing your

character model.

4

B

. Make sure your playback head is on frame 1. In the Perspective view,
click the model, and press 3 on your keyboard to switch to Smooth
Proxy view.

. The preceding thumbnails suggest that the character’s hands are in a
fist. Either by using the shelf buttons you created or by clicking indi-
vidual joints, form both hands into fists, as shown in Figure 12.12.
Remember to press s to set a key for each joint as you rotate them
into position.

FIGURE 12.12 Fingerposescompleted

. Still on frame 1, and using the thumbnail sketch as a guide, use the
charCtrl, footCtr1, kneeCtr1, and arm joints to pose your character
so that it looks like the first thumbnail sketch. When you’re finished,
your pose should look similar to Figure 12.13.
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If you're having

trouble selecting the
foot controls, you

can temporarily hide
the floor by select-

ing it and choosing
Display > Hide > Hide
Selection.

FIGURE 12.13

Be sure to set keys for First key pose completed
all the controls you're
eI, (00 T R 0 5. Go to frame 21, and, without changing anything, key all the controls

ou're moving for this . . .
:’,ose’ Fo,exa?nme again. You're creating a cycle, and you need to start and end with the
footCtr 1Rt needs same pose.

a key, even though . .
it's s);aying in plfce in 6. Go to frame 6, and pose your character like the second thumbnail

this pose, because in sketch, being sure to set a key for the charCtr1, footCtr1, kneeCtrl,
the next pose you'll and arm joints. Your second pose should look something like
move t. Figure 12.14.

When you move the
character up by using
thecharCtrl,
make sure when pos-
ing the foot that the
footCtrlsare

in contact with the
model. Inan IK setup,
the IK handles should
never be far from the
goal object, which

in this case are the
footCtrls.

FIGURE 12.14
Second key pose completed
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Go to frame 11, and pose your character like the third thumbnail
sketch, being sure to set keys as you go. This is the mirror to the
pose on frame 1, but it doesn’t have to be exactly the same. Your pose
should look something like Figure 12.15.

FIGURE 12.15
Third key pose completed

Go to frame 16, and pose your character like the fourth thumbnail
sketch, setting keys as you go. Your character should look something

like Figure 12.16.

FIGURE 12.16
Fourth key pose completed
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If you did a Freeze
Transformations when
you created your
charCtrland
footCtrls,you
can reset them to their
initial positions by typ-
ing 0 into the Translate
X, Y, and Z fields in the
Channel Box.

If you'd like to copy
your arm poses from
frame 6, select a joint,
click frame 6 in the
timeline, and then
right-click and select
Copy. Next, click
frame 16, right-

click, and choose
Paste > Paste.



230

After you've selected
all the keyed controls
and joints, you can cre-
ate a shelf button that
selects them all for
you. Follow the steps
for creating buttons in
Chapter 10, “Rigging
Your Character.”

Chapter 12 « Making It Move: Animating Your Character

9. Click the button at the right end of the Time Slider, and drag left to
shorten the active sequence to 20 frames. To see your key poses in
action, click the Play Forwards button to the right of the timeline.

Timing the Pop-Thru

Now that your key poses are done, it’s time to let Maya do some inbetweening
and get your animation playing smoothly. Inbetweening is where Maya takes the
keys you've defined and creates the transitional positions between them:

1. One at a time, carefully select every control and joint that has more
than one key set (charCtr1, footCtrls, kneeCtrls, and the clav,
shoulder, elbow, and wrist joints).

2. Choose Window > Animation Editors > Graph Editor, as shown in
Figure 12.17.

LULELTE Assets  Animate Geometry C... Create Def... EditDl
/naasp/Docume:

General Editors >

Rendering Editors » ;
AmrnhunEdltrs » Graph Editor
Relationship Editors > rax Editor
Settings/Preferences »

Camera Sequencer
Attribute Editor Dope Sheet
Qutliner HumanlkK

Node Editor Blend Shape
Create Node Pos—

FIGURE 12.17 GraphEditor menu
selection

3. The Graph Editor window opens. Press a to make all the animation
tangents visible, and then drag-select over every tangent to select
them all, as shown in Figure 12.18.

FIGURE 12.18 Selectingall tangents

www.LegendaryLibrary.Mihanblog.Com



Animating Your Character

4. Click the Auto Tangents button at the top of the Graph Editor win-
dow, as shown in Figure 12.19. The tangent lines are now curved.

Auto Tangeqts button

FIGURE 12.19 AutoTangentsbutton

5. Close the Graph Editor window, and click the Play Forwards button to
see your animation.

Adding Breakdown Poses

The key poses look good, but when they’re inbetweened, you get a result that
really wasn’t planned. Instead of kicking his foot forward as he lands, the char-
acter slides his foot forward after it leaves the ground. To keep this from happen-
ing, you will add a couple of keys to further define the character’s action. These
additional keys are known as breakdown poses, because they further break down
the action between the keys. Here are the steps:

1. Click the Animation Preferences button in the lower-right corner
of the interface. In the Preferences window that appears, choose
Settings > Animation from the Categories window, and change the
default in and out tangents to Auto, as shown in Figure 12.20. Click
the Save button.

8.60.6 Preferences
Edit  Help

Categories Animation: Animation Preferences

Auto Key

Rotation Interpolation
ault: Independent Euler-angle curves =
efault: Quaternion Cubic
Tangents
Weighted tangents
Default in tangent: [Auta -
out tangent: ‘Auto -
Animation Blending

Blend

Graph Editar

v Snap Value to Adjacen

FIGURE 12.20 Defaulttangent typeschanged
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To get a view setup like
Figure 12.21, choose
Window > View
Arrangement > Two
Panes Side By Side.

Chapter 12 « Making It Move: Animating Your Character

10.
11.

12.

Click footCtr1Rt, and move the playback head to frame 8.

Press w to select the Move tool. Move footCtr1Rt back so that the
foot is under the torso, as shown in Figure 12.21, and set a key. You
may want to work in the Side or Perspective view to best see where
the foot is.

FIGURE 12.21 Footcontrol moved

Click footCtrlLt, and move the playback head to frame 18.
Repeat step 3 for footCtrlLt.

Click the Play Forwards button to see the change in your animation.
The feet now stay back longer and kick forward quickly.

With the playback head on frame 1, click footCtr1lRt.
Right-click the playback head, and select Copy.

Click frame 3 to move the playback head, and then right-click and
choose Paste > Paste. The key information you copied from frame 1
is now pasted on frame 3.

Move the playback head to frame 11, and click footCtr1Lt.

Repeat steps 8 and 9 for footCtrlLt, pasting the copied information
on frame 13.

Click the Play Forwards button to see your changes. Now the foot
pushing off the ground stays in contact longer, giving the action
more believability.
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Polishing the Animation

Right now, everything in your shot happens at the same time: the arms go down | ENGNG
on the same frame that the leg kicks out, for example. In the real world, things

don’t move like this. Some actions start before others, and other actions end B

animation, the goal is

later. In animation, this concept is referred to as overlap and follow-thru. for the movement to be

You'll apply some overlap and follow-thru to your character’s arm movements believable, not realistic.
to make them feel a bit more believable: Realistic animation is

very difficult to achieve,

1. Choose the clav, shoulder, elbow, and wrist joints on both arms. because of the endless
. . . . . number of subtle move-

2. Choose Window > Animation Editors > Dope Sheet, as shown in ments people make all

Figure 12.22. the time.

Window W.E3T

General Editors
Rendering Editors
Animation Editors
Relationship Editors
Settings /Preferences

Graph Editor
Trax Editor
Camera Sequencer

Attribute Editor

Outliner HumanlK
Node Editor Blend Shape
ICreate NodLe L Expression Editor

=

FIGURE 12.22 DopeSheet menu
selection

3. The Dope Sheet opens. Drag-select the elbow and wrist keys, as
shown in Figure 12.23.

FIGURE 12.23 Elbowand wrist keys selected
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The process of moving
keys to create overlap
and follow-thru is
known as offsetting
or creating offsets. It's
the very last step in the
animation process; the
keys and breakdowns
have to be right before
the offsets are done.

Chapter 12 « Making It Move: Animating Your Character

10.

Press w to select the Move tool.

. Middle-mouse-click one of the selected keys. A double-headed

arrow appears. Drag the keys one frame to the right, as shown in
Figure 12.24.

FIGURE 12.24 Keysmoved

Click off the keys to deselect them, and then drag-select the wrist keys.

Middle-mouse-click, and drag the wrist keys one more frame to the
right.

Click the Play Forwards button to see the result of moving the keys.
The arms now have a slightly circular movement, and the wrist
action ends two frames later than when the character lands, lending
more believability to the action.

To add the final touches to your motion, select all the controls that
have multiple keys on them, and then open the Graph Editor window
(Window > Animation Editors > Graph Editor).

Expand the Graph Editor window until you can see the Pre- and Post-
Infinity cycle buttons, shown in Figure 12.25.
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5 |

Post-infinity  Post-infinity
cycle button  cycle button

FIGURE 12.25 Pre-andPost-Infinity cycle buttons

11. Press a to zoom out to see all your tangents. Then drag-select all your
keys and tangents.

12. With all the keys and tangents selected, click the Pre- and Post-
Infinity cycle buttons. Dotted-line tangents appear, as shown in
Figure 12.26.

FIGURE 12.26 Pre-andPost-Infinity cycles applied

The Pre- and Post-Infinity cycles continue your actions prior to and after the
section of frames you animated. This is handy when you're creating a cycle with
offsets, because it ensures that the first frame of the sequence matches up with
the last frame so the cycle is smooth.
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THE ESSENTIALS AND BEYOND

Animation is a time-consuming process. In this chapter, you created keys, breakdowns, and
offsets to create the beginning of a cycle. You also employed Pre- and Post-Infinity cycles to
ensure that your action cycles, or loops, correctly.

ADDITIONAL EXERCISES

» You can do much more with the animation on this shot. Try animating the head, neck, and
spine joints. Be sure frames 1and 21 are the same on any additional animation you create
so that your cycle is smooth and works correctly.

» What does this motion look like when you act it out? When animators are trying to work out
an action, they will frequently act it out themselves to see how their bodies are moving.
Try acting out this action, paying attention to what your body is doing, and add what you
discover to your animation.

> You can also videotape yourself or a friend performing this action. Sometimes it’s easier
to figure out what’s going on if you can look at a video of the action. Animators frequently
use reference footage to break down movement and figure out exactly how to create a
believable performance.
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CHAPTER 13

Let There Be Light:
Lighting Your Shot

Lighting plays a big part in establishing the feel and mood of a scene. Any
given scene can be made to look inviting, scary, or any other look you're
going for simply by the type, number, and intensity of the lights you place in
the scene. The basics of lighting are easy to learn and, once mastered, can be
applied to a variety of scenes.

Understanding the three-point lighting system
Using the lights
Lighting your scene

Performing light linking

www.LegendaryLibrary.Mihanblog.Com



238

Chapter 13 « Let There Be Light: Lighting Your Shot

Understanding the Three-Point Lighting
System

There are some exceptions, but most scenes are lit with the three-point lighting

system. The three-point lighting system is a technique for making sure elements
of the scene are well lit and stand out from the background. A basic three-point

lighting setup is shown in Figure 13.1.

Rim Light

A
N -

Subject

& A

Fill Light Key Light

Camera

FIGURE 13.1 Three-pointlighting setup

Although any scene can include dozens or even hundreds of lights, each light
generally falls into one of three categories:
> Key light
» Fill light
» Rim light

Key Light

The key light is the main light in a scene and provides most of the illumination
for the scene element it’s lighting. The key light is usually placed to one side

of the camera and is the brightest light in the scene. Figure 13.2 shows a basic
scene lit by a key light.
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FIGURE 13.2 Scenelitwithakey light

Fill Light

The key light does a good job of illuminating the scene but creates some pretty
stark shadows. The /ill light’s job is to put some light in these areas so the scene
doesn’t look quite so film noir-ish The fill light is usually placed on the oppo-
site side of the camera from the key light, and it’s less intense than the key.
Figure 13.3 shows the scene with a fill light added.

FIGURE 13.3 Scenewithfill light added
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Rim Light

The rim light’s job is to help separate the scene elements from the background.
The rim light is placed above and behind the scene and is usually set at a fairly
high intensity. Figure 13.4 shows the scene with a rim light added. Figure 13.5
shows the Autodesk® Maya® scene with the camera and light placements.

FIGURE 13.4 Scenewithrimlightadded

FIGURE 13.5 LightsinaMayascene
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Using the Maya Lights

Maya has several light types, each with different properties and uses. There are
three that are the most versatile, and you’'ll find yourself using them frequently:

» Directional light
» Spot light
» Point light

Directional Light

The best way to think of the directional light is as being like the Sun. The Sun’s
rays travel in all directions, but the Earth is so far away and so small in com-
parison that when the Sun’s light reaches us, the rays are essentially parallel.
The directional light is similar: it illuminates everything in the scene (unless
you exclude some geometry—more on this later), and the rays travel in parallel.
It doesn’t matter where the light is in the scene; it only matters which direction
the light is pointing. The directional light icon is shown in Figure 13.6, and its
effect on the scene is shown in Figure 13.7.

FIGURE 13.6
Directional light icon
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FIGURE 13.7 Directional lightinscene

Spot Light

The spot light is just like a spot you'd see used on a stage or movie set. It casts
light in a given direction and covers a given area; anything outside that area
isn’t illuminated. The rays cast by the light fan out from the light source in a
radial pattern. Figure 13.8 shows the spot light icon, and Figure 13.9 shows the
spot light’s effect on the scene.

FIGURE 13.8
Spot lighticon
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FIGURE 13.9 Spotlightinscene

Point Light

A point light is like a lightbulb. Light emanates from it in all directions, and
there are no boundaries on the rays’ travel. Think of a point light as a lamp with
the shade removed. Figure 13.10 shows the point light icon, and Figure 13.11
shows a scene illuminated by a point light.

FIGURE 13.10
Point light icon
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FIGURE 13.11 Pointlightinscene

Lighting Your Scene

It’s time to light your scene. In preparation for doing that, you’ll make sure all
your scene elements are visible and ready to go.

Placing Your Lights

The first thing to do is make sure all your scene elements are visible, and then
you can start creating and placing your lights. Follow these steps:

1. Open your scene from the end of the preceding chapter, or use
Ch13Start.ma.

2. Select Display > Show > All, as shown in Figure 13.12.

BIEVA Window  Assets  Animate  Geometry C...

v Grid
Heads Up Display
Ul Elements.

Hide

Show Selection
Wireframe Color... Show Last Hidden
Object Display » All Surface CVs
Transform Display > All

nal Show Geometry. »

FIGURE 13.12 Display>
Show > All menu item
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3. Choose Create > Lights > Spot Light, as shown in Figure 13.13. A
spot light icon is created at the origin.

(0 Display Window Assets Animate Ceometry C...
2 (Clouseau) x64: /Users

NURBS Primitives
Polygon Primitives
Volume Primitives

Ambient Light
Directional Light
CV Curve Tool 1 Point Light

EP Curve Tool =1 SpotLight |
Bezier Curve Tool o Area Light
Pencil Curve Tool o Volume Light

Cameras 3

FIGURE 13.13 SpotLight menuitem

4. With the light still selected, choose Panels > Look Through Selected,
as shown in Figure 13.14.

FIGURE 13.14
Look Through Selected
menu item

5. The view switches to show what the spot light sees. The circle in the
middle of the view window is the area the spot light illuminates.
Using your view-manipulation tools, reorient the view so that it looks
similar to Figure 13.15. This is your key light.

Remember that your
character jumps upin
the air during his cycle,
so leave some room
above the character
when you're placing
the circle. If you want
to check to make sure
the spot light will cover
him when he jumps,
click and hold the play-
back head and “scrub”
back and forth on the

timeline to see your
FIGURE 13.15 Key |Ight placed animation.
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6. Choose Create > Lights > Point Light, as shown in Figure 13.16.
A point light is created at the origin. This is your fill light.

NURBS Primitives
Polygon Primitives
Volume Primitives

Ambient Light
Directional Light
CV Curve Tool &l Point Light |
EP Curve Tool o Spot Light
Bezier Curve Tool o Area Light
Pencil Curve Tool o Volume Light

Cameras

=]
(=]
m]
o
o
o

FIGURE 13.16 Pointlight menuitem

7. Move the light so it’s to the left side of the camera and slightly above
it, as shown in Figure 13.17.

FIGURE 13.17 Filllightplaced

8. Create another spot light. Using Look Through Selected as you did
with the key light, place it above and behind your character for a rim
light. Figure 13.18 shows the view from the spot light’s perspective.

Your main lights are now in place. In the next section, you set the intensity of
the lights so the scene is lit well.
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FIGURE 13.18 Rimlightplaced

Setting the Intensity of Your Lights

Each light will have a different intensity depending on the role it’s playing in
lighting the scene. Typically, the key light is the brightest, with the fill and rim
being somewhat less intense. Follow these steps to set the light intensity:

1. Switch to the Perspective view, and move the view so you can see all
three light icons, as shown in Figure 13.19.

In this procedure, you
will switch between
lights frequently. A
good way to access
the lightsin turniis

to select Window >
Outliner. The Outliner
window opens and lists
all the elements in the
scene. You can select
alightin the scene by
clicking its name in the

FIGURE 13.19 Allthreescenelights Outliner.

2. Click each light, and change its name in the Channel Box. Use the
names keyLight, fillLight, and rimLight.
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3. Select fillLight. In the Attribute Editor, click the fillLightShape
tab. Open the Point Light Attributes section, and deselect Illuminates
By Default, as shown in Figure 13.20. Doing so turns off fillLight.

List Selected Focus

filllight | fillightShape defaultLightSet

pointLight: fillLightShape

10Yp3 JakE] / XOg [PuUEYD

2
g
g

FIGURE 13.20 Turning off the
fill light

4. Repeat step 3 for rimLight.

5. keyLight is now the only light illuminating the scene. Select the
camera view. From the Rendering menu set, select Render > IPR
Render Current Frame, as shown in Figure 13.21.

LOLCEI Toon  Stereo  Paint Eff

Render Current Frame o
Redo Previous Render

IPR Render Current Frame
Redo Previous IPR Render

Test Resolution >
Run Render Diagnostics

FIGURE 13.21
IPR Render Current Frame
menu item

6. When the Select A Region To Begin Tuning prompt appears in the
Render View window, drag a selection box around your character and
some of the background, as shown in Figure 13.22.
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10.

Render View
ender IPR Options Display Help

) ‘" | 11 |@i (2 | Ieye Satoare = 11 1PR: OMB

Selact a ragion to begin tuning

FIGURE 13.22 IPRrenderwith characterselected

With the Render View window visible, adjust the Intensity setting
for the light in the Attribute Editor until the scene is well lit but not
overly bright. The setting used for Figure 13.22 is approximately 1.4.

Select fillLight, and recheck Illuminates By Default in the Attribute
Editor. The Render View window should immediately show fillLight
illuminating the scene. Adjust the intensity level to fill in the shadow
areas on the screen-left side of the character. An intensity of about
0.275 works well.

Repeat step 8 with rimLight. An intensity of about 0.6 for this scene
works well.

In the Render View window, click the Render Current Frame button,
shown in Figure 13.23. A rendered frame of your scene replaces the
IPR render in the window.

anNe Render View
i
File View Render IPR Options Display Help

11 |\ﬁ' Izt ‘ Maya Software - 11 1PR: OMB

‘::: = Efi‘wi{ |:|

Render Current Frame button

FIGURE 13.23 RenderCurrent Frame button
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IPR stands for
Interactive
Photorealistic
Rendering. It'san
interactive window
that shows changes to
the scene as you make
them. It's very handy
for setting lighting
levels.

If you want to see

the effect the light is
having on the scene,
toggle llluminates

By Default on and off
while watching the
Render View window.

Your character will look
blocky and angular in
the render. You will
smooth the character
in the next chapter
before doing your final
rendering.
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Casting Shadows

Currently, your lights don’t cast shadows. The next step is to turn on one of the
two shadow options that Maya offers for one or more of the lights in your scene:

» Depth map shadows use a map (similar to the texture map you created
earlier in the book) to create shadows.

» Ray trace shadows mean the light rays coming from the lights in
the scene are tracked, and shadows are created when the rays strike
an object.

Follow these steps to create shadows using the depth map option:

1. Select keyLight, and scroll down in the Attribute Editor to the
Shadows section. Click the arrow next to Shadows to open the sec-
tion (if it’s not already open), and scroll down to Depth Map Shadow
Attributes.

2. Click the Use Depth Map Shadows check box, and set the Resolution
to 2048, as shown in Figure 13.24.

keylight | keylightShape | defaultlightSet

Foo

spotlight: keyLightShape Pres

%
Sample . Light Shape

Jolp3 singity | Joup3 JAAE] / x0§ URYD

¥ Shadows
Shadow Color
¥  Depth Map Shadow Atributes

th Map Shadows

FIGURE 13.24 Depthmapshadow settings

3. Click the Render Current Frame button (to the left of the IPR but-
ton). A single frame renders, showing the shadow created by the
depth map, as shown in Figure 13.25.
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Jptions.  Display

1:1 | 1] B | Maya Software

FIGURE 13.25 Renderwithashadow

4. The shadow is currently pretty hard-edged. To soften the edges of
the shadow areas, change the Filter Size setting under Depth Map
Shadow Attributes to a higher number. Figure 13.26 shows a shadow
with a Filter Size setting of 10.

FIGURE 13.26 Shadow witha higher Filter Size setting

5. Add shadows to fillLight and rimLight, if you like.
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Performing Light Linking

One of the great things about lighting in a CG environment is that lights don’t
have to behave as they do in the real world. As you’ve seen, lights don’t neces-
sarily have to cast shadows. You can set negative values on a light and actually
remove illumination from the scene. Another option is to have a light illuminate
specific objects in a scene without illuminating others. In Maya, this process is
called light linking.

In the following steps, you’ll see how to unlink a light from an object in the
scene:

1. Figure 13.27 shows the still-life scene from earlier in the chapter, lit
by a single spot light.

FIGURE 13.27 Allsceneelements lit

2. To access light linking, in the Rendering menu set choose Lighting/
Shading > Light Linking Editor > Light-Centric, as shown in
Figure 13.28.
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Lighting]Shading Texturing Render Toon Stereo Paint Effe

characterModel /sc

Material Attributes

Assign New Material...
Assign Favorite Material
Assign Existing Material

Assign New Bake Set (mental ray)
Assign Existing Bake Set (mental ray)

oYY vv

Batch Bake (mental ray)
Transfer Maps....

Make Light Links
Break Light Links
Select Objects llluminated by Light
Select Lights llluminating Object
Light Linking Editor

Light-Centric
Object-Centric

Make Shadow Links

FIGURE 13.28 LightLinking Editor
menu item

The Relationship Editor window opens with the scene lights in the
left column and the scene elements in the right column. By clicking
a light to select it, you can see the elements in the scene that light

illuminates (see Figure 13.29).

ann Relationship Editor

FIGURE 13.29 Relationship Editor
with light selected

To remove an object from a light’s influence, hold down Command/
Ctrl and click the object. Figure 13.30 shows the Relationship Editor
with the sphere removed from the spot light’s influence.

Relationship Editor

FIGURE 13.30 Sphereunlinkedfrom

the sp
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5. The light no longer illuminates the sphere, as Figure 13.31 shows.

FIGURE 13.31 Thesphereisnolongerlit.

THE ESSENTIALS AND BEYOND

In this chapter, you lit your scene and learned a little about the three-point lighting system, a
standard arrangement for many scenes in movies and games. You also discovered that although
lights in a CG environment can behave like lights in the real world, they’re also capable of things
that real-world lights simply can’t do.

ADDITIONAL EXERCISES

P Try setting negative values on a light in your scene to see the result. Negative values remove
light from a scene and are often used in areas that are over-lit and need to be a bit darker.

> Add some additional lights to better illuminate the set as a whole. Use the light-linking
technique to keep from over-illuminating your character.

> Lights can also be incorporated into set elements. For example, you can create a simple
light fixture and put a light inside it to illuminate the image on the wall, or create a candle
for the tabletop with a point light inside to suggest the flame.

> Lights, like any other objects in a scene, can be animated. Try putting a fourth light in the
scene with a very low intensity and animating its translate values to create a moving-light
effect.
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Rendering and
Compositing Your
Scene

Now that your animation is complete, it’s time to render out the scene
and put together a movie file that you can play on your computer, load onto
your mobile device, or share on the Web. In this chapter, you'll generate final
frames from the animation you created and do some simple compositing to
turn those rendered frames into a movie file.

Making 2D images out of 3D scenes

Performing compositing

Making 2D Images Out of 3D Scenes

Although you’ve been working in a 3D environment, eventually you have
to output your work as 2D images. Even 3D stereoscopic movies use two
sets of 2D images per frame to achieve the 3D effect. This section takes you
through preparing for and rendering your final frames.
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Smoothing Your Model

Throughout producing your shot, you've been working with a low-polygon
model. As you probably noticed in your test renders in Chapter 13, “Let There
Be Light: Lighting Your Shot,” the character looks kind of blocky and chunky.
Before you do your final render, you want to smooth out the character so it
looks nice and rounded:

1. Open your scene file from the end of Chapter 13, or open Ch14Start.ma.

2. Click the character mesh, and, in the Polygons menu set, choose
Mesh > Smooth > Option Box, as shown in Figure 14.1.

m Edit Mesh  Proxy Normals Color
Combine =]
Separate
Extract o
Booleans >
Average Vertices =]
Transfer Attributes ]
Paint Transfer Attributes Weights Tool o
Transfer Shading Sets ]
Clipboard Actions >
I’;\;ﬂ ll;nfhlrn Weinhts Tanl fml

FIGURE 14.1 Selecting
the Mesh > Smooth option

3. The Smooth Options window opens, as shown in Figure 14.2. Under
Exponential Controls, set Division Levels to 2, and click Smooth.

FIGURE 14.2 SmoothOptionswindow

4. The model’s geometry becomes more detailed. Click the Rendering
shelf tab, and then click the Render Current Frame button, shown in
Figure 14.3, to render a test frame and see the smoothed version of
your model, as shown in Figure 14.4.
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Rendering  PaimtEffects  Toon  Mu Fluids

(6 1 )61 fool

Render Current Frame button

FIGURE 14.3 Rendering
a test frame

FIGURE 14.4 Renderofthesmoothed model

Setting Your Render Preferences

Before you render your scene, you need to check your render settings to make
sure the frames you get are usable, the right size, and the right format:

1. Choose Window > Rendering Editors > Render Settings, as shown

in Figure 14.5.

LGN Assets  Lighting/Shading  Texturing Render Toon Ste

S EB/Documents/ mayalprojects/ charal
»

General Editors
Rendering Editors

Animation Editors » . Render View
% : : [

Relationship Editors 3

Setti Pref, Hypershade

ettings/Preferences bl renkaliy e
Attribute Editor Render Layer Editor
Outliner Custom Stereo Rig Editor
Node Editor

Rendering Flags

Create Node Shading Group Attributes

Hypergraph: Hierarchy
Hypergraph: Connections O Hardware Render Buffer

Paint Effects
LIV Texture Editar

FIGURE 14.5 Selectingthe Render
Settings menu option
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2. The Render Settings window opens. Click the Common tab, shown in
Figure 14.6.

Edit Presets Help

Render Layer |masterlayer '~

sing |Maya Software

sers/naasp/Documents/ maya projects/ characterModel/ images/
le name: Ch140Liff

Image size: 640 x 480 (8.9 x 6.7 inches 72 pixels/inch )

~  Color Management

Enable Color Management

File Output
File name prefix: (not set; us

Image format: | Maya IFF (iff)

Frame/Animation ext: | name.ext (Single Frame) ~

Use custom extension

Version Label

Frame Range

Renderable Cameras

Dept

¥ Image Size

FIGURE 14.6 TheRenderSettings
window’s Common tab

w

You need to address several settings on this tab. In the File Output
section, type the name you want to use for your image files in the
File Name Prefix field. Any name that makes sense to you is fine, and
shorter is better.

4. In the Image Format list box, switch the file type to Targa.
5. In the Frame/Animation Ext field, select name#.ext.

6. In the Frame Padding field, set the number to 2. All these changes
are shown in Figure 14.7.

7. In the Frame Range section, set End Frame to 20, as shown in
Figure 14.8.
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anNna

Edit Presets Help

Render Settings

Render Layer masterLayer =

Render Using [Maya Software -

Common  Maya Software
Path: [Users/naasp/Documents/ maya/projects/characterModel fimages/
File name: dance

To: dancel0.iga
Image size: 640 x 480 (8.9 x 6.7 inches 72 pixels/inch )

¥ Color Management

Enable Color Management

File Output
File name prefix: dance

ar: Targa (tga)

n ext: |name#.ext

dding: 2]

Version Label
Frame Range
Start frame: 1.000
End frame: 10.000

By frame: 1.000

Skip existing frames

Renumber frames

Renderable Cameras

Renderable C

Alp

¥  Frame Range

Start frame: 1.000

xisting frames

nber frames

FIGURE 14.8 FrameRange
section

8. In the Renderable Cameras section, set Renderable Camera to cam-
eral, and make sure Alpha Channel (Mask) isn’t selected, as shown in
Figure 14.9.

¥ Renderable Cameras

able

FIGURE 14.9 Renderable
Cameras section
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Targa files are good-
quality images and
render fairly quickly.
The namett.ext choice
uses the name you
selected, the frame
number, and the

. tga extension as
the filename. Frame
padding is the number
of digits in the frame
number and should
always be the same as
the number of digits in
the last frame of your
scene.

You're rendering only
20 frames because
frame 21 is the same
as frame 1. Including
frame 21 would cause
ashort pause in the
playback loop.
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When rendering, you
always want to render
individual frames,

not a movie file. If
problems occur during
arender, and you're
rendering individual
frames, you will only
have to re-render a few
frames. If you render
toa movie fileand run
into a problem, you
have to re-render the
entire scene.

Chapter 14 « Rendering and Compositing Your Scene

9. Click the Maya Software tab. In the Anti-Aliasing Quality section, set
Quality to Production Quality, as shown in Figure 14.10. Click the
Close button.

masterLaver -
ing 'Maya Software -
Common | Maya Software

~  Anti-aliasing Quality

Frodiciion aualy

Highest quality =

FIGURE 14.10 Anti-Aliasing Quality
section

Running a Batch Render

With all your settings in place, it’s time to let your Autodesk® Maya® software
generate the final frames you'll use to create your movie file. Follow these steps
to run the batch render:

1. In the Rendering menu set, choose Render > Batch Render >
Option Box, as shown in Figure 14.11.

Render Toon Stereo Paint EE

Render Current Frame o
Redo Previous Render

IPR Render Current Frame o
Redo Previous IPR Render

Test Resolution >

Run Render Diagnostics

Set NURBS Tessellation o
Batch Render =]
Cancel Batch Render

Show Batch Render

Kuisiact ' i o

FIGURE 14.11
Selecting the Batch Render
option

2. The Batch Render Animation window opens, as shown in Figure 14.12.
Make sure Use All Available Processors is selected, and then click the
Batch Render and Close button.
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ann Batch Render Animation

v Use all available processors

FIGURE 14.12 BatchRender
Animation window

3. The render process begins. You can track the progress of the render
in the message window at the lower right of the interface window, as
shown in Figure 14.13.

FIGURE 14.13 Renderprogress

4. When the render is complete, you see the message shown in
Figure 14.14. With all your frames rendered, it’s time to put your
movie file together.

No Character Set =

=]

FIGURE 14.14 TheRenderingCompleted message

Finding Your Frames

When you render your frames, Maya automatically puts them into the images
directory of the project directory your scene is in. You can verify that your
frames are in the images directory by going to your documents directory and
then navigating to maya > projects, selecting the project directory your scene
is using, and navigating to the images directory.

Performing Compositing

Compositing is a deep and complex subject, beyond the scope of this book.
Generally speaking, compositing refers to taking individually rendered scene ele-
ments and combining them into a finished image. For our purposes, compositing
means taking individual rendered frames and turning them into a movie file.
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Compositing Your Frames

This procedure uses MPEG Streamclip to composite the rendered frames. MPEG
Streamclip is a freeware application that works on both Mac and Windows com-
puters. It’s available for download at www.squaredS.com/. Follow these steps to
perform the compositing:

1. Download, install, and launch MPEG Streamclip. The interface is
shown in Figure 14.15.

GEC It 200020

FIGURE 14.15 MPEGStreamclip interface

2. Choose File > Open Files, as shown in Figure 14.16.

I5'8 Edit List Enigma Altair Wind
Open Files...
Open URL...
Open DVD...
Close

Show Stream Info

Save Ac 22g

FIGURE 14.16
Open Files menu item
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3. The Open Files window opens. Change the drop-down list at the bot-
tom of the window to All Files. Navigate to the images directory for
your project, and select all the sequentially numbered images in the
directory, as shown in Figure 14.17. Click the Open button.

006 Open Files.
< » ) (321 = @) (&images W Q
[+ pevices [B dance0liga | T
A Maltimedia
B ioisk
4
Ml
P oeion
1 nanap
A Applications
[ Documents
b
£ e
2 ey
Qi
(3] Al Movies
(3] All images
(3] All Documents
gy
s
& Photos [¥ outuv.tga
B Movies & tmp
"
W

FIGURE 14.17 Selecting the rendered images

4. You may see a File Open Error: Unrecognized File Type alert window.
Click the Open Anyway button, shown in Figure 14.18.

g File apen error: unrecognized file type

FIGURE 14.18 Alertwindow

5. The frame sequence loads into MPEG Streamclip. To see a play-
back of your sequence, click one of the playback buttons, shown in
Figure 14.19.
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You can export to AVl if
you prefer that format.
The steps that follow
are the same.

Chapter 14 « Rendering and Compositing Your Scene

[
Playback buttons

FIGURE 14.19 Playbackbutton locations

6. Choose File > Export To QuickTime, as shown in Figure 14.20.

Open Files... 20
Open URL... ®U
Open DVD... 380
Close BW
Show Stream Info I

Save As. .. #S
Export to QuickTime... RE
Export to DV... XHE
Export to AVI... T+ RE
Export to MPEG-4... AHE
Evnart Audi,

FIGURE 14.20 ExportToQuickTime menuitem

7. The Movie Exporter window opens. Set Compression to H.264,
Quality to 100%, and Frame Rate to 15 fps, as shown in Figure 14.21.
Click the Make Movie button.
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MPEG Streamclip - Movie Exporter

Compression: | H.264 }#) (options... )
Quality: (] d
pEs
100% [ g-Frames
[ Limit Data Rate: Kbps
Sound: [ Uncompressed [§] (Stereo 18] [Auto BJ | 256 kbps
Frame Size: No scaling will be Frame Rate: 15}
O 640 x 480 (4:3) Fer (I Frame Blending
O 854 % 480 (16:9) (] Better Downscaling
@ 640 x 480 (unscaled)
O 720 x 576 (DV-PAL) Deselect for progressive movies
© 720 x 480 (DV-NTSO) M interlaced Scaling
O 1280 x 720 (HDTV 720p) >
© 1920 x 1080 (HDTV 10801 Reinterlace Chroma
Other: 320 x| X 240 | Deinterlace Video

Field Dominance: |_Upper Fieid First gy Use Upper F‘e'dvﬁ“" foeal]

codecs except D!

Rotation: [ No *

Zoom: 100 '] % Xy 1 -] Center (1] 18 L]

[ Cropping: Top 0 Left O Bowom O Right O | Destinat

( Presets... ) ( Reset All (_Adjustments... )

Preview ) [ FastStart Cancel

FIGURE 14.21 MovieExporter window settings

The Create New MOV File window opens. Type in a name for your
movie, and select a location for the movie to be saved to, as shown in
Figure 14.22. The desktop is often a good choice, because it makes
the movie easy to find. Click the Save button.

Create New MOV File

Save As: [danceClip] &

Where: | ] Desktop =)

Cancel )

FIGURE 14.22 (reate New MOV File window

An Export Preview window opens briefly as MPEG Streamclip
compiles the movie. When the window closes, your clip is ready for
viewing. Navigate to the location where you saved the file, and open
it in your player of choice. Figure 14.23 shows the movie opened

in QuickTime Player 7. Click Play, and enjoy the results of all your
hard work!
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FIGURE 14.23 MOVfileinamovie player

Using Other Compositing Options

Any software that can create movie files out of individual images can be used to
composite rendered frames. Some of these options are listed here:

QuickTime 7 Pro  An upgrade from the QuickTime Player, QuickTime 7 Pro
is available from the Apple website and is a handy, simple-to-use compositing
tool. Creating a movie in QuickTime 7 Pro is similar to the process you used in
MPEG Streamclip. It runs about $30 and is well worth the money.

After Effects A leading compositing tool published by Adobe, After Effects
can do simple composites as well as complex effects. It handles multiple com-
posite layers well and allows you to apply effects and make changes to various
aspects of your frames. The learning curve is initially pretty steep, but it’s good
software to know.

Final Cut/Premiere Apple’s Final Cut (Mac) and Adobe Premiere (PC) are
video-editing programs, but they’re both capable of loading frame sequences
and exporting movie files. Using one of these packages to do a simple composite
as you just did is a bit of overkill, but if you know the software and have it avail-
able, it’s an option.
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THE ESSENTIALS AND BEYOND

In this chapter, you created the final version of your character by smoothing the low-resolution
mesh, rendered your final frames, and composited the frames into a playable movie file. Your
project is complete!

ADDITIONAL EXERCISES

» When you applied the smoothing to your character, Maya created a smoothing node at the
top of the input stack for the mesh. If you click the model and go to the Channel Box, it’s
listed as polySmoothFace under the Inputs list. Click polySmoothFace, and the node’s chan-
nels appear. The Divisions channel is set to 2, the number of divisions you inputted earlier
in the chapter. To return your model to its low-resolution state, change 2 to 0. Divisions can
be set as high as 4, although 2 is usually sufficient for a good-looking model.

» Tryrendering your scene again with a different file type selected for the individual frames,
and compare the file sizes and image quality. Targa is a good all-around choice, but some-
times a PNG file or even a JPEG might be a better choice for your project.
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APPENDIX A

Autodesk® Maya®
2014 Certification

Autodesk® certifications are industry-recognized credentials that can
help you succeed in your career—providing benefits to both you and your
employer. Getting certified is a reliable validation of skills and knowledge,
and it can lead to accelerated professional development, improved productiv-
ity, and enhanced credibility.

This Autodesk Official Press book can be an effective component of your
exam preparation for the Autodesk Maya 2014 Certified Professional exam.
Autodesk highly recommends (and we agree!) that you schedule regular
time to prepare; review the most current exam preparation roadmap avail-
able at www.autodesk.com/certification; use this book; take a class at an
Authorized Training Center (find ATCs near you here: www. autodesk.com/atc);
and use a variety of resources to prepare for your certification, including
plenty of actual hands-on experience.

Cg;}gg:it‘jg" To help you focus your studies on the skills you need for this exam, the
following table shows objectives that could potentially appear on an exam
and in what chapter you can find information on that topic—and when you
go to that chapter, you'll find certification icons like the one in the mar-
gin here. This book gives you a foundation for the basic objectives covered
in the exam, but you'll need further study and hands-on practice to learn
the remaining objectives and complete and pass the Professional exam.

For further study, see Mastering Autodesk Maya 2014 (www.sybex.com/go/
masteringmaya2014).

Please refer to www.autodesk.com/certification for the most current
exam roadmap and objectives.

Good luck preparing for your certification!
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TABLE A.1 Autodesk Maya 2014 Certified Professional exam topics and objectives

Topic Learning Objective Chapter

Animation Analyze the animation of an Chapter 2
object using the Graph Editor

Constrain an object to a path Not covered

Create a path animation Not covered
and evaluate an object along

the path

Edit animation curves using Chapter 2
the Graph Editor

Identify the constraint used Not covered

for an animation

List constraint types Not covered

Locate the value of keys in Not covered
the Time Slider

Use animation passes and Chapter 2
animation editors

Cameras Differentiate camera types Not covered
Edit FOV (Field of View) Chapter 11
Explain Near and Far Clip Not covered

Planes for your camera

Identify controls for trans- Chapter 11
forming the camera
Compositing Demonstrate how to compos-  Not covered

ite multiple layers together

(Continues)
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TABLE A.1 (Continued)

Learning Objective

Chapter

Data Management/ Differentiate common file Chapter 14
|nter0perab||ity types and usages
Use the Import feature to Not covered
import model data
Dynamics/Simulation Differentiate rigid body Not covered
dynamics from alternate ani-
mation techniques
Explain how to control a soft Not covered
body simulation
Identify and describe the Not covered
behavior of a soft body
Identify nConstraint member-  Not covered
ship properties
Identify rigid body properties  Not covered
Use soft body simulation tools  Not covered
Effects Identify an atmosphere effect ~ Not covered
Identify an event Not covered
Identify and use physical Not covered
fields
Identify important attributes ~ Not covered
of OpticalFX
Identify particle render types  Not covered
Identify particle systems Not covered
Use particle system tools Not covered

(Continues)
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TABLE A.1 (Continued)

Topic Learning Objective Chapter

Lighting Describe focus attributes on Not covered
depth map
Differentiate light types Chapter 13
Differentiate Depth Map shad-  Chapter 13
ows from Raytrace shadows
Describe how to use Look Chapter 13
Through Selected to place
lightsin a scene
Identify the specular compo- Not covered
nent of a light

Materials/Shading Describe how to fix textures Not covered
that move on animated/
deforming surfaces
Identify how to apply 2D Chapter 6
textures
List available materials (Blinn,  Not covered
Phong, Lambert)
Indicate the specular shading  Not covered

attributes that are specific
to Blinn

(Continues)
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TABLE A.1 (Continued)

Topic Learning Objective Chapter

Modeling Explain the typical workflow Chapter 4
for edge loop modeling

Identify the typical work- Not covered
flow for subdivision surface
modeling

Identify the type of Boolean Not covered
operation performed on the
objects

Use object creation and modi-  Chapters 3,4, 5
fication workflows

Use polygon modeling tools Chapters 3,4, 5

Use Boolean Not covered

Rendering Describe raytrace/scanline Not covered
quality settings

List and differentiate Not covered
renderers

Describe the functionality of Chapter 13
render preview within IPR

Indicate the rendering set- Not covered
tings that change when the
NTSC preset is enabled

(Continues)
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TABLE A.1 (Continued)

Topic Learning Objective Chapter

Rigging/Setup Describe options for using the ~ Chapter 8
Blend Shape deformer

Identify bones Chapter 8
Identify options for editing Not covered
rigid skin

Identify options for editing Chapter 9

smooth skin

Use Weight Table Not covered
Scene Assembly/ Describe how to import files Not covered
Pipeline Integration while preserving scene data

Describe how to improve scene  Not covered
organization by using Search
and Rename operations

Scripting Apply (run) scripts Not covered
Execute basic scripts Chapter 5
Create and run scripts Chapter 5

Describe how to add syntaxto  Not covered
ascript

Ul/Object Management Describe and use object Not covered
transformations

Describe how to display safe Chapter 12
frames

Describe viewport configura- ~ Chapter 1
tion and ViewCube navigation

Identify the purpose and ben-  Chapter 10
efits of freezing transforma-
tion data on objects
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Note to the reader: Throughout this index boldfaced page numbers indicate primary discussions of a topic.
Italicized page numbers indicate illustrations.

NUMERALS extruding, 50
joint chains for, 157-162, 160
2D images, from 3D scenes, 255-261 UVs for. 121
2D space, UV space for, 117 Assign New Material window, 115, 215

Attribute Editor, 111, 130
for light, Illuminates By Default, 249

A loading color map in, 131

Adobe Photoshop shader name change in, 113, 114
for color map, 128 for texture, 216
for texture mapping, 126, 127 AVI movie, 31

Adobe Premiere, 266
After Effects, 266
Alpha Channel (Mask), 259 B

animation Backface Culling setting, 80

of bouncing ball, 18-24 ball, creating, 19-21, 27

of character, 226-235 Batch Render Animation window, 260

breakdown poses, 231-232 batch rendering, 260-261, 261
polishing, 233-235 bending, geometry to support, 91-95
pop-thru, 226-230 Blend Shape window, 145

keyframes for, 21-24 blend shapes, 135-137

playblast creation, 31-34 applying to base model, 146

principles, 28-31 for character face, 139-143

realistic, 233 interface, 144-146

setup for, 221-226 names for, 141

Animation menu set, 144 and skeleton, ordering, 135-136
Skeleton

bones. See also joints

IK Handle Tool, Option Box, 187 large end of geometry, 166
Joint Tool, 150 bouncing ball, animation of, 18-24

Skin, Bind Skin, Smooth Bind, Option Box, 168 box modeling of character, 45-66

Animation Preferences, 222 breakdown poses, 231-232

Apple Final Cut, 266 breaking down movement, reference animation
arm footage for, 236
edge loops, 59 brush icon, for painting weights, 179
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camera « cylindrical projection

C

camera
creating, 222-223
locking down, 224-226, 226
Camera Settings menu, 18
camera window, view manipulation tools, 224
cameral view, 223
casting shadows, 250-251, 251
chains. See joint chains
Channel Box, 41, 41
after deleting modeling history, 107
Inputs, 106
Channel Box/Layer Editor, 8, 8
stretch values, 30
channels for camera, selecting, 225
characters. See also joint chains
adding eyeballs, 100-102
animation of, 226-235
breakdown poses, 231-232
polishing, 233-235
pop-thru, 226-230
applying color map, 128-132
box modeling of, 45-66
controls setup for, 198-199
connecting, 199
deformers, creating, 137-143
edge loops for bending, 91-95
mirroring, 102-105
model clean-up, 96-97
position, positive Z axis and, 108
positioning for rigging, 98-100
refining geometry, 55-56
shaping, 65-66

clavicle joint, connecting with spine joint, 167, 167

clearing modeling history, 106-107, 137
closing windows, 10
color, 109. See also surfacing
Color History window, 112, 115
color map
applying to character, 128-132
creating, 126-128

loading in Attribute Editor, 131
in Photoshop, 128
Combine menu item, 87
commands, repeating, 108
Common Material Attributes, 112
compositing, 261-266
frames, 262-265
compression for movie export, 264
connecting joint chains, 165-167
Constrain menu, Pole Vector, 195
constraining movement to one axis, 7
controls setup
for character, 198-199
connecting, 199
connecting IK chains to handle, 192-193
creating external handle, 190-192
for legs, 186-196
for torso, 196-197
connecting, 197-198
Corel Painter, for texture mapping, 126
Create menu
Cameras, Camera, 222, 223
Lights, Spot Light, 245
Locator, 194, 194
NURBS Primitives
Circle, 190
Interactive Creation, 790, 190-191
Polygon Primitives
Cube, Option Box, 42, 217
Cylinder, Option Box, 213
Interactive Creation, 19
Plane, Option Box, 206
Sphere, 7, 20
Create New MOV File window, 265
Create Polygon Sphere menu choice, 101

Create Render Node window, 128, 129, 208, 215, 215

crosshair cursor, 188

cube, as starting point for model, 42, 43
Custom Polygon Display Options window, 80
custom shelves, creating, 199-203

cycle in animation, 22, 226

cylindrical projection, 134
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D

default Maya window, 3
default UV layout, 118
deformations, adding geometry for, 91-95
deformers
creating for character, 137-143
joint influence on, 173-174
order of, 135-136
deleting
edges, 70
faces, 55, 56
history, 106-107, 137
depth map shadows, 250
details, adding, 80-88
direction changes, breaking tangents for fast,
26-28
directional light, 241, 242
directories for projects, 15
for rendered image, 261
Dope Sheet, 233
downloading, reference images, 39
duplicating, 108

E

ear, extruding and scaling polygon for, 84, 84-85
edge loops, 56-59, 58, 59, 69-79
adding for elbow, 92
around eye socket, 78
building, 72-79
for face, 70
edges, 36, 36
adjusting, 80-88
deleting, 70
selecting, 60, 63, 64
setting points, 62
Edit menu
Delete By Type, History, 107
Duplicate Special, 108
elbow
edge loops for, 92

joint weight changes, 177-180, 179

unpainted vs. painted verts, 180
environment. See rooms
Esc, to stop playback, 24
exiting Insert Edge Loop tool, 78
Export Preview window, 265
exporting UV layout image, 125
external control handle, creating, 190-192
extruding

arm, 50

eye socket, 78, 78

faces, 43-45

fingers, 51-55, 52, 53

foot, 48

hand, 51

legs, 47

nose, 81, 82

torso, 46
eye socket

edge loops for, 136, 137

extruding, 78, 78
eyeballs

adding, 100-102

changing surface, 115, 116

creating second, 108

parenting to skeleton, 170-171
eyebrows

blends for, 143

creating, 8688, 87

F

face of character
blend shapes for, 135-143
deformer planning, 138
edge loops for, 70

Face selection mode, 78

faces, 35, 36. See also polygons
extruding, 43-45
scaling, 46
selecting single, 47

file management, 15-18
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File menu hardware texturing, turning on, 210
Export To QuickTime, 264 head
New Scene, 15, 39 joint for, 151
Open Files, 262 parenting eyes to, 170-171
Project Window, 16 Help files, 2
Save Scene, 21 hiding floor and walls, 213, 228
File Open Error: Unrecognized File Type alert hip, connecting with pelvis joint, 165-166
window, 263 history, deleting, 106-107, 137
fill light, 239, 239, 246 Hotbox, 9, 9
turning off, 248 Hypershade window, 109-114, 110
Final Cut (Apple), 266
fingers
edge loops for, 94 |

extruding, 51-55, 52, 53
joints for, 158-159, 159
FK (forward kinematics), 185
Flip UVs Options window, 123
follow-thru, 233
foot, extruding, 48
forward kinematics (FK), 185
four-view window, 3
Frame padding, 259
frames, compositing, 262-265
Freeze Transformations command, 100, 191
for walls, 207

icon fonts, for controls, 203
IK (inverse kinematics), 156, 186
IK (inverse kinematics) chains
connecting to control handle, 192-193
creating, 186-189
IK Handle Tool, 187
illumination, removing, 252
Image Center Z value, 40
importing
PSD File, 128
reference images, 39, 39
in tangents, Auto setting, 231
inbetweening, 230

G Insert Edge Loop tool, 56-59, 57, 77

exiting, 78
geometry, adding for deformations, 91-95 intensity of lighting, 247-249
GIMP (GNU Image Manipulation Program), for Interactive Creation, 101, 206
texture mapping, 126 turning off, 19
Granite attribute, settings, 216 Interactive Normalize Weights, 178
Graph Editor interpolation, 21
movement in, 24-28 tangents for, 24
Translate Y in, 25 inverse kinematics (IK), 156, 186
grayscale surface, 174
J
H - .
joint chains, 148-162
hand for arm, 157-162
extruding, 51 connecting, 165-167
joints for, 158 for leg, 154-156
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mirroring, 162-163, 164
viewing, 186

joints. See also weighting joints
connecting to model, 168-171
how they work, 147
influence on deformers, 173-174
names for, 153
parenting, 166
system setup, 147

JPEG file, 267

K

Keep Faces Together option, 43, 53
key light, 238, 239
key tangents, setting, 221-222
keyframes, 3, 21-24
kinematics, 185

inverse (IK), 156, 186

L

lambert surface, creating, 110, 111
large end of bone geometry, 166
legs

controls setup, 186-196

edge loops for, 59, 93

extruding, 47

joint chains for, 154-156
lighting, 237

casting shadows, 250-251, 251

intensity of, 247-249

linking, 252-253

Maya lights, 241-243

negative values on, 252

placing, 244-246

switching between, 247

three-point, 238, 238-240
linking lighting, 252-253
low-resolution render, 31

M

Maintain Max Influences setting, 174
manipulating objects, 5-8
manipulator handles, enlarging or reducing, 7
marking menu, 9, 9, 114-116

Assign New Material, 7114, 114

for table, 215

Edge, 71

in UV Editor, 122
Max Influences setting, 171, 174
Maya Embedded Language (MEL) script, 102-103
Maya interface, 2

range slider, 4, 4

shelves, 5, 5

time slider, 3, 3

playback head, 22

Toolbox window, 4, 4

ViewCube, 6-7, 7

views, 2—3

windows, 8-10
Maya lights, 241-243
Maya Preferences window, 10
MEL. See Maya Embedded Language (MEL) script
MEL window, 103, 103
memory, for texture map display, 132
merge threshold, for Mirror function, 105
Merge Vertices Options window, 96, 97
Mirror Joint Options window, variable

names in, 163

Mirror Options window, 104
Mirror Skin Weights Options window, 183-184, 184
mirroring

joint chains, 162-163, 164

model, 102-105

troubleshooting, 108
model building, 37-38

box modeling of character, 45-66

clearing history, 137

connecting joints to, 168-171

cube, 42, 43

duplicating, 139, 140, 142

mirroring, 102-105

smoothing, 256-257
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modeling tools, 38—45

Modify menu, Freeze Transformations, 191,

195, 197
for walls, 207
mouth
blend shapes for, 139, 143
edge loops for, 76-77, 137
extruding interior of, 78
surface for, 133
Move Pivot tool, 99-100
Move tool, 7,21, 21, 98
for positioning joints, 152
movement, in Graph Editor, 24-28
Movie Exporter window, 264, 265
movie file, rendering, 260
movie player, 266
moving
UV shell, 120
views, 5—8

N

names
for arm chain joints, 161
for joints, 153
for legs, 154-155
for lights, 247
for projects, 16
for script button, 202
for shelves, 199
variables for, 163164
neck
edge loops for, 94
joint for, 151
New Shelf menu, 199
Ngons, 38, 38

Split Polygon tool to break up, 72

Normalize Weights setting, 178
nose, extruding, 81, 82
NURBS Primitives
circle, 190-192, 191, 198
creating, 196

Interactive Creation, 190, 190-191

o

Object mode, 98
objects

changing size, 7

lights on specific, 252-253, 254

manipulating, 5-8
offsetting, 234
Open Files window, 263, 263
opening Project window, 16
Option boxes, 10, 10
orthographic views, 219
out tangents, 221

Auto setting, 231
Outliner window, 247
overlap, 233

P

Paint Skin Weights tool, 174, 174
Add operation, 175, 175
Replace operation, 176, 176
panning view, 5
parenting joints, 166
pelvis joint
connecting control, 197-198
connecting with hip joint, 165-166
Persp/UV Texture Editor window preset, 118
Perspective view, 2, 40, 88, 216
for cube bottom, 44, 44
Shading, Hardware Texturing, 131
Photoshop
for color map, 128
for texture mapping, 126, 127
Pivot point Move tool, 193
Planar Mapping Options window, 119, 119, 218
Playback buttons, 264
playback, Esc to stop, 24
playblast, creating, 31-34
Playblast Options window, 32
PNG file, 267
point light, 243, 244, 246
pole vector constraints, for rigging, 194, 194-196
Poly Count Heads-Up Display, 89
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polygon cube, 86
Polygon Cube Options window, 42, 42
Polygon Cylinder Options window, 213
Polygon Plane Options window, 206, 206
polygon sphere
for ball, 19
creating, 7
radius of, 20
Polygon Sphere Options window, 20, 20
polygon view, and smooth proxy view, 88
polygons, 35-36
adjusting, 8088
custom, 80
Ngons, 38, 38
quads, 37, 37
Polygons menu set, 71
Create UVs, Planar Mapping, Option Box,
119, 218
Edit Mesh
Delete Edge/Vertex, 60, 64, 71
Extrude, 44, 45
Insert Edge Loop tool, 56-59, 57, 77
Keep Faces Together, 43, 53
Merge, 97
Option Box, 96
Flip, 123
Mesh, Smooth, Option Box, 256
polys, 35. See also polygons
pop-thru, 226-230
timing, 230-231
pose to pose technique, 221
positioning characters, for rigging, 98-100
Post-Infinity cycle button, 235
poster, 217-219, 219
Pre-Infinity cycle button, 235
Preferences window, 10
Settings, Animation, Tangents, 222
Premiere (Adobe), 266
project directory, 15
for rendered image, 261
Project window, opening, 16
projection manipulator, 120
projects, names for, 16
props, 213-219

PSD File, importing, 128
Python, 103

Q

quads, 37, 37
QuickTime, 31
QuickTime 7 Pro, 266

R

radius, of polygon sphere, 20
range slider, 4, 4
ray trace shadows, 250
realistic animation, 233
reference animation footage, 236
reference images, 39
moving, 41
Relationship Editor window, 253, 253
Render Settings window, Common tab, 258
Render View window, Select A Region To Begin
Turning prompt, 248, 249
Renderer menu, High Quality Rendering, 216
rendering
batch, 260-261, 261
setting preferences, 257-260
Rendering menu set, Render
Batch Render, Option Box, 260
IPR Render Current Frame, 248
repeating commands, 108
resolution gate, turning on, 18-19, 222-223
rigging
basic concepts, 185-186
character positioning for, 98-100
deleting history before, 106
external control handle creation, 190-192
goal of, 203
pole vector constraints for, 194, 194-196
torso control setup, 196-197
rim light, 240, 240, 247
rooms, 205-219
floor and walls, 206-207
hiding, 213
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textures, 208-212
visibility, 214
props, 213-219

poster, 217-219, 219

table, 213-216, 214
Rotate Frame control, 219
Rotate tool, 7
Rotation Plane solver, 188

S

Save To File, for playblast, 32-33
Scale tool, 7
scaling, UV shell, 120
scene-file management, 15-18
scenes. See rooms
Script Editor window, 200-203

clearing history, 201

Save Script To Shelf button, 202
selected objects, zooming in to view, 6
selecting

edges, 60

front faces, 218

skeleton and mesh, 168

UV shell, 120, 123

views, 18-19
shaders, 109

creating, marking menu for, 114-116
Shading menu, X-Ray, 65
shadows

casting, 250-251, 251

softening edges, 251
shaping characters, 65—66
shell, 120
shelves, 5, 5

creating custom, 199-203
shoulder, edge loops for, 92
Show menu

Grid, 98

Polygons, 186, 190, 190
Single-Chain solver, 188
single-view window, 3
size

of joints, 151

of manipulator

of object, changing, 7
skeleton, 148. See also joint chains
and blend shapes, ordering, 135-136
completed, 167
parenting eyes to, 170-171
skinning, 168
Smooth Bind, 168-171
Options settings, 7169
Smooth Options window, 256, 256
smooth proxy view, and polygon view, 88
Solid Brush profile, 178
speed, of bouncing ball, 24
sphere. See polygon sphere
spine
connecting with clavicle joint, 166, 167
joint chain for, 148-152
spline tangents, adjusting, 25-26
Split Polygon tool, 60—64
to break up Ngons, 72
menu, 61
reactivating, 73
settings, 61
Settings window, 72
spot light, 242, 243
squash technique, 28-29
stopping playback, Esc key for, 24
stretch technique, 29-31
subdirectories, 17
surfaces
applying additional, 132-134
creating, 109-116
for eyeball, 115, 116
UV layout, 117-126
surfacing, 109
symmetrical object, modeling one half, 55-56

T

table, 213-216, 214
tangents
adjusting spline, 25-26
breaking for fast direction changes, 26-28
for interpolation, 24
selecting all, 231
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Targa files, 259

texture maps, 109, 117, 126-134
selecting, 209
troubleshooting, 132

textures, for floor and walls, 208-212, 212

.tga file extension, 259
three-point lighting, 238, 238-240
threshold, for merging vertices, 97
thumb, 54, 54
thumbnails, 227
tileable textures, 208
tiling number, for texture, 210
time slider, 3, 3
playback head, 22
timing, pop-thru, 230-231
Tool Settings window, 10
Current Solver, 187
Lock button, 182
Toolbox window, 4, 4
torso
connecting control, 197-198
edge loops for, 95
extruding, 46
joint chain for, 152

setting up rigging control, 196-197

Translate Y, 25

tangent for, 25
triangles (tris), 38
troubleshooting

mirroring, 106, 108

texture map appearance, 132
Tumble tool, 5

U

UV Editor, marking menu in, 122
UV layout, 117-126
exporting image, 125
UV projections
completed, 125
types, 134
UV shell, 120, 123

UV Snapshot menu, 125
UV Snapshot window, 126, 126
UV space, 117, 117

revise, 122

\

variables, for names, 163-164
vertex mode, 82
vertices, 35, 36

adjusting, 65, 65-66, 66, 80—88

aligning to 0 (zero) point on X axis, 102

in blend shape, 140, 141
joints and, 147
numbers assigned to, 136
removing extra, 96
view manipulation tools, 224
View menu

Camera Settings, Resolution Gate, 18
Shading, Wireframe on Shaded, 70

view planes, setting up, 39-41
view window, 223
presets, 118
ViewCube, 6-7, 7
views
for joint chain, 148, 148
moving, 5-8
selecting, 18-19

visible objects, zooming in to view, 6

w

Web, search for tileable textures, 208

Webdings, for controls, 203
weighting joints, 173
adjustments, 174-184
displaying, 174
importance of, 173-174
locking, 182, 182
mirroring, 183-184
painting weights, 176-183, 177
strategies for, 175
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Window menu wrist
Animation Editors edge loops for, 93
Blend Shape, 145 painting verts, 181

Dope Sheet, 233
Graph Editor, 24, 230, 231
Outliner, 247 X
Playblast, Option Box, 32
Rendering Editors
Hypershade, 109, 110
Render Settings, 257
Settings/Preferences, Preferences, 10
windows, 8-10
closing, 10
Wingdings, for controls, 203
Wood attribute, settings, 216 zooming views, 6

X axis, aligning vertices to 0 (zero) point, 102
X-Ray mode, 101, 749, 149

for points in polygon, setting, 73
X-Ray shading, 65

y4
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